Firefox interface is horribly laggy in a variety of situations, with delayed scrolling and typing

Bug #990997 reported by skalka on 2012-04-29
294
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Invalid
High
firefox (Ubuntu)
High
Unassigned
Declined for Precise by Chris Coulson
Declined for Trusty by Chris Coulson
Declined for Vivid by Chris Coulson
Declined for Wily by Chris Coulson
Declined for Xenial by Chris Coulson

Bug Description

Typing is extremely slow in typing in multiline fields. This happens with the text field on twitter, google+, blogger. Usually there's a big delay between typing and charachters to appear and cpu works a lot. Everything works fine with other browsers like chrome or opera. Disabling Javascript doesn't solve the issue even because withut js it's impossibile to load text fields that make a large use of it. My pc is equipped with a nvidia 8400gs m video chip. Let me know if more informations are needed.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: firefox 12.0+build1-0ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
NonfreeKernelModules: nvidia
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: skalka 1958 F.... pulseaudio
BuildID: 20120423122624
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf4500000 irq 48'
   Mixer name : 'Conexant CX20549 (Venice)'
   Components : 'HDA:14f15045,103c30cd,00100100'
   Controls : 18
   Simple ctrls : 9
Channel: release
Date: Sun Apr 29 12:02:14 2012
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.100 metric 2
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=12.0/20120423122624 (Running)
RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:
 Apr 29 09:11:28 Renato wpa_supplicant[910]: WPA: Group rekeying completed with 00:18:39:ab:f3:0e [GTK=CCMP]
 Apr 29 09:21:01 Renato kernel: [ 2004.363531] cfg80211: Found new beacon on frequency: 2467 MHz (Ch 12) on phy0
 Apr 29 10:11:28 Renato wpa_supplicant[910]: WPA: Group rekeying completed with 00:18:39:ab:f3:0e [GTK=CCMP]
 Apr 29 10:32:47 Renato kernel: [ 6310.072316] process `skype' is using obsolete setsockopt SO_BSDCOMPAT
 Apr 29 11:11:28 Renato wpa_supplicant[910]: WPA: Group rekeying completed with 00:18:39:ab:f3:0e [GTK=CCMP]
dmi.bios.date: 12/01/2008
dmi.bios.vendor: Phoenix
dmi.bios.version: F.2E
dmi.board.name: 30CE
dmi.board.vendor: Wistron
dmi.board.version: 80.52
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenix:bvrF.2E:bd12/01/2008:svnHewlett-Packard:pnHPPaviliondv2500NotebookPc:pvrF.2E:rvnWistron:rn30CE:rvr80.52:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv2500 Notebook Pc
dmi.product.version: F.2E
dmi.sys.vendor: Hewlett-Packard

skalka (skalka) wrote :
Gert van Dijk (gertvdijk) wrote :

Had the same issue here. Solved it by disabling all addons except the Ubuntu default addons. Might figure out later which add on was the cause.

iGadget (igadget) wrote :

In my situation (which is the situation Gert is referring to) the add-on causing the slowness was "Translate This! 1.8". Disabling it restored the normal speed experience. Do you have this add-on installed?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed

One important cause of this bug is an issue in the default GTK theme:
<https://bugzilla.mozilla.org/show_bug.cgi?id=563887>

Installing a different theme improves performance a lot. One good default is:
<https://addons.mozilla.org/en-US/firefox/addon/os-x-yosemite/>

summary: - Slow typing in Firefox
+ Slow performance in Firefox, with slow typing
tags: added: trusty wily xenial
tags: added: vivid
Changed in firefox (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
summary: - Slow performance in Firefox, with slow typing
+ Slow performance in Firefox interface, with slow typing
summary: - Slow performance in Firefox interface, with slow typing
+ Slow performance in Firefox interface, with delayed typing

Enabling add-ons like Adblock Plus or WOT, which require certain processing, also makes Firefox to slow down noticeably in a Intel i5, and sluggish in a Intel Core 2 Quad.

This problem is triggered in a variety of situations, but the root cause is that the interface needs to be separated from the engine, and take advantage of multi-threading.

summary: - Slow performance in Firefox interface, with delayed typing
+ Firefox interface is horribly laggy in a variety of situations, with
+ delayed scrolling and typing
Changed in firefox (Ubuntu):
importance: High → Wishlist
importance: Wishlist → High
Changed in firefox:
importance: Unknown → High
status: Unknown → New
GizmoChicken (gizmochicken) wrote :

As has been pointed out above, these problems are triggered in a variety of situations. But for me, the most common culprits have been unwanted scripts running in the background. I've found that running "NoScript Security Suite" helps immensely. "NoScript Security Suite" can be found here:

https://addons.mozilla.org/en-US/firefox/addon/noscript/

After activating NoScript, you'll need to allow certain scripts to run for some sites to function properly.

information type: Public → Public Security
Changed in firefox:
status: New → Invalid
Paul White (paulw2u) wrote :

We are sorry that we do not always have the capacity to review all reported bugs in a timely manner. This bug was reported some time ago and there have been many changes in Ubuntu and Firefox since that time.

Does anyone still see a problem related to the one that was reported using currently supported versions of Firefox and Ubuntu? Please let us know if you do otherwise this report can be left to expire in approximately 60 days time.

Thank you for helping make Ubuntu better.

Paul White
[Ubuntu Bug Squad]

Changed in firefox (Ubuntu):
status: Triaged → Incomplete
Paul White (paulw2u) wrote :

Report did not expire due to bug watch
Upstream report closed "RESOLVED WORKSFORME" on 2018-04-10
No reply to comment #9 so closing

Changed in firefox (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.