[regression] default search engines are readded (keywords wiped) with upgrade

Bug #936920 reported by LAZA on 2012-02-20
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned
iceweasel (Debian)
Fix Released
Unknown

Bug Description

Original Bug:
https://bugs.launchpad.net/firefox/+bug/428306

i had detected, that the original search engines are added with an update!

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: firefox 10.0.2+build1-0ubuntu0.11.04.1
ProcVersionSignature: Ubuntu 2.6.38-13.55-generic 2.6.38.8
Uname: Linux 2.6.38-13-generic x86_64
NonfreeKernelModules: fglrx
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: frank 2290 F.... xfce4-volumed
 /dev/snd/controlC0: frank 2290 F.... xfce4-volumed
                      frank 2302 F.... pulseaudio
BuildID: 20120216100510
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe024000 irq 16'
   Mixer name : 'Realtek ALC889A'
   Components : 'HDA:10ec0885,1458a102,00100101'
   Controls : 38
   Simple ctrls : 21
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xfdffc000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Channel: release
Date: Mon Feb 20 13:10:15 2012
ForcedLayersAccel: False
IncompatibleExtensions:
 Leo Search - ID={c666c018-6409-4479-afa3-68e4129e7eff}, Version=1.1.0, minVersion=3.5, maxVersion=8.*, Location=app-profile, Type=extension, Active=Yes
 NoScript - ID={73a6fe31-595d-460b-a920-fcc0f8843232}, Version=2.3, minVersion=1.9a2, maxVersion=1.9.6, Location=app-profile, Type=extension, Active=Yes
InstallationMedia: Xubuntu 10.04.2 "Lucid Lynx" - Release amd64 (20110215.1)
IpRoute:
 192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.101 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
 default via 192.168.0.1 dev eth0 proto static
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 vboxnet0 no wireless extensions.
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=10.0.2/20120216100510 (Running)
RfKill:

RunningIncompatibleAddons: True
SourcePackage: firefox
UpgradeStatus: Upgraded to natty on 2012-01-02 (48 days ago)
dmi.bios.date: 07/08/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F7c
dmi.board.name: GA-MA790GP-UD4H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF7c:bd07/08/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA790GP-UD4H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA790GP-UD4H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA790GP-UD4H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

LAZA (laza74) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Changed in iceweasel (Debian):
status: Unknown → New
Václav Šmilauer (eudoxos) wrote :

This bug keeps coming back. #858683 looks like a dupe of this, though it has been marked as fix released. Using up-to-date 12.04.

LAZA (laza74) wrote :

Sorry to say that so clear:
IT WAS NEVER FIXED!

There was an bug, that all the self-implemented search engines got lost AND all the standard back in (even if there all whiped out).
So half of the problem is corrected....

Changed in iceweasel (Debian):
status: New → Fix Released
Thomas Kluyver (takluyver) wrote :

This seemed to happen again with a recent Firefox update on 13.04.

E.g. I add a 'w' keyword for Wikipedia, so typing 'w Ubuntu' in the URL bar does a Wikipedia search directly. After each upgrade, the keyword is gone.

peT (pe44) wrote :

I can confirm this is still happening. For me only the default search engines are affected, meaning google.com, duckduckgo.com, ebay.com, amazon.com, twitter.com, wikipedia (english) and yahoo.com.
The must get readded as they also are listed on bottom in the list of search engines after every update AND more importantly are readded although I usually delete most of them anyway.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.