Fresh 10.04 upgrade, firefox won't run

Bug #933283 reported by RubeRad on 2012-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Upgraded to 10.04 from, I think it was 8.04? (it was pretty old). Everything seemed to go ok, except sound and firefox. I found some other web advice to do with fixing up alsa, so sound works now. But still firefox will not start.

Click the icon, error window "Your Firefox profile cannot be loaded. It may be missing or inaccessible."

Try to start from command line, same window, and the following error messages:

 (firefox:2781): GnomeUI-WARNING **: While connecting to session manager:
None of the authentication protocols specified are supported.
/home/tina/.esd_auth: Permission denied

I can check, and if /home/tina/.esd_auth actually exists, then I can remove it and try again, same result. Sometimes that .esd_auth reappears, sometimes it doesn't.

I have moved .mozilla off to .mozilla_old, afaik I have no profiles, still can't open. I tried all sorts of options for firefox, like -safe-mode, -ProfileManager, etc., all the same.

See als bug 23917 (https://bugs.launchpad.net/ubuntu/+source/gksu/+bug/23917), seems to be the same problem, never solved. One potential problem there was full disks, I don't think that's me:
> df -kh
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 9.2G 5.5G 3.3G 63% /
none 484M 280K 484M 1% /dev
none 488M 1.3M 487M 1% /dev/shm
none 488M 116K 488M 1% /var/run
none 488M 0 488M 0% /var/lock
none 488M 0 488M 0% /lib/init/rw
/dev/sda3 56G 34G 20G 63% /data
/dev/sda4 7.6G 6.7G 499M 94% /windoze

Based on some other webpage, I rm -rf /tmp/.esd-1001/, but that didn't help.

> uname -a
Linux starbuck 2.6.32-38-generic #83-Ubuntu SMP Wed Jan 4 11:13:04 UTC 2012 i686 GNU/Linux

> firefox -v
Mozilla Firefox 10.0.1

RubeRad (ruberad) on 2012-02-16
description: updated
RubeRad (ruberad) wrote :

OK, i got firefox up, but this is not a solution:

> sudo su
# firefox

works!

but

> sudo firefox

does not!

It is (obviously) not acceptable to have to run ffox as root...

Micah Gersten (micahg) wrote :

If you were running Firefox with sudo, you'll run into issues. Please run:
chown -R MYUSER:MYUSER ~/.mozilla
where MYUSER is your system user name. Then try running Firefox normally (firefox).

Changed in firefox (Ubuntu):
status: New → Incomplete
RubeRad (ruberad) wrote :

Thanks for checking in.

I already moved the old ~/.mozilla to ~/.mozilla_old, and none of my attempts have yet created a new ~/.mozilla (except when I managed to start up firefox as root, it probably created a /.mozilla, which I should probably look for and delete).

I'll double-check tonight though.

Another thing, I'll log in as a different user and try that; and I'll create a new user and try that.

RubeRad (ruberad) wrote :

I tried logging in as a different user; this user had no ~/.mozilla to remove, but trying to start firefox had the same behavior

Launchpad Janitor (janitor) wrote :

[Expired for firefox (Ubuntu) because there has been no activity for 60 days.]

Changed in firefox (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers