FTBFS on powerpc (again)

Bug #926495 reported by Ben Collins on 2012-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Unassigned
thunderbird (Ubuntu)
High
Unassigned

Bug Description

The yarr patch was removed in the last upload since it was supposedly fixed upstream. Apparently not quite right just yet. This build failure shows up now:

c++ -o jsanalyze.o -c -fvisibility=hidden -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux -DEXPORT_JS_API -DIMPL_MFBT -DJS_HAS_CTYPES -DDLL_PREFIX=\"lib\" -DDLL_SUFFIX=\".so\" -DNO_NSPR_10_SUPPORT -Ictypes/libffi/include -I. -I/build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/js/src -I. -I./../../dist/include -I./../../dist/include/nsprpub -I/build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/obj-powerpc-linux-gnu/dist/include/nspr -I/build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/js/src -I/build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/js/src/assembler -I/build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/js/src/yarr -fPIC -D_FORTIFY_SOURCE=2 -fno-rtti -pedantic -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -Wno-long-long -g -pthread -pipe -DNDEBUG -DTRIMMED -g -O3 -freorder-blocks -fomit-frame-pointer -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1 -D_FORTIFY_SOURCE=2 -DMOZILLA_CLIENT -include ./js-confdefs.h -MD -MF .deps/jsanalyze.pp /build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/js/src/jsanalyze.cpp
In file included from /build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/js/src/vm/RegExpObject.h:54:0,
                 from /build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/js/src/jsscriptinlines.h:53,
                 from /build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/js/src/vm/Stack-inl.h:49,
                 from /build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/js/src/jsinferinlines.h:50,
                 from /build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/js/src/jsanalyze.cpp:45:
/build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/js/src/yarr/pcre/pcre.h:49:18: fatal error: jstl.h: No such file or directory
compilation terminated.
make[6]: *** [jsanalyze.o] Error 1
make[6]: Leaving directory `/build/buildd/firefox-11.0~b1+build1/build-tree/mozilla/obj-powerpc-linux-gnu/js/src'

Not sure if the same problem happens on arm (still building).

Could I ask that next time a patch is removed that is known to be pertinent to successful building on powerpc that you let me do a quick build before upload? Will save us these round trips on the buildd (which is much slower, and tend not to work well as test build systems).

Thanks

Changed in thunderbird (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

Oh, the patch was disabled because it needs work. I knew that it didn't build on powerpc, and that was also clear on the upstream bug as well.

This is going to be a regular occurrence (every 6 weeks) because the JS engine changes fast, and powerpc is only a tier 3 platform upstream (which means that it gets no consideration upstream when making changes, and is only kept alive by distributions)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 11.0~b4+build1-0ubuntu1

---------------
firefox (11.0~b4+build1-0ubuntu1) precise; urgency=low

  * New upstream release from the beta channel (FIREFOX_11_0b4_BUILD1)

  * Update globalmenu-extension to 2.0.4
    - Add support for Firefox 12
    - Ensure we correctly hide dummy menu items
  * Fix LP: #915895 - Just set autoDisableScopes to 0. Other distributions
    are already doing this, and we already made this feature pretty much
    useless by allowing extensions in the application directory, so that our
    language packs aren't disabled by default
    - update debian/vendor.js
  * Fix LP: #926495 - Add patch based on one from bmo: #691898 to enable
    building on ppc again
    - add debian/patches/fix-build-failure-without-yarr-jit.patch
    - update debian/patches/series
  * Fix LP: #939657 - Don't call g_settings_new each time we create a HTTP
    channel. Doing this causes a dbus roundtrip, and results in us spamming
    the session bus unnecessarily
    - add debian/patches/avoid-dbus-roundtrip-for-httpchannel.patch
    - update debian/patches/series
  * Fix LP: #894166 - Make Firefox work with our system hyphenation patterns,
    and stop including our own
    - update debian/vendor.js
    - add debian/patches/dont-include-hyphenation-patterns.patch
    - update debian/patches/series

  [ Jamie Strandboge <email address hidden> ]
  * debian/usr.bin.firefox.apparmor.12.04: include p11-kit abstraction (only
    needed on 12.04). LP: #918973
 -- Chris Coulson <email address hidden> Fri, 24 Feb 2012 14:55:30 +0000

Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 11.0~b3+build1-0ubuntu1

---------------
thunderbird (11.0~b3+build1-0ubuntu1) precise; urgency=low

  * New upstream release from the beta channel (THUNDERBIRD_11_0b3_BUILD1)

  * Update globalmenu-extension to 2.0.4
    - Add support for Thunderbird 12
    - Ensure we correctly hide dummy menu items
  * Fix LP: #915895 - Just set autoDisableScopes to 0. Other distributions
    are already doing this, and we already made this feature pretty much
    useless by allowing extensions in the application directory, so that our
    language packs aren't disabled by default
    - update debian/vendor.js
  * Fix LP: #939657 - Don't call g_settings_new each time we create a HTTP
    channel. Doing this causes a dbus roundtrip, and results in us spamming
    the session bus and dbus-daemon using lots of CPU when updating mailboxes
    - add debian/patches/avoid-dbus-roundtrip-for-httpchannel.patch
    - update debian/patches/series
  * Fix LP: #926495 - Add patch based on one from bmo: #691898 to enable
    building on ppc again
    - add debian/patches/fix-build-failure-without-yarr-jit.patch
    - update debian/patches/series
  * Fix LP: #894166 - Make Thunderbird work with our system hyphenation
    patterns, and stop including our own
    - update debian/vendor.js
    - add debian/patches/dont-include-hyphenation-patterns.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Fri, 24 Feb 2012 14:46:13 +0000

Changed in thunderbird (Ubuntu):
status: Confirmed → Fix Released
Chris Coulson (chrisccoulson) wrote :

This still doesn't build. Someone else will need to take this if they want Firefox 11 to work on powerpc

Changed in thunderbird (Ubuntu):
status: Fix Released → Triaged
Changed in firefox (Ubuntu):
status: Fix Released → Triaged
Changed in firefox (Ubuntu):
status: Triaged → Fix Committed
Changed in thunderbird (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 11.0~b6+build1-0ubuntu1

---------------
firefox (11.0~b6+build1-0ubuntu1) precise; urgency=low

  * New upstream release from the beta channel (FIREFOX_11_0b6_BUILD1)

  [ Jamie Strandboge <email address hidden> ]
  * debian/usr.bin.firefox.apparmor.*:
    - allow access to statm and smaps for about:memory (LP: #911494)
    - allow read access to files in /opt (LP: #728485)

  [ Chris Coulson <email address hidden> ]
  * Update debian/patches/fix-build-failure-without-yarr-jit.patch
  * Fix LP: #926495 - Disable the SPS profiler on unsupported architectures
    - add debian/patches/no-sps-profiler-on-unsupported-archs.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Thu, 08 Mar 2012 16:15:52 +0000

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 11.0~b5+build1-0ubuntu1

---------------
thunderbird (11.0~b5+build1-0ubuntu1) precise; urgency=low

  * New upstream release from the beta channel (THUNDERBIRD_11_0b5_BUILD1)

  * Update debian/patches/fix-build-failure-without-yarr-jit.patch
  * Fix LP: #926495 - Disable the SPS profiler on unsupported architectures
    - add debian/patches/no-sps-profiler-on-unsupported-archs.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Thu, 08 Mar 2012 16:18:01 +0000

Changed in thunderbird (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers