Firefox 12 fails to build on Lucid x86_64 (../../../dist/include/nsCOMPtr.h:316: internal compiler error: in tree_nrv, at tree-nrv.c:143)

Bug #918763 reported by Chris Coulson on 2012-01-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned
Lucid
Critical
Unassigned

Bug Description

Firefox and Thunderbird 12 are failing on Lucid x86_64 with this error:

c++ -o HttpChannelParent.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include /build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/config/gcc_hidden.h -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES -DSTATIC_EXPORTABLE_JS_API -DMOZ_THUNDERBIRD=1 -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux -DEXCLUDE_SKIA_DEPENDENCIES -DOS_LINUX=1 -DOS_POSIX=1 -DIMPL_NS_NET -I/build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/netwerk/protocol/http/../../base/src -I/build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/xpcom/ds -I/build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/content/base/src -I/build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/content/events/src -I/build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/ipc/chromium/src -I/build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/ipc/glue -I../../../ipc/ipdl/_ipdlheaders -I/build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/netwerk/protocol/http -I. -I../../../dist/include -I../../../dist/include/nsprpub -I/build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/obj-x86_64-linux-gnu/mozilla/dist/include/nspr -I/build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/obj-x86_64-linux-gnu/mozilla/dist/include/nss -fPIC -fno-rtti -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -Wno-long-long -g -fno-exceptions -fno-strict-aliasing -fshort-wchar -pthread -ffunction-sections -fdata-sections -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks -fomit-frame-pointer -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/HttpChannelParent.pp /build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/netwerk/protocol/http/HttpChannelParent.cpp
/build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/netwerk/protocol/http/HttpChannelParent.cpp:338: warning: ignoring #pragma warning
In file included from ../../../dist/include/nsAutoPtr.h:48,
                 from ../../../dist/include/gfxPattern.h:46,
                 from ../../../dist/include/IPC/IPCMessageUtils.h:54,
                 from ../../../ipc/ipdl/_ipdlheaders/mozilla/net/PNecko.h:14,
                 from ../../../ipc/ipdl/_ipdlheaders/mozilla/net/PNeckoChild.h:9,
                 from ../../../dist/include/mozilla/net/NeckoChild.h:44,
                 from /build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/netwerk/protocol/http/nsHttp.h:60,
                 from ../../../dist/include/mozilla/net/HttpChannelParent.h:45,
                 from /build/buildd/thunderbird-trunk-12.0~a1~hg20120118r9213.84699/build-tree/mozilla/mozilla/netwerk/protocol/http/HttpChannelParent.cpp:41:
../../../dist/include/nsCOMPtr.h: In function 'nsQueryInterface do_QueryInterface(nsISupports*)':
../../../dist/include/nsCOMPtr.h:316: internal compiler error: in tree_nrv, at tree-nrv.c:143
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.4/README.Bugs> for instructions.

See https://launchpadlibrarian.net/90342632/buildlog_ubuntu-lucid-amd64.thunderbird-trunk_12.0~a1~hg20120118r9213.84699-0ubuntu1~umd1~lucid_FAILEDTOBUILD.txt.gz

Chris Coulson (chrisccoulson) wrote :

This is obviously a complete blocker for the Firefox 12 update

Changed in firefox (Ubuntu):
status: New → Invalid
Changed in firefox (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Critical
Chris Coulson (chrisccoulson) wrote :

(ie, on 24th April)

summary: - Firefox 12 fails to build on Lucid i386
+ Firefox 12 fails to build on Lucid x86_64
(../../../dist/include/nsCOMPtr.h:316: internal compiler error: in
tree_nrv, at tree-nrv.c:143)
description: updated
Chris Coulson (chrisccoulson) wrote :

The last good build of Thunderbird on Lucid x86_64 was 12.0~a1~hg20120103r9103.83671.

The first build confirmed with this failure is 12.0~a1~hg20120118r9213.84699.

That is a fairly wide window, but unfortunately, we aren't doing daily builds anymore for Lucid and there were other failures in between.

Chris Coulson (chrisccoulson) wrote :

Here we go:

Due to skipped revisions, the first bad revision could be any of:
changeset: 84424:63c3d103610c
user: Honza Bambas <email address hidden>
date: Fri Jan 13 16:36:03 2012 +0100
summary: Bug 621446 - investigation bug for crash at RecvRedirect2Verify, r=jduell

changeset: 84425:9fab07be5d36
user: Honza Bambas <email address hidden>
date: Fri Jan 13 16:36:03 2012 +0100
summary: Bug 717773 - Crash [@ SpdySession::LogIO], r=mcmanus

changeset: 84426:b605399234fc
user: Honza Bambas <email address hidden>
date: Fri Jan 13 17:04:15 2012 +0100
summary: Bug 621446 - Fixed red caused by changeset 63c3d103610c from bad member rename, r=bustage

So, it's basically http://hg.mozilla.org/mozilla-central/rev/63c3d103610c plus the bustage follow up: http://hg.mozilla.org/mozilla-central/rev/b605399234fc

Chris Coulson (chrisccoulson) wrote :

This is fixed now

Changed in firefox (Ubuntu Lucid):
status: Triaged → Fix Released
Miyur (mayur-nagekar) wrote :

I synced the latest source code and I still see this on 10.04 LTS. Does anyone how can I fix fix this ?
Thanks for your help.

Miyur (mayur-nagekar) wrote :

I upgraded to 12.04 LTS now. Isn't there any way to get this running on Lucid, Maverick, Natty or Oneiric ?

Honza Bambas (honzab) wrote :

Is there a chance you fix this by changing the build machine or build config?

I need to know till this Friday 1/27/2012 to land a potential fix on time on mozilla-central to not get this slip to mozilla-aurora, where fixes are harder to add to or remove from.

Is there any #ifdef I could use to just disable the pragma "O0" for you builds? That effectively disables the whole investigation patch.

Thanks.

Chris Coulson (chrisccoulson) wrote :

I guess you could test for gcc < 4.5, as it's only broken on < 4.5. In any case, we just reverted the patch for our own builds so that we can keep the builds going. This isn't really a problem for us, assuming that it's only a short-term thing. I don't want to create extra work for you

Honza Bambas (honzab) wrote :

Thanks for the info, Chris.

The patch is there only for debugging a hard to catch crash. It should go away after two cycles tops (I need to bump it to beta, since there are no crash-stat data from aurora (alfa)). The patch will also (very soon) land on aurora release channel.

Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package firefox - 11.0+build1-0ubuntu0.10.10.2

---------------
firefox (11.0+build1-0ubuntu0.10.10.2) maverick-security; urgency=low

  * New upstream stable release (FIREFOX_11_0_BUILD1)
    - see LP: #951250 for USN information

  * Rebuilt against updated gcc to fix LP: #931637
  * Ensure that the crash reporter is disabled if rebuilt by Ubuntu
    derivatives, as there will be no crash symbols for those
    - update debian/rules
  * Only add "Ubuntu" to the UA string when being built for Ubuntu
    - update debian/rules
  * Temporarily disable ipdl tests due to build failures. These aren't
    enabled upstream, anyway
    - update debian/config/mozconfig.in
  * Always set the update channel - not setting it at build-time on release
    builds breaks the extensions.checkCompatibility pref. The only things
    using it at runtime are nsBlocklistService, Test Pilot (beta + aurora)
    and the about dialog (where the channel is hidden anyway)
    - update debian/rules
    - update debian/firefox.install.in
  * Fix LP: #898883 - IPC xpcshell tests hang the buildd's. Give all
    xpcshell tests an X display, as plugin-container won't work without one
    - update debian/build/testsuite.mk
  * Turn on all IPC xpcshell tests again
    - update debian/build/testsute.mk
  * Drop the default-apps xml file - there is already one provided by
    gnome-control-center, so ours duplicates this. We never used to install
    it for Firefox 3.6
    - remove debian/firefox.xml.in
    - update debian/firefox-gnome-support.install.in
    - update debian/rules
  * Ship Test Pilot as a distribution addon, like upstream. This means
    that the addon manager can update it. It does also mean that it will
    remain installed in users profiles if they try the beta or aurora
    builds, but the Feedback button is disabled on release builds
    - update debian/firefox.install.in
    - fixes LP: #913357
  * Drop patches fixed upstream
    - remove debian/patches/fix-cursor-handling.patch
    - update debian/patches/series
  * Call xvfb-run with "-a" in case there are other servers running on the
    builder
    - update debian/build/testsuite.mk
  * Really fix LP: #898883 - IPC xpcshell tests hang the build. What was
    actually happening is plugin-container would fail to start because all
    available X connections had been used up by many instances of dbus-launch,
    spawned each time an xpcshell tried to talk to the session bus. Because
    we run all of the xpcshell tests with one Xvfb instance, the buses
    accumulate until the available X connections all run out. To fix this, run
    all tests requiring a display inside dbus-launch, so we create just a
    single bus for all xpcshell tests
    - update debian/build/testsuite.mk
    - update debian/control{,.in}
  * Add Ligurian to locale blacklist, as we don't support this in Ubuntu
    - update debian/config/locales.blacklist
  * Fix LP: #918763 - Revert the temporary investigation patch for
    bmo: #621446, as it breaks GCC4.4
    - add debian/patches/revert-bmo621446-investigation.patch
    - update debian/patches/series
  * Refresh patches
    - update debian/patches/ubuntu-ua...

Read more...

Changed in firefox (Ubuntu):
status: Invalid → Fix Released
Aaron Thomas (athomas-work) wrote :

I get this error when compiling thunderbird-11.0.1+build1 for lucid (thunderbird from the page at https://launchpad.net/ubuntu/precise/+source/thunderbird/11.0.1+build1-0ubuntu2 ). I'm using gcc4.4.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers