Mozvoikko disabled by default for users

Bug #915895 reported by Timo Jyrinki on 2012-01-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Chris Coulson

Bug Description

There is an issue that with the new Firefox policy of disabling 3rd party extensions by default, mozvoikko is now disabled by default for every user even though it's automatically installed as part of Ubuntu installation.

There is also no pop-up "wants to install this extension" in the case of new installations, so the user simply sees that spell-checking does not work in Firefox/Thunderbird, unless he manually realizes to go to the Extensions dialog and enable Voikko extension.

Language packs and ubufox extension are currently enabled by default because they are installed in a different way.

Related branches

Changed in mozvoikko (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

Chris, Micah, as far as I remember non-binary extensions are automatically migrated to the firefox plugin system. Is that also possible with binary extensions? If not, this might be a wontfix?

Changed in mozvoikko (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

Migrating extensions to be profile-managed is something that we're only doing in Lucid and Maverick so that we don't have to keep a dozen or so extensions updated for the next year. In any case, those are also disabled by default and trigger the about:newaddon tab after installing them. I'd prefer for this to not be a long term thing, as the addon migrator code is quite sensitive to behavioural changes in the addon manager, making it difficult to support for 5 years (but it's manageable with the 1 year of support left for Lucid)

The issue is that Firefox considers anything that isn't installed via its addon manager as third party (see blog.mozilla.com/addons/2011/08/11/strengthening-user-control-of-add-ons/).

We do make an exception though for the addons that are bundled on the CD though.

Personally, I would prefer it if mozvoikko was hosted on addons.mozilla.org now so that users could install it from there rather than the archive. When we dropped all of the Firefox extensions from the archive, we made an exception for mozvoikko because it contained a binary component. This isn't the case anymore though (it's all written in JS), so there doesn't seem to be any real reason to make an exception for it now (other than the fact that the developers haven't submitted it to addons.mozilla.org).

Timo Jyrinki (timo-jyrinki) wrote :

Hi Chris. I asked around a bit for thoughts about this, and I try to summarize the various points of view here.

Firstly, since you talked about "all JS", I'm not sure if you missed that mozvoikko has a dependency on the libvoikko library, which then depends on the 7MB voikko-fi package. This would mean that while the Ubuntu's current mozvoikko component is not a binary itself, spreading it via addons.mozilla.org would mean spreading it in form of a ca. 8MB binary extension instead, duplicating libraries.

As mozvoikko is anyway part of language support, it could be argued that there are enough reasons that Finnish users should continue to be given optimal out of-the-box Ubuntu experience including spell-checking support in e-mail and browser, similar to other language users.

However, according to the voikko main developer, it may be possible to consider using addons.mozilla.org with only the mozvoikko component included (requiring user to have libvoikko already installed), but there would be three work items to be done:

- mozvoikko should be modified to support a broad selection of libvoikko versions, so that users of also older distro versions could use it, and also future API changes in libvoikko should be brought in in a way that doesn't break the extension.
- mozvoikko should have notification system and guidance about possibly missing libvoikko
- testing with various operating systems should be made easy and automated

Those could be possible to be done in the future (although that would still mean no out-of-the-box spell-checking support in Mozilla products for the end users).

There is then an additional potential problem that if eg. Fedora and Debian continue to ship mozvoikko in their default installs, while Ubuntu would want users to manually install the extension via a.m.o. This would then mean both maintaining the packaging in multiple distributions while also needing to maintain the a.m.o version.

I'm not aware how the disabled-by-default issue is going to be handled in the other distributions.

Timo Jyrinki (timo-jyrinki) wrote :

Just a small update from discussions elsewhere that Fedora apparently patches the auto-disable away for packaged extensions, and thus spell-checking also works out-of-the-box there when installing Fedora. http://pkgs.fedoraproject.org/gitweb/?p=firefox.git;a=blob;f=firefox-8.0-enable-addons.patch;h=795b082e295f70b614743acbe0bbaf77a8b05288;hb=HEAD

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mozvoikko (Ubuntu):
status: New → Confirmed
Changed in mozvoikko (Ubuntu):
status: Confirmed → Fix Released
affects: mozvoikko (Ubuntu) → firefox (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers