Update button in Extension Update popup for Test Pilot does nothing

Bug #913357 reported by Christopher Kyle Horton on 2012-01-08
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Periodically, I get this popup informing me I need to do an update for Test Pilot to participate in a study. The Update button on this window does absolutely nothing.

Furthermore, going into the Add-ons screen through the global menu (using Unity) and manually checking for add-ons updates says no updates are available.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: firefox 10.0~b3+build2-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-8.14-generic 3.2.0
Uname: Linux 3.2.0-8-generic x86_64
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: christopher 1539 F.... pulseaudio
 /dev/snd/controlC1: christopher 1539 F.... pulseaudio
BuildID: 20120105170210
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfe028000 irq 22'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,1458c601,00100002'
   Controls : 40
   Simple ctrls : 22
Card1.Amixer.info:
 Card hw:1 'U0x46d0x802'/'USB Device 0x46d:0x802 at usb-0000:00:02.1-4, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0802'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 6144
   Mono: Capture 6144 [100%] [30.00dB] [on]
Channel: beta
Date: Sun Jan 8 02:28:37 2012
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
IpRoute:
 default via 67.194.144.1 dev eth0 proto static
 67.194.144.0/23 dev eth0 proto kernel scope link src 67.194.144.241 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=10.0/20120105170210
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: Upgraded to precise on 2011-12-13 (25 days ago)
dmi.bios.date: 11/03/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F6
dmi.board.name: M61PME-S2P
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF6:bd11/03/2009:svnGigabyteTechnologyCo.,Ltd.:pnM61PME-S2P:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnM61PME-S2P:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: M61PME-S2P
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Ben A (8-roothorick-gmail-com) wrote :

I'm seeing the same issue, except in the Add-ons manager, Test Pilot isn't even in the list...

Chris Coulson (chrisccoulson) wrote :

This is fixed in the current Aurora builds already

Changed in firefox (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package firefox - 11.0~b1+build1-0ubuntu1

---------------
firefox (11.0~b1+build1-0ubuntu1) precise; urgency=low

  * New upstream release from the beta channel (FIREFOX_11_0b1_BUILD1)
    - Fix LP: #875266 - Firefox ignores GNOME3 proxy settings
    - Fix LP: #857153 - Needs to get accessibility settings from GSettings

  * Update globalmenu-extension to 2.0.3
  * Ensure that the crash reporter is disabled if rebuilt by Ubuntu
    derivatives, as there will be no crash symbols for those
    - update debian/rules
  * Only add "Ubuntu" to the UA string when being built for Ubuntu
    - update debian/rules
  * Drop obsolete Debian menu file
    - remove debian/firefox.menu.in
    - don't create a 32x32 xpm icon in debian/rules
    - drop the imagemagick build-depend in debian/control
  * Temporarily disable ipdl tests due to build failures. These aren't
    enabled upstream, anyway
    - update debian/config/mozconfig.in
  * Always set the update channel - not setting it at build-time on release
    builds breaks the extensions.checkCompatibility pref. The only things
    using it at runtime are nsBlocklistService, Test Pilot (beta + aurora)
    and the about dialog (where the channel is hidden anyway)
    - update debian/rules
    - update debian/firefox.install.in
  * Don't declare an extra DEB_ENABLE_THUMB2 variable, as it's only used
    for the mozconfig. Just do the "if DEB_HOST_ARCH == armel" check
    directly there instead
    - update debian/rules
    - update debian/config/mozconfig.in
  * Fix LP: #898883 - IPC xpcshell tests hang the buildd's. Give all
    xpcshell tests an X display, as plugin-container won't work without one
    - update debian/build/testsuite.mk
  * Turn on all IPC xpcshell tests again
    - update debian/build/testsute.mk
  * Drop the default-apps xml file from lucid and maverick - there is
    already one provided by gnome-control-center, which means that ours
    is only relevant for nightly builds. It's not worth the extra
    complexity for this
    - remove debian/firefox.xml.in
    - update debian/firefox-gnome-support.install.in
    - update debian/rules
  * Ship Test Pilot as a distribution addon, like upstream. This means
    that the addon manager can update it. It does also mean that it will
    remain installed in users profiles if they try the beta or aurora
    builds, but the Feedback button is disabled on release builds
    - update debian/firefox.install.in
    - fixes LP: #913357
  * Drop patches fixed upstream
    - remove debian/patches/fix-build-failure-without-yarr-jit.patch
    - remove debian/patches/fix-cursor-handling.patch
    - update debian/patches/series
  * Keep the firefox-kde-support suggest on releases older than precise
    for now
    - update debian/rules
  * Ensure that we suggest kmozillahelper on lucid
    - update debian/rules
  * Ensure that we replace kubuntu-firefox-installer on lucid
    - update debian/rules
  * Don't build with --disable-gconf on precise and newer. There won't be
    a hard runtime requirement on this from Firefox 12 anyway, and this
    keeps us closer to the upstream configuration
    - update debian/config/mozconfig.in
...

Read more...

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers