Firefox: Not using localized Google Search

Bug #899013 reported by Jan Rathmann on 2011-12-02
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Ubuntu Translations
firefox (Ubuntu)

Bug Description


on a fresh Precise Alpha1 installation search results through the Google search bar (right beside the URL bar) are English during the first run of Firefox, allthough the system's locale (and the one in Firefox too) is German.

You can reproduce it the following way:

- Boot a fresh installation of Precise, whose locale has been set to German on installation (or perhaps also other languages different from English).
- Start Firefox.
- Enter "Tonne" in the Google search bar on the right top.
- Google displays the English Wikipedia page for "Tonne" as the first result.
- Close Firefox.
- Start Firefox again and do the same search again.
- Now Google displays correctly the German Wikipedia page for "Tonne" as the first result.

Kind regards,

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: firefox 9.0~b3+build1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-2.5-generic 3.2.0-rc3
Uname: Linux 3.2.0-2-generic x86_64
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
 /dev/snd/controlC1: jan 1488 F.... pulseaudio
 /dev/snd/controlC0: jan 1488 F.... pulseaudio
BuildID: 20111124173847
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
 Card hw:0 'Intel'/'HDA Intel at 0xf9100000 irq 45'
   Mixer name : 'Realtek ALC889A'
   Components : 'HDA:10ec0885,1458a002,00100101'
   Controls : 41
   Simple ctrls : 23
 Card hw:1 'NVidia'/'HDA NVidia at 0xf6000000 irq 17'
   Mixer name : 'Nvidia GPU 14 HDMI/DP'
   Components : 'HDA:10de0014,10de0101,00100100'
   Controls : 20
   Simple ctrls : 4
Channel: beta
Date: Fri Dec 2 09:31:52 2011
ForcedLayersAccel: False
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
 default via dev eth0 proto static dev eth0 scope link metric 1000 dev eth0 proto kernel scope link src metric 1
 lo no wireless extensions.

 eth0 no wireless extensions.
 Windows Media Player Plug-in 10 (compatible; Totem) -, Location=/usr/lib/mozilla/plugins
 QuickTime Plug-in 7.6.6 -, Location=/usr/lib/mozilla/plugins
 DivX® Web Player -, Location=/usr/lib/mozilla/plugins
 VLC Multimedia Plugin (compatible Totem 3.0.1) -, Location=/usr/lib/mozilla/plugins
 iTunes Application Detector -, Location=/usr/lib/mozilla/plugins
 PATH=(custom, no user)
Profiles: Profile0 (Default) - LastVersion=9.0/20111124173847

RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install) 07/10/2008
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F13 P35-DS3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF13:bd07/10/2008:svnGigabyteTechnologyCo.,Ltd.:pnP35-DS3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnP35-DS3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr: P35-DS3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Jan Rathmann (kaiserclaudius) wrote :
summary: - Google search bar delivers english results on first start of Firefox
- instead of localized ones
+ Firefox not using localized Google Search

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Hendrik Knackstedt (hennekn) wrote :

This bug had been fixed a while ago but now it appeared again. All other search providers are localized but not Google anymore.

tags: added: i18n oneiric
tags: added: regression-release

isnt that an upstream-bug? if it is we should put it on the bugtracking-system from mozilla

Hendrik Knackstedt (hennekn) wrote :

Not sure if it is an upstream-bug. We already had a similar problem that had to be fixed in the language-pack. Maybe it's a language pack bug again? Adding project.

Hendrik Knackstedt (hennekn) wrote :

By the way, in Oneiric it's not fixed by restarting firefox but it's permanent.

Jan Rathmann (kaiserclaudius) wrote :

Still present with Firefox 11 Beta in Precise.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
Jan Rathmann (kaiserclaudius) wrote :

This also happens on a fresh installation, when Firefox is running for the first ime.

Hendrik Knackstedt (hennekn) wrote :

For me this bug disappeared today. I don't know how. I don't think I changed anything but it now loads the German Google page when using the Firefox search box. Maybe it's because I cleared my cache?

I found out by personal testing that Firefox in OpenSuse is also
affected, so it seems not to be distro specific.
On the other hand, with the Firefox vanilla builds by I
can't reproduce this bug.

Still present with Firefox 13 on Precise.

MarijonasV (marijonas194az) wrote :

"Jan Rathmann (kaiserclaudius) wrote on 2012-06-09: #12
Still present with Firefox 13 on Precise."

Me too.

summary: - Firefox not using localized Google Search
+ Firefox: Not using localized Google Search
Changed in ubuntu-translations:
status: New → Confirmed
tags: added: saucy
Changed in firefox (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-translations:
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in firefox (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
Changed in hundredpapercuts:
assignee: Papercuts Ninjas (papercuts-ninja) → nobody
status: New → Triaged
importance: Undecided → Medium
To post a comment you must log in.