Make hyphenation work with system hyphenation patterns

Bug #894166 reported by Gerhard Großmann on 2011-11-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Chris Coulson
Precise
High
Chris Coulson
thunderbird (Ubuntu)
Undecided
Chris Coulson
Precise
Undecided
Chris Coulson

Bug Description

The page http://www.belleslettres.eu/blog/firefox-silbentrennung.php provides a test field for German hyphenation in Firefox 8.0 (build1-0ubuntu0.11.10.3). On my friend’s Windows PC the hyphenation works, but it didn’t work on my Ubuntu Laptop (11.10 Oneiric)– there simply wasn’t any hyphenated word. I tested with a new profile without addons etc.

I have filed this bug at https://bugzilla.mozilla.org/show_bug.cgi?id=704885 too, but there was somebody who got hyphenation with the Mozilla build for Linux x86_64 (also my system). He reasoned the missing hyphenation is caused by the Canonical build.

By the way: Does somebody know a testpage for English hyphenation?

I think only with appropriate hyphenation you can use justified text on webpages, especially in languages as German. Missing hyphenation sometimes results in catastrophic word spaces. More information about hyphenation and an English test paragraph on http://blog.fontdeck.com/post/9037028497/hyphens (doesn’t work in my Canonical build).

Meanwhile I found another hyphenation test page for English → http://meyerweb.com/eric/css/tests/css3/show.php?p=hyphens – the third paragraph should be hyphenated. But there both my friends Windows Firefox 8.0 and my own one fail.

Maybe this is because on Eric Meyers page there are no vendor prefixes like moz-hyphens? Does Canonical’s FF support them? If not, my problem is for now insolvable.

summary: - No hyphenation in Firefox 8.0
+ No support for moz-hyphens in Firefox 8.0 (Canonical)

This is because the language "de" specified by the website isn't getting mapped to the right hyphenation pattern, which is installed as hyph_de_DE.dic (we're using our own hyphenation patterns installed via the language selector rather than the ones bundled with Firefox). The upstream hyphenation pattern is installed as hyph_de.dic

Changed in firefox (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → Low
status: New → Triaged
Chris Coulson (chrisccoulson) wrote :

Note, that hyphenation *does* work with Firefox 10, but this is only because Firefox is bundling its own hyphenation patterns in the omni.jar and using those instead. This is pretty undesirable, as those increase the package size quite considerably (and the same for Thunderbird too).

We really want to drop those and make this work properly with the patterns provided by the openoffice.org-hyphenation, myspell-xx and hyphen-xx packages

summary: - No support for moz-hyphens in Firefox 8.0 (Canonical)
+ Make hyphenation work with system hyphenation patterns
Changed in firefox (Ubuntu Precise):
importance: Low → High
Changed in firefox (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
Changed in openoffice.org-dictionaries (Ubuntu Precise):
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in openoffice.org-hyphenation (Ubuntu Precise):
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in thunderbird (Ubuntu Precise):
assignee: nobody → Chris Coulson (chrisccoulson)
tags: added: rls-mgr-p-tracking
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 11.0~b4+build1-0ubuntu1

---------------
firefox (11.0~b4+build1-0ubuntu1) precise; urgency=low

  * New upstream release from the beta channel (FIREFOX_11_0b4_BUILD1)

  * Update globalmenu-extension to 2.0.4
    - Add support for Firefox 12
    - Ensure we correctly hide dummy menu items
  * Fix LP: #915895 - Just set autoDisableScopes to 0. Other distributions
    are already doing this, and we already made this feature pretty much
    useless by allowing extensions in the application directory, so that our
    language packs aren't disabled by default
    - update debian/vendor.js
  * Fix LP: #926495 - Add patch based on one from bmo: #691898 to enable
    building on ppc again
    - add debian/patches/fix-build-failure-without-yarr-jit.patch
    - update debian/patches/series
  * Fix LP: #939657 - Don't call g_settings_new each time we create a HTTP
    channel. Doing this causes a dbus roundtrip, and results in us spamming
    the session bus unnecessarily
    - add debian/patches/avoid-dbus-roundtrip-for-httpchannel.patch
    - update debian/patches/series
  * Fix LP: #894166 - Make Firefox work with our system hyphenation patterns,
    and stop including our own
    - update debian/vendor.js
    - add debian/patches/dont-include-hyphenation-patterns.patch
    - update debian/patches/series

  [ Jamie Strandboge <email address hidden> ]
  * debian/usr.bin.firefox.apparmor.12.04: include p11-kit abstraction (only
    needed on 12.04). LP: #918973
 -- Chris Coulson <email address hidden> Fri, 24 Feb 2012 14:55:30 +0000

Changed in firefox (Ubuntu Precise):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 11.0~b3+build1-0ubuntu1

---------------
thunderbird (11.0~b3+build1-0ubuntu1) precise; urgency=low

  * New upstream release from the beta channel (THUNDERBIRD_11_0b3_BUILD1)

  * Update globalmenu-extension to 2.0.4
    - Add support for Thunderbird 12
    - Ensure we correctly hide dummy menu items
  * Fix LP: #915895 - Just set autoDisableScopes to 0. Other distributions
    are already doing this, and we already made this feature pretty much
    useless by allowing extensions in the application directory, so that our
    language packs aren't disabled by default
    - update debian/vendor.js
  * Fix LP: #939657 - Don't call g_settings_new each time we create a HTTP
    channel. Doing this causes a dbus roundtrip, and results in us spamming
    the session bus and dbus-daemon using lots of CPU when updating mailboxes
    - add debian/patches/avoid-dbus-roundtrip-for-httpchannel.patch
    - update debian/patches/series
  * Fix LP: #926495 - Add patch based on one from bmo: #691898 to enable
    building on ppc again
    - add debian/patches/fix-build-failure-without-yarr-jit.patch
    - update debian/patches/series
  * Fix LP: #894166 - Make Thunderbird work with our system hyphenation
    patterns, and stop including our own
    - update debian/vendor.js
    - add debian/patches/dont-include-hyphenation-patterns.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Fri, 24 Feb 2012 14:46:13 +0000

Changed in thunderbird (Ubuntu Precise):
status: New → Fix Released
Martin Pitt (pitti) on 2012-03-07
no longer affects: openoffice.org-dictionaries (Ubuntu Precise)
no longer affects: openoffice.org-dictionaries (Ubuntu)
no longer affects: openoffice.org-hyphenation (Ubuntu Precise)
no longer affects: openoffice.org-hyphenation (Ubuntu)
Changed in firefox (Ubuntu):
milestone: ubuntu-12.04-beta-1 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers