File Upload dialog has no preview for images

Bug #89381 reported by Ookadoo on 2007-03-03
46
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Undecided
Unassigned
firefox (Ubuntu)
Wishlist
Alexander Sack
firefox-3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

I don't know if this is a defect or new feature request. The file upload dialog looks standard to gnome but it does not have the option to show a preview for image filetypes.

If you need a screenshot comparison let me know. There are help forum threads discussing this deficiency.

http://ubuntuforums.org/showthread.php?p=1840382 has some good comparison screenshots.

I would prefer the ability to have a "Preview Pane" to see the picture (if a valid type is selected) AND be able to change the current view to the equivalent of "View As Icons" in Nautilus.

Ubuntu Edgy 6.10 x86, however I also booted up the latest test release of Feisty 7.04 and there is still no way to view image previews.

Let me know if you have questions.

Related branches

Ookadoo (jbrown0) wrote :

I neglected to mention my OS:

Ubuntu Edgy 6.10 x86, however I also booted up the latest test release of Feisty 7.04 and there is still no way to view image previews.

description: updated
Changed in firefox:
assignee: nobody → mozilla-bugs
importance: Undecided → Wishlist
status: Unconfirmed → Needs Info
Ookadoo (jbrown0) wrote :

I noticed this is marked "Needs Info". I'll be glad to provide what info I can.

On Sat, Mar 24, 2007 at 05:35:54PM -0000, Ookadoo wrote:
> I noticed this is marked "Needs Info". I'll be glad to provide what
> info I can.
>

Does gtk standard file dialog provide that feature (e.g. image
preview)? What application do you see that in?

 - Alexander

Ookadoo (jbrown0) wrote :

Gimp provides that preview, it looks as if it's using the same upload
dialog. Is that a good example? If not I'll try to find some more. :)

On 3/24/07, Alexander Sack <email address hidden> wrote:
>
> On Sat, Mar 24, 2007 at 05:35:54PM -0000, Ookadoo wrote:
> > I noticed this is marked "Needs Info". I'll be glad to provide what
> > info I can.
> >
>
> Does gtk standard file dialog provide that feature (e.g. image
> preview)? What application do you see that in?
>
> - Alexander
>
> --
> File Upload dialog has no preview for images
> https://launchpad.net/bugs/89381
>

Alexander Sack (asac) wrote :

On Sun, Mar 25, 2007 at 12:27:00AM -0000, Ookadoo wrote:
> Gimp provides that preview, it looks as if it's using the same upload
> dialog. Is that a good example? If not I'll try to find some more. :)

Gimp might be a special case. Please look if you see others that
provide that :)

 - Alexander

Ookadoo (jbrown0) wrote :

Hi Alexander,

Sorry I haven't replied before now. I can't think of any gnome utilities
that provide that and tried a few but they did not. Do you think it's
possible for Firefox to provide this function?

Thanks,
Jason

On 3/24/07, Alexander Sack <email address hidden> wrote:
>
> On Sun, Mar 25, 2007 at 12:27:00AM -0000, Ookadoo wrote:
> > Gimp provides that preview, it looks as if it's using the same upload
> > dialog. Is that a good example? If not I'll try to find some more. :)
>
> Gimp might be a special case. Please look if you see others that
> provide that :)
>
> - Alexander
>
> --
> File Upload dialog has no preview for images
> https://launchpad.net/bugs/89381
>

kfrance (kirt-lillywhite) wrote :

Using the image preview when inserting an image into openoffice there is an option to preview images. It seems to be part of gnome.

Paul Williams (pwill) wrote :

Any news on this? I don't want to have to have a Nautilus window open when uploading images, and I do a lot of uploading.

Changing from "needs info" to "confirmed", as kfrance confirmed it as a GNOME bug in the last post...

Changed in firefox:
status: Needs Info → Confirmed
Ookadoo (jbrown0) wrote :

I installed Feisty final, which still does not have the capability.

From Firefox's Help->About:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)

Alexander Sack (asac) wrote :

Please don't confirm bugs unless you are member of the mozillateam or are aware of mozillateam bug procedures. For instance, without the proper tag/state combination the bug might get lost.

Thanks,

 - Alexander

Jonathan (infectiouslogic) wrote :

I am having the same problems with nautilus. Many of my images just won't preview but when I open them up from gimp they will then preview. This is pretty annoying. Any ideas on this one? I think I did uninstall nautilus in order to install the latest pidgin (i had to because stupid gaim is tied to ubuntu-desktop & nautilus) after which time I reinstalled nautilus through synaptic. Did I mess stuff up? I have also been noticing that sometimes file extension associations go away.

Please help,

Jonathan

MCSE_Crossover (kevin-a-joy) wrote :

Is there any updates to this bug report? This is a big issue I think and I can't believe that it has been over looked. Is there something that is preventing this from being fixed?

This occurs for me using Kubuntu Feisty when browsing and attempting to upload files with Firefox and Thunderbird as well. It also occured using Ubuntu Feisty.

I'd also like to voice my displeasure with this lack of functionality. It makes sifting through images with numeric filenames a needless hassle. I hope a thumbnail preview pane is added to Firefox's file-chooser ASAP.

Ookadoo (jbrown0) wrote :

Jonathan, could you have installed anything funky? In my nautilus it says "JPEG image" and not "jpeg document" as it shows in yours.

Travis Watkins (amaranth) wrote :

To implement this you have to add a preview widget to the GtkFileChooser. See http://developer.gnome.org/doc/API/2.0/gtk/GtkFileChooser.html#gtk-file-chooser-set-preview-widget

Stephen Cofer (sdcofer) wrote :

Attached is a very minimal but functional preview feature using the preview widget for FF2 (it also works in the latest FF3 preview versions but it has to be manually entered since nsFilePicker.cpp has changed enough where patch won't automatically insert the changes).

Does anyone know if Mozilla has been made aware of the patch above? If so, is any action being taken on it? I searched Mozilla's Bugzilla, but didn't see anything.

Alexander Sack (asac) wrote :

thanks for the patch. I will review and submit it upstream.

Changed in firefox:
assignee: mozilla-bugs → asac
status: Confirmed → In Progress
Gabriel M. (gabrielm) wrote :

Rather than patching firefox as well as every other ubuntu program that might open an image, I think this fonctionality would better be implemented as a patch to the GtkFileChooser itself. GtkFileChooser should look in a config file for a default preview widget, and use it if no other preview widget has been defined by the calling program.

Ubuntu could use the nautilus preview widget as a system-wide default, Xubuntu would use a Thunar preview widget, and so on. Therefore you would have preview functionality when opening files from any programs (not only for images, but also for pdf files, text files, etc), and said programs could always overwrite the defaults and provide their own widget if they need it.

I believe this is more or less the way windows does it, by the way: whenever you are in a file open dialog you seem to be able to do everything you can do in the file manager. Windows XP has it, and I think it even dates back to windows 95... too bad the picture preview feature always gets delayed in linux desktop environments, because of philosophical discussions about how much a file open dialog should do.

ChristofferS (ubuntu-curo) wrote :

Gabriel,

I completely agree.

However, I think that Gnome upstream (and Ubuntu also) has closed the bug about general preview functionality in gtkfilechooser. I don't understand the reason behind this decision.

It seems very inefficient to enable it in all programs.

Luis R. Rodriguez (mcgrof) wrote :

If Gnome upstream has closed that bug it is very unfortunate. I'm promoting Ubuntu for regular users and this happens to be a big complaint I have received so far. So in the meantime I'll tell my users to use a debian package I've built based on Stephen Cofer's patch. I just rebased it for 2.0.0.8+2nobinonly-0ubuntu0.

Here is the deb, README.txt and patch:

http://ruslug.rutgers.edu/~mcgrof/firefox/preview-pictures/

I'll attach the patch here as well.

  Luis

Luis R. Rodriguez (mcgrof) wrote :

Sorry I meant for Gutsy ;) -- that patch is for gutsy..

geeknik (brian-carpenter) wrote :

Hey Luis, thanks for patching that up, but is there any way you can make a .deb for x86-64? If not, is there anyone related to this bug that could do so?

Luis R. Rodriguez (mcgrof) wrote :

Nope, sorry, I have no x86-64 box and really don't feel like cross compiling.

what's preventing this bug being fixed ?

I'm guessing the reason this hasn't been fixed yet has something to with Mozilla putting more time and resources into the Windows and OS X versions of Firefox, while the Linux only gets any attention when people start to complain loudly enough to Mozilla.

Ookadoo (jbrown0) wrote :

Luis, thanks so much for your deb file, but when I try to apt-get anything it replaces it with the other firefox deb.

Ghostvirus, I'd love to see this ticket fixed and closed. Obviously there are enough people who want this feature, should I add a linking ticket to Mozilla's bug tracking system?

KhaaL (khaal) wrote :

Luis, could you please make a .deb file with this fix for version 2.0.0.10? The new version of FF dosen't have a image preview.

Alexander Sack (asac) wrote :

we won't apply this for 2.x ... lets make sure that firefox 3 will get this. Please test if this issue exists for you if you use the latest firefox-3.0 package in hardy.

Thanks,
 - Alexander

Changed in firefox:
status: In Progress → Won't Fix
Alexander Sack (asac) wrote :

please comment on whether latest firefox-3.0 in hardy still lacks this feature.

Changed in firefox-3.0:
status: New → Incomplete
Travis Watkins (amaranth) wrote :

This _just_ got fixed in the latest nightly of firefox 3 so I doubt our packages have that fix. Unless you're really fast. :)

Fabien Tassin (fta) wrote :

It's indeed in firefox 3.0 b3pre so it will only appear in hardy in about a month, i.e. when beta3 will be released upstream.

(I've tested it in Minefield builds, it works fine)

Luis R. Rodriguez (mcgrof) wrote :

Confirmed, I've tested it on Firefox 3.0b3pre and I see its there.

Alexander Sack (asac) on 2007-12-29
Changed in firefox-3.0:
status: Incomplete → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox-3.0 - 3.0~b3~cvs20080101t1000+nobinonly-0ubuntu1

---------------
firefox-3.0 (3.0~b3~cvs20080101t1000+nobinonly-0ubuntu1) hardy; urgency=low

  * new years upstream snapshot (3.0b3 pre, CVS 20080101t1000) features:
    - new firefox 3 version (LP: #178066)
    - file upload dialog has preview for images (LP: #89381)
    - gnome/gtk theme icons for main navigation and mime-type icons work
      properly now (LP: #160942)
    - honours proper plugin/extension locations now (LP: #123118)
      (see https://wiki.ubuntu.com/XulrunnerGecko)
    - import bookmarks from ffox 2 properly (LP: #163746)
    - proper implementation for adding security exceptions (LP: #179706)

  [ Alexander Sack ]
  * new upstream snapshot (3.0b3 pre, CVS 20080101t1000)
  * update firefox-profile patch because of changed upstream codebase
    - update debian/patches/firefox-profilename
  * firefox-3.0 now has its own extensions directory because latest
    xulrunner-1.9 supports extensions (and plugins) in three directories:
    PROFILE, APP (ffox), GRE (xul)
    - update debian/firefox-3.0.dirs
    - update debian/rules
  * exceptional official branding release for cvs version to hardy: add easy to
    use FORCE_OFFICIAL_BRANDING switch in rules and enable it for this release
    - update debian/rules

  [ Fabien Tassin ]
  * Move xulrunner-1.9 dependencies to b3
    - update debian/control

firefox-3.0 (3.0~b2+nobinonly-0ubuntu1) hardy; urgency=low

  [ Fabien Tassin ]
  * new upstream snapshot (3.0b2 from FIREFOX_3_0b2_RELEASE)
    - update debian/changelog
  * Drop debian/patches/no-have-stdint-h-ftbfs.patch integrated
    upstream and bump xulrunner requirements to 1.9~b2~cvs20071119
    - update debian/control
    - drop debian/patches/no-have-stdint-h-ftbfs.patch
    - update debian/patches/series
  * Add libdbus-glib-1-dev >= 0.60 to build-deps. See MozBug #388743.
    - update debian/control
  * Update rules to use system cairo if cairo >= 1.5.4 is found
    - update debian/rules
  * Add libpixman-1-dev to build-deps, needed by system cairo
    - update debian/control
  * Update Standards-Version to 3.7.3
    - update debian/control
  * Drop -1.9 suffix of expected xulrunner-1.9 pkg-config files
    - update debian/patches/nspr_flags_by_pkg_config_hack.patch
  * Fold Build-Depends line making changes easier to track in diffs
    - update debian/control

  [ Alexander Sack ]
  * use system nspr and system nss; add build-depends accordingly
    - update debian/control
    - update debian/rules
  * add versioned depends on xulrunner-1.9 >= 1.9~b2+nobinonly which is the
    first xulrunner-1.9 that officially uses system nspr/nss.
  * tighten dependency on xulrunner-1.9 << 1.9~b3~
    - update debian/control
  * drop DEV_PACKAGE_INDICATION business because xulrunner pkg-config files
    properly reference system-nss/nspr since 1.9+b2+nobinonly
    - update debian/rules

 -- Alexander Sack <email address hidden> Wed, 02 Jan 2008 15:43:50 +0100

Changed in firefox-3.0:
status: In Progress → Fix Released
Changed in firefox:
status: New → Fix Released
Alex Moldovan (alexmoldovan) wrote :

Still not working if you have flash installed. As soon as you install the flashplugin the preview is gone. I tried it on lucid 32 and 64 (all kernels since the release date) and the result is the same. I used Firefox 2.6.8 and Adobe Flash Player plugin version 10.1.53.64-1lucid1. See the screenshots.

Alex Moldovan (alexmoldovan) wrote :
Alex Moldovan (alexmoldovan) wrote :
Fabián Rodríguez (magicfab) wrote :

Same problem in Maverick using the latest Adobe Flash for 64-bit.

This seems to be website-specific.

Try to upload an image to Flickr with Flash enabled - no preview

Try to upload an image to your Launchpad profile with Flash enabled - preview is OK.

It looks like websites can override the OS upload dialog with their own or something along those lines.

Micah Gersten (micahg) wrote :

@ Alex Moldovan, Fabián Rodríguez

Please file a new bug instead of comment on old resolved ones. You can reference the old bug # in the new bug report.

Alex Moldovan (alexmoldovan) wrote :

I filed the Bug #613886 for this issue.

It seems it's a problem with Flash. I tries Picknik and it didn't show previews using their flash based uploader, it happended with imgur's flash uploader as well. When using non-flash uploader it displays a preview.

Miroslav Hadzhiev (xtigyro) wrote :

Still no or very small preview of images when using Facebook uploader.

Mike (bild85) wrote :

I don't think this is FF-specific. Perhaps a new bug report is necessary. See https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/1125281

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers