Firefox doesn't restart after upgrades where the version changes

Bug #807733 reported by Micah Gersten on 2011-07-08
68
This bug affects 10 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned

Bug Description

When you click the restart button in Firefox after a version upgrade (like 5->6, 3.6.17->3.6.18, but not 8.0~a1~hg20110707r72459 -> 8.0~a1~hg20110708r72522), Firefox doesn't restart. This functionality works normally after addons are installed. The problem is the path changes to the Firefox binary.

Micah Gersten (micahg) wrote :

We should try to fix this before release.

Changed in firefox (Ubuntu Oneiric):
importance: Undecided → Medium
milestone: none → ubuntu-11.10-beta-2
status: New → Triaged
summary: - Firefox doesn't restart after major version upgrades
+ Firefox doesn't restart after upgrades where the version changes
description: updated
Dave Walker (davewalker) on 2011-09-23
Changed in firefox (Ubuntu):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 11.0+build1-0ubuntu1

---------------
firefox (11.0+build1-0ubuntu1) precise; urgency=low

  * New upstream stable release (FIREFOX_11_0_BUILD1)

  * Clean up search plugin installation now that we build our own
    language packs:
    - Drop the recursive symlink from /usr/lib/firefox-addons/searchplugins,
      which lintian kept complaining about
    - Don't effectively symlink distribution/searchplugins to searchplugins,
      as they have different layouts and this avoids the same data being
      iterated over twice
    - Revert to the upstream layout in distribution/searchplugins
    - Simplify distro-locale-searchplugins.patch, as we don't need to swap the
      loading order of common / locale-specific searchplugin paths now.
      $LIBDIR/distribution/searchplugins/common is no longer a symlink
      to $LIBDIR/searchplugins, so there is no need to have the ability for
      locale-specific plugins to override common ones. They already override
      those in $LIBDIR/searchplugins
      - add debian/firefox-locale.preinst.in, which will end up in all
        language packs to assist the symlink -> folder transition
      - update debian/firefox.dirs.in
      - update debian/firefox.install.in
      - update debian/firefox.links.in
      - update debian/firefox.preinst.in
      - update debian/patches/distro-locale-searchplugins.patch
      - update debian/rules
  * Fix LP: #807733 - Firefox doesn't restart after upgrades where the version
    changes. Don't include the version number in the install path, as Firefox
    cannot re-exec itself. In doing this, we also move the distribution.ini
    back in to our installation directory, as that never made sense in
    /usr/lib/firefox-addons
    - update debian/firefox-dev.install.in
    - update debian/firefox-dev.links.in
    - update debian/firefox-locale.preinst.in
    - update debian/firefox.lintian-overrides.in
    - update debian/firefox.preinst.in
    - update debian/rules
  * Expose distribution/extensions in /usr/lib/firefox-addons, to allow
    administrators to add extensions that they want to add to default user
    profiles, and that they want the addon manager to keep updated. We lost
    this functionality when upgrading from Firefox 3.6, due to the loss of
    /etc/firefox/profile
    - update debian/firefox.dirs.in
    - update debian/firefox.install.in
    - update debian/firefox.links.in
    - update debian/firefox.postinst.in
 -- Chris Coulson <email address hidden> Tue, 13 Mar 2012 14:05:38 +0000

Changed in firefox (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package firefox - 12.0+build1-0ubuntu0.11.10.1

---------------
firefox (12.0+build1-0ubuntu0.11.10.1) oneiric-security; urgency=low

  * New upstream stable release (FIREFOX_12_0_BUILD1)
    - see LP: #987262 for USN information

  [ Chris Coulson <email address hidden> ]
  * Update globalmenu-extension to 2.0.6
    - Add support for Firefox 12
    - Ensure we correctly hide dummy menu items
  * Firefox recommends libcanberra0 now that bmo: #635918 has landed
    - update debian/control{,in}
  * Clean up search plugin installation now that we build our own
    language packs:
    - Drop the recursive symlink from /usr/lib/firefox-addons/searchplugins,
      which lintian kept complaining about
    - Don't effectively symlink distribution/searchplugins to searchplugins,
      as they have different layouts and this avoids the same data being
      iterated over twice
    - Revert to the upstream layout in distribution/searchplugins
      - add debian/firefox-locale.preinst.in, which will end up in all
        language packs to assist the symlink -> folder transition
      - update debian/firefox.dirs.in
      - update debian/firefox.install.in
      - update debian/firefox.links.in
      - update debian/firefox.preinst.in
      - update debian/patches/distro-locale-searchplugins.patch
      - update debian/rules
  * Fix LP: #807733 - Firefox doesn't restart after upgrades where the version
    changes. Don't include the version number in the install path, as Firefox
    cannot re-exec itself. In doing this, we also move the distribution.ini
    back in to our installation directory, as that never made sense in
    /usr/lib/firefox-addons
    - update debian/firefox-dev.install.in
    - update debian/firefox-dev.links.in
    - update debian/firefox-locale.preinst.in
    - update debian/firefox.lintian-overrides.in
    - update debian/firefox.preinst.in
    - update debian/rules
  * Expose distribution/extensions in /usr/lib/firefox-addons, to allow
    administrators to add extensions that they want to add to default user
    profiles, and that they want the addon manager to keep updated. We lost
    this functionality when upgrading from Firefox 3.6, due to the loss of
    /etc/firefox/profile
    - update debian/firefox.dirs.in
    - update debian/firefox.install.in
    - update debian/firefox.links.in
    - update debian/firefox.postinst.in
  * Refresh patches
    - update debian/patches/avoid-dbus-roundtrip-for-httpchannel.patch
    - update debian/patches/firefox-kde.patch
    - update debian/patches/mozilla-kde.patch
    - update debian/patches/no-sps-profiler-on-unsupported-archs.patch
    - update debian/patches/ubuntu-codes-google.patch
  * Massively simplify distro-locale-searchplugins.patch, as we don't need
    to swap the loading order of common / locale-specific searchplugin
    paths. $LIBDIR/distribution/searchplugins/common is no longer a symlink
    to $LIBDIR/searchplugins, so there is no need to have the ability for
    locale-specific plugins to override common ones. They already override
    those in $LIBDIR/searchplugins
    - update debian/patches/distro-locale-searchplugins.patch
  * Fi...

Read more...

Changed in firefox (Ubuntu Oneiric):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers