Ubuntu

language packs pull in Firefox on upgrade

Reported by George Klein on 2011-06-22
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Chris Coulson
Natty
High
Micah Gersten
Oneiric
High
Chris Coulson

Bug Description

FIX: temporarily remove the depends on Firefox, we'll migrate this to a Breaks in the future so that people get the proper version of their language pack with their version of Firefox

------------------------------------------

"apt-get dist-upgrade" today for natty wants to newly install firefox (amongst many other packages) on a server with command line only. It makes no sense to require firefox on a server with no gui.

Looking at the upgrades and then their dependencies, it looks to me like the cause of this is a new dependency on firefox-locale-en for language-pack-en-base 1:11.04+20110607.

I know I can work around this by just doing "apt-get upgrade" instead which is fine for a short while but it will increase the work in keeping my servers up to date and, imho, will rule out a future release upgrade.

Micah Gersten (micahg) wrote :

Thank you for reporting this to Ubuntu. We added the recommends on the firefox language pack to pull in that language pack on upgrades since it's now built by the firefox source. However, our testing apparently didn't discover this issue that Firefox itself gets pulled in on upgrade on systems that don't have it. This would affect servers and derivatives like Kubuntu. We apologize for this inconvenience and will fix this as soon as possible.

affects: language-pack-en-base (Ubuntu) → firefox (Ubuntu)
Changed in firefox (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → High
status: New → Triaged
Changed in firefox (Ubuntu Natty):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Micah Gersten (micahg)
summary: - language-pack-en-base 1:11.04+20110607 adds firefox as dependency
+ language packs pull in Firefox on upgrade
Chris Coulson (chrisccoulson) wrote :

So, this dependency in the nightly builds is currently very strict, because we get issues with users upgrading firefox without upgrading language packs, in combination with running the addon compatibility reporter, and this breaks Firefox. We want to be able to prevent users upgrading one or the other in future, so I've replaced the dependency in the nightly build with a strict Breaks instead, but i'm not sure how well that will work out yet.

There is no strict relationship in the current stable version (it's just a loose dependency), so there's no need to keep that

Micah Gersten (micahg) on 2011-06-22
tags: added: regression-release
Marc Deslauriers (mdeslaur) wrote :

Updated to correct this regression are being worked on and will be released in the next few hours. Please refrain from doing "apt-get dist-upgrade" on servers until the fix is uploaded. "apt-get upgrade" works as expected.

Micah Gersten (micahg) on 2011-06-23
description: updated
Changed in firefox (Ubuntu Natty):
status: In Progress → Fix Committed
Micah Gersten (micahg) wrote :

Chris, I'm handing this off to you for oneiric

Changed in firefox (Ubuntu Oneiric):
milestone: none → oneiric-alpha-2
assignee: Micah Gersten (micahg) → Chris Coulson (chrisccoulson)
Micah Gersten (micahg) on 2011-06-23
tags: added: regression-update
removed: regression-release
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 5.0+build1+nobinonly-0ubuntu0.11.04.2

---------------
firefox (5.0+build1+nobinonly-0ubuntu0.11.04.2) natty-security; urgency=low

  * fix LP: #800857 - language packs pull in Firefox on upgrade
    - update debian/control.langpacks
    - update debian/control
 -- Micah Gersten <email address hidden> Wed, 22 Jun 2011 18:08:55 -0500

Changed in firefox (Ubuntu Natty):
status: Fix Committed → Fix Released
Micah Gersten (micahg) on 2011-06-23
tags: added: natty oneiric regression-release
Steven Sroka (lin-unix) wrote :

One last problem. I don't have Firefox installed, yet when I upgrade language-pack* apt tries to pull in firefox-locale-en

Chris Coulson (chrisccoulson) wrote :

Yes, that is normal and totally expected. It's also necessary to ensure the transition goes smoothly for Firefox users (the Firefox translations were bundled in language-pack-xx-base previously, anyway)

George Klein (gk-t-t-l) wrote :

Thanks for the quick response. Sanity has now returned to my overnight check.

Martin Pitt (pitti) wrote :

firefox-locale-XX should Breaks: firefox (<< 5)

Changed in firefox (Ubuntu Oneiric):
milestone: oneiric-alpha-2 → oneiric-alpha-3
Martin Pitt (pitti) on 2011-07-01
Changed in firefox (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → oneiric-alpha-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 5.0+build1+nobinonly-0ubuntu2

---------------
firefox (5.0+build1+nobinonly-0ubuntu2) oneiric; urgency=low

  * Fix the language packs to not depend on Firefox (LP: #800857)
    - update debian/control.langpacks
 -- Chris Coulson <email address hidden> Mon, 04 Jul 2011 21:59:08 +0100

Changed in firefox (Ubuntu Oneiric):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers