when sessionmanager restors a session with more than one winow, only the first window gets a global menu

Bug #779905 reported by Bazon on 2011-05-09
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Global menubar extension
Undecided
Unassigned
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

steps to reproduce:
1. be sure firefox session manager is enabled (which is the default setting)
2. open more than one firefox window (i also had a tab pinned as app-tab btw.)
3. reboot system without closing firefox
4. after reboot restart firefox (and allow session restoration when asked to)
5. only the first window gets a global menu, all other windows get menus inside the window
(expected: all firefox windows get global menus)

a suppose, there is something wrong in firefox-globalmenu

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: firefox-globalmenu 4.0.1+build1+nobinonly-0ubuntu0.11.04.1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon May 9 14:50:08 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
ProcEnviron:
 LANGUAGE=de_DE:en_GB:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)

Bazon (bazonbloch) wrote :
description: updated
Chris Coulson (chrisccoulson) wrote :

Not confirming, that works fine here...

Changed in firefox (Ubuntu):
status: New → Invalid
Bazon (bazonbloch) wrote :

Sorry, to kill Firefox seems not enough, a reboot is needed to see this.
I'll edit the description.

description: updated
Changed in firefox (Ubuntu):
status: Invalid → New
Chris Coulson (chrisccoulson) wrote :

Still not confirming, it works fine here. And please don't reopen the firefox task. There is already a globalmenu-extension task open

Changed in firefox (Ubuntu):
status: New → Invalid
SRoesgen (s-roesgen) wrote :

I get the same problem here.

I opened two different windows, each with several opened tabs. I close Firefox, so that sessionmanager saves the opened windows including their opened tabs. When I reopen Firefox, the windows are arestored, the tabs are restored, but only one of the Firefox windows has a working global menubar, the other one has only the normal menu integrated in the window.

For me even a reboot does not help. Sessionmanager restores only one window with working globalmenu-extension.

Chris Coulson (chrisccoulson) wrote :

I just fixed a startup race here which will probably fix this

Changed in globalmenu-extension:
status: New → Fix Committed
Changed in globalmenu-extension:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 6.0~b1+build1+nobinonly-0ubuntu1

---------------
firefox (6.0~b1+build1+nobinonly-0ubuntu1) oneiric; urgency=low

  * New upstream release from the beta channel (FIREFOX_6_0b1_BUILD1)

  * Update globalmenu-extension to 1.7
    - Fixes LP: #779905 - menubar sometimes appears inside the window rather
      than the panel, due to a startup race
  * Drop the profile migrator, as it doesn't really make any sense with the new
    release cycle. Instead, just copy the firefox profile (if it exists) to
    firefox-trunk (if it doesn't exist)
    - remove debian/migrator/xulapp-profilemigrator
    - update debian/firefox.sh.in
    - update debian/firefox.install.in
    - update debian/rules
    - update debian/control.in
  * xpt_link and xpt_dump have been replaced by xpt.py
    - update debian/firefox-dev.install.in
    - update debian/firefox-dev.links.in
  * Add support for the system provided hyphenation patterns, by linking
    @MOZ_LIBDIR@/hyphenation to /usr/share/hyphen
    - update debian/firefox.links.in
  * Refreshed patches:
    - update debian/patches/firefox-kde.patch
    - update debian/patches/mozilla-kde.patch
    - update debian/patches/plugin-for-mimetype-pref.patch
    - update debian/patches/reload-new-plugins.patch
  * The official branding moved from other-licenses to browser. Handle this
    - update debian/rules
  * Dropped patches fixed upstream:
    - remove debian/patches/use-MOZ_APP_LAUNCHER-for-launcher-exec.patch
    - remove debian/patches/fix-nsGIOService.patch
    - remove debian/patches/default-browser-check-use-gio.patch
    - remove debian/patches/update-assembler-excl-arch-list.patch
    - remove debian/patches/default-uri-handler-check-use-gio.patch
    - remove debian/patches/powerpc-build-fix.patch
    - update debian/patches/series
  * Drop the special "kde.js" file handling from the pref service. It hasn't
    had the desired effect since Firefox 4, as the specialfile handling
    doesn't apply to pref files inside the omni.jar. Moving kde.js back in to
    defaults/pref isn't an option, as these are always read after the prefs
    in the omni.jar, which would mean that all users would get the KDE
    specific prefs. Note, we only override one pref in kde.js anyway, it can
    go elsewhere if really required
    - update debian/patches/mozilla-kde.patch
    - update debian/patches/firefox-kde.patch
 -- Chris Coulson <email address hidden> Fri, 08 Jul 2011 20:43:38 +0100

Changed in firefox (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers