some webpages shows no text, and somewebpage can't input text

Bug #775220 reported by boyang.du
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

www.google.com (ENGLISH) and firefox official website (ENGLISH) show no text on the pages, images are shown as normal
however website such as www.douban.com (CHINESE) are rendered as normal but can't input text, copy and paste not working either. System Language is set to be ENGLISH, iBus is used (CHINESE). already tried a clean re-install, not working.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: firefox 4.0.1+build1+nobinonly-0ubuntu0.11.04.1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon May 2 01:24:38 2011
FirefoxPackages:
 firefox 4.0.1+build1+nobinonly-0ubuntu0.11.04.1
 flashplugin-installer 10.2.159.1ubuntu1
 adobe-flashplugin N/A
 icedtea-plugin N/A
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Release i386 (20110427)
ProcEnviron:
 LANGUAGE=en_US
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
boyang.du (duboyang-h) wrote :
Revision history for this message
boyang.du (duboyang-h) wrote :

this is a screenshot of web page www.google.com (in my case, redirected to www.google.it), no text are shown.

but launchpad.net works well.

Revision history for this message
Aaron Murray (xornot) wrote :

Please turn off all plug-ins and extensions and try again. Also, have you tried any other browsers?

Aaron Murray (xornot)
Changed in firefox (Ubuntu):
assignee: nobody → Aaron Murray (xornot)
Revision history for this message
Aaron Murray (xornot) wrote :
Changed in firefox (Ubuntu):
assignee: Aaron Murray (xornot) → nobody
Revision history for this message
boyang.du (duboyang-h) wrote :

no, I recently just installed Kubuntu 11.04 and then use the firefox-kde-installer come with the Kubuntu to install firefox (4.0.1) and found it won't work, and I tried to use "locate firefox" to find files and delete them and re-installed firefox use apt-get but still won't work.

Now I'm not sure if this a firefox bug or somethings go wrong with the configuration files.
However, the google chrome is also keeping crash on start on the same computer. I'm wondering if there's a problem in the lib files these two browser both used.

the google-chrome show Error Messages like "unable to find font '0'", and then can't open any webpages (show blank or just a "Oh, Snap, something wrong ..."

============
Aaron Murray wrote 4 hours ago: #4
Did you just upgrade Firefox?

See: https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/338785

Revision history for this message
boyang.du (duboyang-h) wrote :

currently only the browser "Rekonq" can correctly open most webpages, but still got problems like

1. when open gmail page, the webpage tab is not shown correctly
2. when open "www.douban.com" the browser keeps refresh itself. (firefox can open www.douban.com correctly, but when ibus switched to "IM off" then can't input anything in the input box, but when switched to "Chinese PinYin" then it is able to type in the input box).

Revision history for this message
boyang.du (duboyang-h) wrote :

I've tried to turn off all the extensions and plug-ins shown in the add-ons manager, and restart the firefox but still the same
?field.comment=I've tried to turn off all the extensions and plug-ins shown in the add-ons manager, and restart the firefox but still the same

Revision history for this message
Aaron Murray (xornot) wrote :

Could you please do the following:

* Open Firefox
* In the URL field type "about:config" without the quotes.
* Copy and Paste that information into this bug report.

Thanks!

Aaron Murray (xornot)
Changed in firefox (Ubuntu):
status: New → In Progress
Revision history for this message
boyang.du (duboyang-h) wrote :

thx for replying, however I can't find a way to export or print the about:config page, so I just attached the prefs.js file I find in the .mozila folder and it should contains all the values which are different from the default ones. if this is not useful, please let me know how to get the about:config entries out to a txt file maybe

Revision history for this message
Aaron Murray (xornot) wrote :

At this point, I have done all I can personally do. I can recommend you try the following, but beyond this, all we can do is see if somebody with more knowledge on the subject steps in, or just keep this bug in the list for future reference.

So, you can try ...

1. Downloading/burning a live CD and see if you have the same problems with that OS. If you do not, you may consider reinstalling everything from scratch.
2. Report this bug to: https://bugzilla.mozilla.org/

Thank you for reporting this issue. I will keep this bug report open for the time being and see if anybody else jumps in to give it a stab.

Changed in firefox (Ubuntu):
status: In Progress → Incomplete
Revision history for this message
boyang.du (duboyang-h) wrote :

thanks for replying

I've tried to run kubuntu on USB stick, and after install firefox, it works fine, and google-chrome works without crash, so I suppose there may be some problems with my hard-disk installation (maybe broken package during update or something). Anyway, now I switch to Ubuntu 11.04 and everything works fine.

thanks very much.

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for firefox (Ubuntu) because there has been no activity for 60 days.]

Changed in firefox (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers