Apparmor prevents the use of mozplugger

Bug #766512 reported by Damien Clauzel on 2011-04-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: apparmor

While loading a mp3 file in firefox, I get this message in /var/log/kern.log :
___
Apr 19 21:59:17 portable kernel: [70804.799364] type=1400 audit(1303243157.632:99): apparmor="DENIED" operation="exec" parent=4790 profile="/usr/lib/firefox-trunk-6.0a1/firefox{,*[^s][^h]}" name="/usr/bin/mozplugger-controller" pid=4910 comm="plugin-containe" requested_mask="x" denied_mask="x" fsuid=1000 ouid=0
___

The expected result is firefox playing the mp3.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: apparmor 2.5.1-0ubuntu0.10.10.4
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Apr 19 22:01:09 2011
ProcEnviron:
 LANGUAGE=fr_FR:en
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdline: BOOT_IMAGE=/vmlinuz-2.6.35-28-generic root=/dev/mapper/hostname_ouvert-rootfs ro quiet splash
SourcePackage: apparmor

Damien Clauzel (damien-clauzel) wrote :
Brubel Sabs (brubelsabs) wrote :

I also got this message on my ubuntu 10.10 x86_64, but I think this is a firefox misconfiguration problem instead, as I found a workaround while trying advises from https://help.ubuntu.com/community/EvinceMozilla

 - uninstall mozplugger with `sudo aptitude remove --purge mozplugger`
 - within firefox call "about:addons" change to "plugins" and disable existing PDF plugins
 - quit firefox
 - mv ~/.mozilla/firefox/YOUR_FF_ID_STUFF/pluginreg.dat ~/.mozilla/firefox/YOUR_FF_ID_STUFF/old_pluginreg.dat
 - reinstall mozplugger
 - everything should be fine now and you should not receive apparmor messages complaining about mozplugger nor evince when starting firefox and using firefox.

(essential is that in firefox "about:plugins" mozplugger is listed...)

HTH

Brubel Sabs (brubelsabs) wrote :

Oh I forgot you must place a mozpluggerrc into ~/.mozilla/ with the following content:

application/pdf: pdf: PDF file
application/x-pdf: pdf: PDF file
text/pdf: pdf: PDF file
text/x-pdf: pdf: PDF file
application/x-postscript: ps: PostScript file
application/postscript: ps: PostScript file
    repeat noisy swallow(evince) fill: evince "$file"

Changed in apparmor (Ubuntu):
importance: Undecided → Low
status: New → Triaged
affects: apparmor (Ubuntu) → firefox (Ubuntu)
tags: added: apparmor
Changed in firefox (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
Changed in firefox (Ubuntu):
assignee: Micah Gersten (micahg) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers