Comment 70 for bug 741528

Let's not forget to land the additional patch into 1.9.1 and 1.9.2