Firefox claims that it's not my default browser; repeatedly in guest session too

Bug #732792 reported by Matthew Paul Thomas on 2011-03-10
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Low
Unassigned
gnome-vfs (Ubuntu)
Medium
Chris Coulson

Bug Description

Binary package hint: firefox

Ubuntu Natty alpha 3, all updates installed

1. Switch to a guest session.
2. Launch Firefox.

What happens: "Firefox is not currently set as your default browser. Would you like to make it your default browser?"
What should happen: No such alert, because (as confirmed by "Preferred Applications") Firefox *is* the default browser.

Related branches

Chris Coulson (chrisccoulson) wrote :

Not confirming the issue here. Could you please attach your /usr/share/applications/mimeinfo.cache and your /etc/gnome/defaults.list.

Thanks

Changed in firefox (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Jacopo Moronato (jmoronat) wrote :

Same here, attaching my mimeinfo.cache and defaults.list .
If I rimember correctly, it should also happen in "live" mode.

Jacopo Moronato (jmoronat) wrote :

..ops, * remember * .

Chris Coulson (chrisccoulson) wrote :

That looks normal. I still can't recreate this here on the guest session though

Jacopo Moronato (jmoronat) wrote :

I'm testing with latest Natty daily iso. Firefox claims it's not the default browser everywhere: in Live session user and also after installation (guest session or normal user session).

Mike (bild85) wrote :

Confirming here too: Alpha 3, 64-bit for Intel-Mac. Happens in regular user session. I created a link within the terminal and clicked on it, and it opened within Firefox. So Firefox clearly IS the default browser - it just doesn't know it yet.

Mike (bild85) wrote :

Since the guest session doesn't remember settings, it will pop up this message each time Guest is accessed.

summary: - Firefox in guest session claims that it's not my default browser
+ Firefox claims that it's not my default browser; repeatedly in guest
+ session too
Chris Coulson (chrisccoulson) wrote :

Ok, I see what happens, but I'm not sure of the best way to fix it.

Changed in firefox (Ubuntu):
status: Incomplete → Triaged
Chris Coulson (chrisccoulson) wrote :

There is actually a second bug here, and that is that Firefox is doing the default browser check at all. We turn that check off entirely, so I'm not sure why it's ignoring that.

Chris Coulson (chrisccoulson) wrote :

Ok, it seems we actually dropped a change from gnome-vfs to set the default browser to firefox, which some legacy apps still depend on (and this is why firefox thinks it isn't the default browser)

Changed in gnome-vfs (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

The firefox task is kept open just for disabling the default browser check. This isn't actually a firefox bug

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-vfs - 1:2.24.4-0ubuntu4

---------------
gnome-vfs (1:2.24.4-0ubuntu4) natty; urgency=low

  * Also handle the "%U" placeholder to really fix LP: #739416
    - update debian/patches/31_gio_uri_placeholder.patch
  * Fix LP: #732792 - Firefox in guest session claims that it's not my
    default browser. Ensure we set Firefox as the default in gnomevfs too
    - update debian/libgnomevfs2-common.gconf-defaults
 -- Chris Coulson <email address hidden> Thu, 24 Mar 2011 17:59:24 +0000

Changed in gnome-vfs (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers