MASTER Crash with totem when opening an MPG link [@_destroystream] [@NP_Initialize]

Bug #71315 reported by Miguel Paraz
22
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Mozilla Bugs

Bug Description

1. Clicked on one of the .mpg links here:
http://m-ph.com/downloads/
2. Document window goes black, then a popup: totem could not play fd://0 ... you do not have a decoder ...
3. I can't remember exactly since I could not replicate: Only Firefox title bar remains, I believe totem was mentioned there. No document window.
4. After a few seconds, the crash dump prompt comes up.

When I tried it again, I got #2, but the black screen had the player controls.

Revision history for this message
Miguel Paraz (mparaz) wrote :
David Farning (dfarning)
Changed in firefox:
assignee: nobody → mozillateam
importance: Undecided → Medium
Revision history for this message
John Vivirito (gnomefreak) wrote :

Sounds like you dont have all the codecs installed. Please see: https://help.ubuntu.com/community/RestrictedFormats
for the ones you are missing.

Changed in firefox:
status: Unconfirmed → Needs Info
Revision history for this message
Alexander Sack (asac) wrote :

importance high, as crashing a common use case like video is not acceptable.

Changed in firefox:
importance: Medium → High
Revision history for this message
John Vivirito (gnomefreak) wrote :

Taking for retrace. Thank you.

Changed in firefox:
assignee: mozillateam → gnomefreak
Revision history for this message
John Vivirito (gnomefreak) wrote :

Stacktrace

Revision history for this message
John Vivirito (gnomefreak) wrote :

threadstack

Revision history for this message
John Vivirito (gnomefreak) wrote :

Trace done

Changed in firefox:
assignee: gnomefreak → mozillateam
Revision history for this message
Mike Mariano (mikemariano) wrote : Totem Crash with MOV link

I had a nearly identical experience with an MOV file here:

http://www.gametrailers.com/player.php?id=17125&type=mov&pl=game

I left-clicked instead of downloaded, Totem started, and Firefox crashed without any error messages at all.

David Farning (dfarning)
Changed in firefox:
assignee: mozillateam → mozilla-bugs
Revision history for this message
John Vivirito (gnomefreak) wrote : Re: Crash with totem when opening an MPG link

Taking to retrace last report.

Changed in firefox:
assignee: mozilla-bugs → gnomefreak
Revision history for this message
John Vivirito (gnomefreak) wrote :
Revision history for this message
John Vivirito (gnomefreak) wrote :
Revision history for this message
John Vivirito (gnomefreak) wrote :

Finished retrace.

Changed in firefox:
assignee: gnomefreak → mozilla-bugs
Revision history for this message
John Vivirito (gnomefreak) wrote :

Mike Mariano while reading over the stacktraces on this bug report, Yours doesnt give us enough info to process it. If you can reproduce this please file a bug report for new crash and attach the crash report. sorry for the inconveince.

Revision history for this message
John Vivirito (gnomefreak) wrote :

Im taking this back i want to try something

Changed in firefox:
assignee: mozilla-bugs → gnomefreak
Revision history for this message
John Vivirito (gnomefreak) wrote :

Not able to get a retrace Mike Mariano's crash report. Assigning back to mozilla-team. Leaving as mt-needsummary.

Changed in firefox:
assignee: gnomefreak → mozilla-bugs
Revision history for this message
John Vivirito (gnomefreak) wrote :

Mike can you please file a new bugreport with your crash report attached.

Revision history for this message
Alexander Sack (asac) wrote :

master move to confirmed.

Changed in firefox:
status: Needs Info → Confirmed
Revision history for this message
Alexander Sack (asac) wrote :

we haven't seen any new dupes for a while, so this appears to be fixed (at least in ffox 3).

Changed in firefox:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers