firefox refuses to start and pretend to be already running

Bug #693396 reported by yves GUILLON on 2010-12-22
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Unassigned

Bug Description

Here are the messages
Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

(firefox-bin:2686): GLib-WARNING **: g_set_prgname() called multiple times
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value "((GString*) 0xb4948d60)" of type `GString'

I have had to find the way for changing default browser in order to be abble to send this report (with firefow as default, no report could be sent.

My system results from an update of xubuntu 904 to xubuntu 910

Maybe the minor environment error about colour installation results in a wrong error treatment doubling the call to firefox ??
Note that thunderbird also pretends to be called twice but does start
(thunderbird-bin:3006): GLib-WARNING **: g_set_prgname() called multiple times

ProblemType: Bug
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ygxubuntu 2371 F.... xfce4-mixer-plu
                      ygxubuntu 2411 F.... xfce4-volumed
                      ygxubuntu 2413 F.... pulseaudio
CRDA: Error: [Errno 2] Aucun fichier ou dossier de ce type
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7eb8000 irq 16'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,1043831a,00100004'
   Controls : 12
   Simple ctrls : 7
Date: Wed Dec 22 14:56:21 2010
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=2c73af53-7939-44b1-9b03-76274c4de4c6
MachineType: ASUSTeK Computer INC. 901
Package: linux-image-2.6.31-22-generic 2.6.31-22.69
ProcCmdLine: root=UUID=42e3bc91-5120-438c-b12c-7d7a8bb5d4a0 ro quiet splash
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-22.69-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-22-generic N/A
 linux-firmware 1.26
SourcePackage: linux
Uname: Linux 2.6.31-22-generic i686
WpaSupplicantLog:

dmi.bios.date: 05/13/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2001
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 901
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2001:bd05/13/2009:svnASUSTeKComputerINC.:pn901:pvrx.x:rvnASUSTeKComputerINC.:rn901:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 901
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

yves GUILLON (guillon-yves) wrote :
yves GUILLON (guillon-yves) wrote :

standard users may have the bug without being able to report because of default reporting process through failing firefox call

I may not be the only guy with this problem

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have the correct package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in firefox.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: linux (Ubuntu) → firefox (Ubuntu)
Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make ubuntu better. Could you please try to reproduce this issue in a clean profile (no extensions, plugins, theme changes, etc.)? You can do this by using the below:

Start Firefox by entering the following command is a terminal: firefox -ProfileManager. You should now see the Profile Manager window.

Important note: From the Profile Manager you are also able to remove and rename profiles. Be very careful when deleting profiles, if you created the profile in a directory that already existed, the entire directory will be removed!

Click on the 'Create Profile...' button to start the 'Create Profile Wizard'. Click 'Next' and enter a descriptive name for the new profile. Click Finish to have Firefox create the new profile. You should now be taken back to the Profile Manager and the newly created profile should be listed. Select it and click 'Start Firefox'. Try to reproduce the bug with this new profile.

Note: you can go back to your own profile by starting Firefox using the command firefox -ProfileManager again, selecting your own profile, and clicking on 'Start Firefox'.

Please let us know by comment here if this is reproducable with the clean profile.

Changed in firefox (Ubuntu):
status: New → Incomplete

L'essai demandé donne le résultat reproduit dans le fichier texte joint;
pas de succès avec un profil firefox propre.

Noter que le lancement de thunderbird via console, produit un début de
message similaire à celui de firefox, mais que thunderbird se lance tout
de même. La copie de console se trouve en fin du fichier joint.

Pour mémoire, mon système 9.04 xubuntu résulte d'une migration
automatique depuis le 8.04, peut-être y a-t-il dans la configuration
xubuntu quelque-chose qui fait doublon avec ce que donne la migration
automatique prévue pour gnome. ??

Charlie Kravetz a écrit :
> Thank you for taking the time to report this bug and helping to make
> ubuntu better. Could you please try to reproduce this issue in a clean
> profile (no extensions, plugins, theme changes, etc.)? You can do this
> by using the below:
>
> Start Firefox by entering the following command is a terminal: firefox
> -ProfileManager. You should now see the Profile Manager window.
>
> Important note: From the Profile Manager you are also able to remove and
> rename profiles. Be very careful when deleting profiles, if you created
> the profile in a directory that already existed, the entire directory
> will be removed!
>
> Click on the 'Create Profile...' button to start the 'Create Profile
> Wizard'. Click 'Next' and enter a descriptive name for the new profile.
> Click Finish to have Firefox create the new profile. You should now be
> taken back to the Profile Manager and the newly created profile should
> be listed. Select it and click 'Start Firefox'. Try to reproduce the bug
> with this new profile.
>
> Note: you can go back to your own profile by starting Firefox using the
> command firefox -ProfileManager again, selecting your own profile, and
> clicking on 'Start Firefox'.
>
> Please let us know by comment here if this is reproducable with the
> clean profile.
>
> ** Changed in: firefox (Ubuntu)
> Status: New => Incomplete
>
>

yves GUILLON (guillon-yves) wrote :
Download full text (4.1 KiB)

L'essai demandé donne le résultat reproduit dans le fichier texte joint;
pas de succès avec un profil firefox propre.

Noter que le lancement de thunderbird via console, produit un début de
message similaire à celui de firefox, mais que thunderbird se lance tout
de même. La copie de console se trouve en fin du fichier joint.

Pour mémoire, mon système 9.04 xubuntu résulte d'une migration
automatique depuis le 8.04, peut-être y a-t-il dans la configuration
xubuntu quelque-chose qui fait doublon avec ce que donne la migration
automatique prévue pour gnome. ??

Comme le message m'est revenu sans pièce jointe, je le renvoie en
copiant le contenu de la pièce jointe dans le message .

"
sur la console, le start firefox donne ceci :

ygb@ygEeePC901xubuntu:/media/VerbatimP2ext2/ygb/Bureau$ firefox
-ProfileManager

(firefox-bin:3176): GLib-WARNING **: g_set_prgname() called multiple times
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve
property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file
value "((GString*) 0xb4acddb0)" of type `GString'
ygb@ygEeePC901xubuntu:/media/VerbatimP2ext2/ygb/Bureau$

et il s'affiche une boite avec le message suivant :

Firefox cannot use the profile "test-alr-run" because it is in use.
To continue, close the running instance of Firefox or choose a different
profile.

Une reprise depuis console après fermeture de la boite profile manager
donne ceci, avec le même message de blocage.
ygb@ygEeePC901xubuntu:/media/VerbatimP2ext2/ygb/Bureau$ firefox &
[1] 3217
ygb@ygEeePC901xubuntu:/media/VerbatimP2ext2/ygb/Bureau$
(firefox-bin:3226): GLib-WARNING **: g_set_prgname() called multiple times
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve
property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file
value "((GString*) 0xb4a5adb0)" of type `GString'

la ssortie par controleC donne :
^C
[1]+ Done firefox
ygb@ygEeePC901xubuntu:/media/VerbatimP2ext2/ygb/Bureau$

Noter qu'un lancement de thunderbird via console semble donner le même
incident au début, mais le logiciel se lance tout de même.

ygb@ygEeePC901xubuntu:/media/VerbatimP2ext2/ygb/Bureau$ thunderbird

(thunderbird-bin:3280): GLib-WARNING **: g_set_prgname() called multiple
times
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve
property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file
value "((GString*) 0xb253500)" of type `GString'

** (thunderbird-bin:3280): CRITICAL **: murrine_style_draw_focus:
assertion `height >= -1' failed

** (thunderbird-bin:3280): CRITICAL **: murrine_style_draw_focus:
assertion `height >= -1' failed
ygb@ygEeePC901xubuntu:/media/VerbatimP2ext2/ygb/Bureau$

"

********** Fin des essais

Charlie Kravetz a écrit :
> Thank you for taking the time to report this bug and helping to make
> ubuntu better. Could you please try to reproduce this issue in a clean
> profile (no extensions, plugins, theme changes, etc.)? You can do this
> by using the below:
>
> Start Firefox by entering the following command is a terminal: firefox
> -ProfileManager. You should now see the Profile Manager window.
>
> Important ...

Read more...

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

The reporter was able to reproduce this issue using a clean firefox profile.

Thanks for taking the time to make Ubuntu better!

Changed in firefox (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
marcus aurelius (adbiz) wrote :

i get this error message often after closing down firefox then restarting.
i have to restart ubuntu to clear the error before it would load.
i has been happening for quite awhile now, maybe 4 months.

yves GUILLON (guillon-yves) wrote :

My problem (no access to firefox under Xubuntu 804) has been solved in
may 2011 by reinstallation of firefox AND ubufox.
It seems that some software for gnome had not been installed or had been
removed after attempt to add and later remove nautilus file browser to
Xubuntu desk.

I mau look back in my logs to see exactly when access has been recovered
if needed by someone.

Yves GUILLON

Le 30/09/2011 00:41, marcus aurelius a écrit :
> i get this error message often after closing down firefox then restarting.
> i have to restart ubuntu to clear the error before it would load.
> i has been happening for quite awhile now, maybe 4 months.
>

Thomas Schweikle (tps) wrote :

This is related to the problem double clicking firefox icon if it starts firefox with only one click. Firefox is started twice in such cases, one instance failing to lock the profile.
After starting firefox there is a window of about 200ms you can start additional firefox instances all trying to get exclusive access to the active profile. later additionaly started firefox instances do what is expected: open a new tab within the running instance.
Firefox locks the profile way to late. This has to be done way further within the startup and initialization code ...

Changed in firefox (Ubuntu):
status: Triaged → Fix Released

@Charlie Kravetz
It looks like the recent change from Triaged to Fix Released was in error. Since only triagers/developers can set Triaged status, it looks like it falls on you to fix this.

Changed in firefox (Ubuntu):
status: Fix Released → Triaged
Simon P. (simpre) on 2012-11-18
Changed in firefox (Ubuntu):
status: Triaged → Confirmed
yves GUILLON (guillon-yves) wrote :

I mailed a message telling it become OK after an update thta
reintroduced an adequate version of ubuntufox or something like this. I
dont remember exactly, and can't find the message as I don't from which
computer I mailed it.

Present problems with Firefox are on AMD64 version for ubuntu 10 and 12
where access to links included in mail by thunderbird do not open in
firefox.
It has been corrected in october but correction disapeared with versions
10.0.2 of thunderbird or firefox.

Le 18/11/2012 18:57, Simon P. a écrit :
> ** Changed in: firefox (Ubuntu)
> Status: Triaged => Confirmed
>

Drey (drey) wrote :

Same here on Ubuntu 12.10 64-bit FF18
When i try to open firefox, sometimes it hangs (nothing happens), so i have to kill it with system monitor (there are 2 firefox processes there) and open again.

To post a comment you must log in.