Gecko/00000000 in Firefox's user agent string

Bug #68459 reported by Marek Stepien on 2006-10-26
4
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Medium
firefox (Ubuntu)
Low
Mozilla Bugs

Bug Description

Binary package hint: firefox

This is Ubuntu's Firefox UA string:

Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.8.1) Gecko/0000000000 Firefox/2.0 (Ubuntu-edgy)

This means the Build ID is probably set to these zeroes... It usually should contain the build date.

Alternatively, the same information can be generated and placed elsewhere, as I
hear there are implications to layout link performance.

See also related: bug 26798 & bug 37484 . Perhaps we should take this moment to
replace the current build id with something a bit less flawed? I'm always a bit
concerned when someone wants to use the build id to distinguish between builds
when the build id not a unique identifier (by itself).

The date portion of the UA was intended to be a "source" date, not a build date.
If it were generated as part of the *checkout* target it would not cause undue
extra linkage in layout.

On the plus side developer builds would have meaningful and consistent build
ID's. On the down side there might not be a way to distinguish official release
"re-spins". Does that happen often enough (without re-pulling) to matter?

We're gonna need a different date for "gecko" and for the "app" anyway, once we
separate the build. The gecko buildid should be used for the useragent, but the
app buildid (probably on uniqueness-crack) should be used for profile-uniqueness.

Any progress here?

Marek Stepien (marek-stepien) wrote :

Binary package hint: firefox

This is Ubuntu's Firefox UA string:

Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.8.1) Gecko/0000000000 Firefox/2.0 (Ubuntu-edgy)

This means the Build ID is probably set to these zeroes... It usually should contain the build date.

Adam Guthrie (ispiked) wrote :

I'm pretty sure this is because Firefox is not using official branding (which results in the build ID getting set to all 0s). Mozilla bug 244485 is related.

Jonh Wendell (wendell) on 2007-01-23
Changed in firefox:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Jonh Wendell (wendell) wrote :

Actually, the USER_AGENT in feisty is right, but if you type about: in location bar, you'll see the wrong build id.

Changed in firefox:
status: Unknown → In Progress
Alexander Sack (asac) wrote :

reconfirm. Need to eval to fix this.

Changed in firefox:
assignee: nobody → mozillateam
David Farning (dfarning) on 2007-02-24
Changed in firefox:
assignee: mozillateam → mozilla-bugs
Alexander Sack (asac) wrote :

released a fix for feisty in upload: 2.0.0.2+1-0ubuntu1

Changed in firefox:
status: Confirmed → Fix Released

2 years and no update? This is still a problem with the current Minefield Build on Win XP SP2.

It happened to me today while doing Litmus testing.

In Minefield:
Help>About Minefield comes back with a build ID of 20070308, which is 2 numbers short of the 10 digit number required.

about: in the address bar returns 0000000000.

litmus.mozilla.org reports 0000000000 as the build ID as well.

Changed in firefox:
status: In Progress → Confirmed

With all the build ID changes in last couple of months, is this still an issue?

This was fixed by bug 383167.

Changed in firefox:
status: Confirmed → Fix Released
Changed in firefox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.