Firefox doesnt remember geometry (and position) of window

Bug #65841 reported by michelem on 2006-10-13
6
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Mozilla Team
Nominated for Edgy by michelem
Nominated for Feisty by michelem

Bug Description

Binary package hint: firefox

If I start a firefox I aspect that it will open with last geometry/position window, but this doesnt happen.
I installed firefox-gnome-support but no way.

Chris Burgan (cburgan) wrote :

Thanks for your report.

This isn't really a bug but more of a feature request so I will mark it as wishlist.

Changed in firefox:
importance: Undecided → Wishlist
John Vivirito (gnomefreak) wrote :

Can you please give us the version of ubuntu and the full version of firefox. see apt-cache policy firefox.

This seems to be related to https://bugzilla.mozilla.org/show_bug.cgi?id=314809
can you please confirm this is your issue Michelem? If not do you see your exact issue at: https://bugzilla.mozilla.org/buglist.cgi?quicksearch=window+position

Changed in firefox:
assignee: nobody → mozillateam
status: Unconfirmed → Needs Info
John Vivirito (gnomefreak) wrote :

This doesnt seem to be a wishlist bug but more of a annoying bug.

Changed in firefox:
importance: Wishlist → Undecided
michelem (michele-marcucci) wrote :

I'm sorry but the "bug" isnt more present when I upgraded to Feisty Fawn, so I dont know what was the version in Edgy when i submitted the report.
Now the geometry is correct but not the position, it always start at 0,0, the version is:

firefox:
  Installed: 2.0.0.1+1-0ubuntu1
  Candidate: 2.0.0.1+1-0ubuntu1
  Version table:
 *** 2.0.0.1+1-0ubuntu1 0
        500 http://de.archive.ubuntu.com feisty/main Packages
        100 /var/lib/dpkg/status

Alexander Sack (asac) on 2007-02-20
Changed in firefox:
status: Needs Info → Fix Released
Doug Holton (edtechdev) wrote :

I am seeing this bug with Ubuntu Feisty.

Close firefox (or thunderbird) and open them again, and they do not appear in the same place they were.

I saw these instructions from 2006 for some kind of "advanced window settings" option in gnome, but there was no such option when right clicking on the title bar of a window or clicking on the title icon:
http://ubuntuforums.org/archive/index.php/t-36505.html%3C/t-199815.html

I was going to report it as a firefox/thunderbird bug (missing feature), but they apparently explicitly don't include the window saving/loading state code in their unix builds, since "since "unix types seem to prefer that Mozilla not override the window positioning provided by their window managers":
https://bugzilla.mozilla.org/show_bug.cgi?id=31086

So the question is, is there still some kind of "advanced settings" where I can have gnome remember window positions, and where are they. Please enable the saving of window position by default in Gutsy if the functionality is already there.

On Fri, Jul 06, 2007 at 02:46:54AM -0000, DH wrote:
> I am seeing this bug with Ubuntu Feisty.
>
> Close firefox (or thunderbird) and open them again, and they do not
> appear in the same place they were.
>
> I saw these instructions from 2006 for some kind of "advanced window settings" option in gnome, but there was no such option when right clicking on the title bar of a window or clicking on the title icon:
> http://ubuntuforums.org/archive/index.php/t-36505.html%3C/t-199815.html
>
> I was going to report it as a firefox/thunderbird bug (missing feature), but they apparently explicitly don't include the window saving/loading state code in their unix builds, since "since "unix types seem to prefer that Mozilla not override the window positioning provided by their window managers":
> https://bugzilla.mozilla.org/show_bug.cgi?id=31086
>
> So the question is, is there still some kind of "advanced settings"
> where I can have gnome remember window positions, and where are they.
> Please enable the saving of window position by default in Gutsy if the
> functionality is already there.
>

For me gnome doesn't remember position of windows at all ... though I
just tried with gnome-terminal.

Does it work for you for non firefox applications?

 - Alexander

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.