Ubuntu

Mozilla Firefox prints at 300dpi by default

Reported by Laurence Smart on 2010-07-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

Using CUPS and printing to a Samsung SCX-4521F multi-function printer, Firefox always send document as 300dpi. Printer default is 600dpi and all other programs send print jobs at 600dpi. Problem started in the previous version of Ubuntu. Upgraded to latest version of Ubuntu this week but still prints at 300dpi.

Haven't found and way to rectify problem by searching forums and help on the Internet.

Using Firefox 3.6.6 now. Problem has not been solved with upgrades to Firefox either.

Thanks.

Laurence

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: firefox 3.6.6+nobinonly-0ubuntu0.10.04.1
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Jul 16 08:32:42 2010
FirefoxPackages:
 firefox 3.6.6+nobinonly-0ubuntu0.10.04.1
 firefox-gnome-support 3.6.6+nobinonly-0ubuntu0.10.04.1
 firefox-branding 3.6.6+nobinonly-0ubuntu0.10.04.1
 abroswer N/A
 abrowser-branding N/A
ProcEnviron:
 LANG=en_AU.utf8
 SHELL=/bin/bash
SourcePackage: firefox

Laurence Smart (laurencesmart) wrote :
Laurence Smart (laurencesmart) wrote :

Fix provided upstream in Firefox bug tracker:
http://support.mozilla.com/en-US/forum/1/504098

"As user, open a shell and enter:
lpoptions -o Resolution=600dpi

This will add a default resolution to ~/.cups/lpoptions"

After following these instructions, Firefox prints to 600DPI by default.

Micah Gersten (micahg) wrote :

Thank you for reporting this to Ubuntu. Sometimes Firefox profiles can become corrupt and/or extensions can conflict. Could you please try this with a new profile and see if the problem still exists? You do not need to delete your old profile to test. If this helps, you might want to try to disable all your extensions and re-enable them one by one until you find the problematic one.

You can start the profile manager with the following command when Firefox is closed:
firefox -ProfileManager

Changed in firefox (Ubuntu):
status: New → Incomplete
Chris Smart (csmart) wrote :

I also tested this with my profile and a fresh profile and the issue remains the same. I also downloaded Firefox direct from Mozilla and the issue remains the same, so it's not an Ubuntu bug, it's just the way Mozilla has coded Firefox to select the default print DPI resolution - grabbing the lowest value. The fix posted by Laurence solved the problem for me.

I think this can be closed.

-c

Launchpad Janitor (janitor) wrote :

[Expired for firefox (Ubuntu) because there has been no activity for 60 days.]

Changed in firefox (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers