Opening url from external app on different workspace, doesn't open url on the current workspace.

Bug #60069 reported by lexual on 2006-09-12
4
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Wishlist
Mozilla Bugs

Bug Description

Steps to reproduce.
Have firefox running on one of gnome's workspace.
Run evolution on a different workspace.
Click on an url from within evolution.
url will open as a new tab in existing firefox in different workspace.

Unless the user realizes that the url has been opened in another workspace, they may think that the url has opened and either continue clicking on the link, or just assume that the program is broken.

I'm running latest edgy with firefox 1.99 and gnome 2.16

Yes, this is a problem. I have several workspaces; one for private mail, media, fun and games. Another for programming, where I have my testsites, html editors, etc. If I opened firefox in the Private workspace and then switch to the Programming workspace, then when I click links in the Programming workspace, they are opened in firefox in the Private workspace. This makes it look as if nothing happened.

It would be very nice if a new instance of Firefox was created on each workspace and "closest" instance is used. That is to say, if I click a link in the Programming workspace, then the Programming instance of Firefox is used.

Michael Broadbent (mikebro) wrote :

I can reproduce this with the following steps:
1) Open Firefox on Desk 1
2) Open Epiphany on Desk 2
3) Open up an E-mail with a web link in it
4) Click the link

Result: The link opens in a new tab on Desk 1.

If you open an instance of Firefox before you click a link on Epiphany it will open the link on the current desk.

I am marking this as Confirmed and Wishlist because some people would prefer to have all their tabs open in one place and others would like it to open an instance on each desk.

Thanks for your suggestion. The changes you are requesting require more discussion, which should be done on an appropriate mailing list or forum. http://www.ubuntu.com/community/forums/ might be a good start.

Changed in firefox:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Changed in firefox:
assignee: nobody → mozilla-bugs
Rolf Leggewie (r0lf) wrote :

This is fixed at least in gutsy and hary. There is a blinking window on the gnome task bar. Once clicked, one is taken to the other work space and the FF window there.

Changed in firefox:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers