package firefox 3.6.6+nobinonly-0ubuntu0.10.04.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Bug #599978 reported by Achilles
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Fix Released
Low
Unassigned

Bug Description

Binary package hint: firefox

I have created the symbolic link /usr/bin/firefox -> /usr/lib/firefox-3.6.6/firefox.sh that solved a similar problem in previous upgrades, but something else seems to be wrong this time.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: firefox 3.6.6+nobinonly-0ubuntu0.10.04.1
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
Architecture: amd64
Date: Tue Jun 29 16:52:29 2010
ErrorMessage: subprocess installed post-installation script returned error exit status 2
FirefoxPackages:
 firefox 3.6.6+nobinonly-0ubuntu0.10.04.1
 firefox-gnome-support 3.6.6+nobinonly-0ubuntu0.10.04.1
 firefox-branding 3.6.6+nobinonly-0ubuntu0.10.04.1
 abroswer N/A
 abrowser-branding N/A
SourcePackage: firefox
Title: package firefox 3.6.6+nobinonly-0ubuntu0.10.04.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Revision history for this message
Achilles (aalmansi) wrote :
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

I'm not really sure how this is possible. The firefox package ships the /usr/bin/firefox symlink, this hasn't changed in ages and you seem to be the only person with this problem.

Could you please post the output of "ls -l /usr/bin/firefox" and "dpkg -L firefox", and also attach your /var/lib/dpkg/diversions.

Thanks

Changed in firefox (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Achilles (aalmansi) wrote : Re: [Bug 599978] Re: package firefox 3.6.6+nobinonly-0ubuntu0.10.04.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
Download full text (3.8 KiB)

ls -l /usr/bin/firefoxlrwxrwxrwx 1 root root 33 2010-06-29 16:59 /usr/bin/firefox ->
 /usr/lib/firefox-3.6.6/firefox.sh
/var/lib/dpkg/diversions:

/bin/sh/bin/sh.distribdash/usr/share/man/man1/sh.1.gz/usr/share/man/man1/sh.distrib.1.gzdash/usr/share/dict/words/usr/share/dict/words.pre-dictionaries-commondictionaries-common/usr/share/dbus-1/services/org.freedesktop.Notifications.service/usr/share/dbus-1/services/org.freedesktop.Notifications.service.notify-osdnotify-osd/usr/bin/screen/usr/bin/screen.realscreen-profiles/usr/bin/gnuplot/usr/bin/gnuplot-noxgnuplot-x11/usr/share/man/man1/gnuplot.1.gz/usr/share/man/man1/gnuplot-nox.1.gzgnuplot-x11/usr/bin/firefox/usr/bin/firefox.ubuntu:/usr/bin/mozilla-firefox/usr/bin/mozilla
-firefox.ubuntu:/usr/share/vim/vim72/doc/help.txt/usr/share/vim/vim72/doc/help.txt.vim-tinyvim-runtime/usr/share/vim/vim72/doc/tags/usr/share/vim/vim72/doc/tags.vim-tinyvim-runtime/usr/lib/gnupg/gpgkeys_curl/usr/lib/gnupg/gpgkeys_curl.non_curlgnupg-curl/usr/lib/gnupg/gpgkeys_hkp/usr/lib/gnupg/gpgkeys_hkp.non_curlgnupg-curl/usr/share/gnome-games/pixmaps/slot.svg/usr/share/gnome-games/pixmaps/slot.svg.unbrandedbranding-ubuntu/usr/share/gnome-games/pixmaps/baize.png/usr/share/gnome-games/pixmaps/baize.png.unbrandedbranding-ubuntu/usr/share/gnome-games/mahjongg/pixmaps/postmodern.svg/usr/share/gnome-games/mahjongg/pixmaps/postmodern.svg.unbrandedbranding-ubuntu/usr/share/gnome-games/gnometris/pixmaps/gnometri
s.svg/usr/share/gnome-games/gnometris/pixmaps/gnometris.svg.unbrandedbranding-ubuntu/usr/share/gnome-games-common/cards/gnomangelo_bitmap.svg/usr/share/gnome-games-common/cards/gnomangelo_bitmap.svg.unbrandedbranding-ubuntu
--- On Tue, 6/29/10, Chris Coulson <email address hidden> wrote:

From: Chris Coulson <email address hidden>
Subject: [Bug 599978] Re: package firefox 3.6.6+nobinonly-0ubuntu0.10.04.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
To: <email address hidden>
Date: Tuesday, June 29, 2010, 6:12 PM

I'm not really sure how this is possible. The firefox package ships the
/usr/bin/firefox symlink, this hasn't changed in ages and you seem to
 be
the only person with this problem.

Could you please post the output of "ls -l /usr/bin/firefox" and "dpkg
-L firefox", and also attach your /var/lib/dpkg/diversions.

Thanks

** Changed in: firefox (Ubuntu)
   Importance: Undecided => Low

** Changed in: firefox (Ubuntu)
       Status: New => Incomplete

--
package firefox 3.6.6+nobinonly-0ubuntu0.10.04.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
https://bugs.launchpad.net/bugs/599978
You received this bug notification because you are a direct subscriber
of the bug.

Status in “firefox” package in Ubuntu: Incomplete

Bug description:
Binary package hint: firefox

I have created the symbolic link  /usr/bin/firefox ->
 /usr/lib/firefox-3.6.6/firefox.sh that solved a similar problem in previous upgrades, but something else seems to be wrong this time.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: firefox 3.6.6+nobinonly-0ubuntu0.10.04.1
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2...

Read more...

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

You have some diverts there which is causing dpkg to install the /usr/bin/firefox symlink to /usr/bin/firefox.ubuntu. I'm not sure where you've got that from, but that's not a bug with our Firefox package

Changed in firefox (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Kees Cook (kees) wrote :

Google seems to show something called "ubuntuzilla" doing it. And the
diversion seems to be a long-standing recommendation, for better or worse:
http://www.google.com/search?hl=en&q="%2Fusr%2Fbin%2Ffirefox.ubuntu"

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 4.0~b12+build1+nobinonly-0ubuntu2

---------------
firefox (4.0~b12+build1+nobinonly-0ubuntu2) natty; urgency=low

  * Fix some typos in the manpage
    - update debian/firefox.1.in
  * Fix up the mess left by Ubuntuzilla rather than leaving our official
    package in a broken and inconsistent state, which ends up with users
    reporting bugs to Launchpad and giving us a bad reputation. If
    /usr/bin/firefox has been diverted and there is no /usr/bin/firefox
    provided on the system, just do the job of whatever package it was that
    broke the users install and remove the diversion for them. This should
    hopefully stop the frequently reported bugs we get from Ubuntuzilla users
    about /usr/bin/firefox being missing
    - update debian/firefox.postinst.in
    - Fixes LP: #512937, LP: #529136, LP: #552919, LP: #572733, LP: #574111,
      LP: #599978, LP: #600271, LP: #610522, LP: #610756, LP: #610907,
      LP: #612162, LP: #620400, LP: #623980, LP: #625014, LP: #630643,
      LP: #635166, LP: #638342, LP: #641838, LP: #658828, LP: #668809,
      LP: #672282, LP: #676239, LP: #707704, LP: #724090
  * Don't allow users to report bugs with apport-bug when /usr/bin/firefox
    has been diverted
    - update debian/firefox.py.in
  * Don't build with --disable-elfhack on armel. It's been fixed now
    - update debian/rules
 -- Chris Coulson <email address hidden> Fri, 25 Feb 2011 13:54:59 +0000

Changed in firefox (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers