[edgy Knot-2 CD] firefox's fonts are uglified (not antialiased)

Bug #58511 reported by Michael R. Head on 2006-09-01
60
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

I boot the Edgy Knot-2 CD on this Thinkpad T22 w/ S3 Inc. 86C270-294 Savage/IX-MV video chipset, and when I launch firefox, the fonts are not antialiased, despite other applications' fonts being so. Will attach a screenshot.

Michael R. Head (burner) wrote :

BTW: this is version 1.99+2.0b1+dfsg-1ubuntu3

Michael R. Head (burner) wrote :

OK, I see now that the fonts as setup by default are "Times", "Helvetica", and "Courier," which apparently aren't antialiasable? Once I changed the fonts in the firefox preferences to "serif", "sans-serif", and "monospace", everything was peachy.

John Vivirito (gnomefreak) wrote :

Closing due to it not being a bug but a setting that needed changing.

Changed in firefox:
status: Unconfirmed → Rejected
Corey Burger (corey.burger) wrote :

Confirming this is a bug. This is a regression from Dapper. Fonts have become much more unreadable.

Changed in firefox:
status: Rejected → Confirmed
Michael R. Head (burner) wrote :

Yeah, it's definitely a bug to have ugly fonts selected by default.

Hezekiah Carty (hez) wrote :

Fresh Knot-2 installation, same problem here. It also affects Epiphany - though it isn't fixable in Epiphany directly - changing the font settings make no difference.

Xavier (chantry-xavier) wrote :

I'll not try to argue, but just paste a few links instead :
http://daringfireball.net/2003/03/antiantialiasing
http://modeemi.cs.tut.fi/~tuomov/b/archives/2006/03/17/T20_15_31/
http://www.sabi.co.uk/Notes/anno06-2nd.html#060429
http://avi.alkalay.net/linux/docs/font-howto/Font.html#fix

I personally like bitmap fonts. ms fonts look very nice but it's a non go as a default.
So if you don't like bitmap fonts, we are unfortunately stuck with fonts which require antialiasing.
Though, it's probably better if ubuntu did not overwrite firefox fonts settings, since it's already using "Sans Serif" or "Serif" aliases by default, just like gnome or vanilla kde do.
This will probably makes use of DejaVu or Bitstream Vera fonts, using ubuntu's fontconfig settings.

Xavier (chantry-xavier) wrote :

Btw, this site seems to overwrite the fonts used, so the settings have no effect unless you disable "Allow web page to overwrite fonts" or something like this in firefox fonts preference.
After disabling it, (and setting Proportional to Sans Serif instead of Serif, and decreasing size from 16 to 14), it looks nicer to me.
I'm not sure which fonts this page use by default (the M is quite weird), and why it has changed.

Also, I don't know why, but I find that Helvetica looks less nice in some cases, like for this page on my current system, where it looks slightly bold. In this case, I prefer ms fonts like Arial or Verdana (these guys at least got one thing right...)

Suzan (suzan72) wrote :

In my opinion, it's a edgy bug!

As I tested Knot2 last week I was very shocked about the fonts in firefox!! New user will think "Linux is so ugly...." :-(

In dapper fonts look good, in edgy they are ugly. This is a bad step backwards...

this is a bug. fonts are really ugly and don't look the same compared to the rest of the system at all.
in fact, not only those fonts look out of place in GNOME, they look out of place compared the to menu bar of firefox itself (which is antialiased)!

The problem with no antialiasing is due to a bug in firefox's default configuration. In order to have antialiasing and hinting, these two settings must be defined in the global rcfile (or hard coded at compile time):

font.FreeType2.enable must be true (it is false now)
font.FreeType2.unhinted must be false (it is true now)

A *temporary fix* is to set those variables correctly in your personal settings by using about:config. This is certainly a bug in firefox's build (hopefully to be corrected with the Beta2 packages).

Another thing. For some reason, firefox is not using fontconfig's libraries. If you read fontconfig's default configuration you'll see that Serif, Sans and Monospace are mapped to Bistream Vera (btw, that *should* be Deja Vu instead, Debian has already done the transition, I think), Yet, firefox is using the X11 bitmaps for Arial, Helverica and Times.

rubinstein (rubinstein) wrote :

I want to add that the menu bar fonts of firefox are fuzzy compared to other gnome applications; look at the screenshot.

The solution by Pedro Alejandro López-Valencia doesn't work for me, the fonts look the same, are not antialiased.

Oskar, you still need to change the fonts from Times, Helvetica and Courier to different ones. I changed them to Serif, Sans-Serif and Monospace. (This is the reason behind my second comment above.)

rubinstein (rubinstein) wrote :

OK, I changed the fonts, now some are aliased and the rest is very fuzzy.

My other applications have beautiful antialiasing, antialiased firefox fonts in the menu and in the browser screen however are just fuzzy and look different than the rest of the desktop.

I forgot to check the obvious... This is a regresion in the default installation settings of fontconfig-setup. In all previous versions, bitmap files are *never* included by default, but in Edgy they are.

That is, if firefox finds bitmap fonts of the typefaces it wants, it obviously will use them. If not, it will use the next best thing (a substitute aliased in /etc/fonts.conf, be it a truetype or a type 1 font, whatever comes first).

capricorn (ubuntuuser82) wrote :

Fuzzy fonts in edgy's Firefox menu (and openoffice by the way) were gone, after I chose another option in System -> Preferences -> Fonts dialog (contrast), don't know why

Gert Kulyk (gkulyk) wrote :

For me the ugly menu fonts vanished after I added the line "MOZ_DISABLE_PANGO=0" in /etc/firefox/firefoxrc . I read somewhere that this setting is enabled per locale by default, at least german locale obiously does not enable it. Fonts in Epiphany (body affected) still are looking terrible (as described in https://launchpad.net/distros/ubuntu/+source/firefox/+bug/58511/comments/6 )

Fonts aren't anti-aliased in other applications too. The problem is the fonts themselves, more specifically the Lucida-family.

rubinstein (rubinstein) wrote :

I installed the edgy beta release, and the fonts in the menus and inside of firefox are still fuzzy and the antialiasation is still different to my remaining GNOME desktop.

Santiago Otero (jsotero) wrote :

I've got the same problem too. The menu fonts of firefox and openoffice are different. It seems like hinting in fontconfig is disable for firefox and openoffice.
If I disable hinting in fontconfig all my fonts look all the same.

Fixed on Edgy Eft Beta.

Changed in firefox:
status: Confirmed → Fix Released
Paolo Borelli (pborelli) wrote :

why has this been marked Fix Released? I still have the issue with the latest packages.

And I am not the only one, just quoting from two comments above:

> I installed the edgy beta release, and the fonts in the menus and inside of firefox are still > fuzzy and the antialiasation is still different to my remaining GNOME desktop.

> I still have the issue with the latest packages.
Maybe the way I boot GNOME is affecting the fonts, but I'm running a fresh install and the fonts are anti-aliased.

Changed to Need Info

Changed in firefox:
status: Fix Released → Needs Info

The fonts are correct on my two desktops. Fixed now?

Paolo Borelli (pborelli) wrote :

How can it be fixed? there have been no firefox updates.

> How can it be fixed? there have been no firefox updates.

As I mentioned before, the problem isn't in Firefox, but in the
fonts used.

rubinstein (rubinstein) wrote :

> The fonts are correct on my two desktops. Fixed now?

Unfortunately, no. I have a laptop and a desktop, on both the problem persists.

>As I mentioned before, the problem isn't in Firefox, but in the
>fonts used.

Yes, epiphany and gnome-terminal have the same problems (albeit the menus are OK.)

Michael R. Head (burner) wrote :

The bug as originally reported is fixed. That is, if you take the Beta Desktop CD and boot with it, you will now get antialiased fonts with firefox. I imagine if you installed from Knot-2, you might have to change your font settings in firefox.

Changed in firefox:
status: Needs Info → Fix Released
rubinstein (rubinstein) wrote :

>The bug as originally reported is fixed. That is,
>if you take the Beta Desktop CD and boot with it,
>you will now get antialiased fonts with firefox.

Yes, but the problem with different antialiased fonts remains. Should we file a new bug report or reopen this bug an rename it?

rubinstein (rubinstein) wrote :

Everybody who has different antialiased fonts should subscribe to:
Bug #63403 Semi-random ugly font rendering in Edgy
(https://launchpad.net/distros/ubuntu/+bug/63403)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers