firefox occasionally highlights contents of form fields while typing thereby overwriting previously entered keystrokes

Bug #583122 reported by Asif Rahman on 2010-05-20
226
This bug affects 52 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
New
Medium
firefox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: firefox

On occasion while typing into a form field in firefox (search field, url field, webpage form field), after typing a few characters, the browser will automatically highlight the previously entered characters, causing my subsequently entered keystrokes to overwrite the previously entered keystrokes. I cannot reproduce this behavior reliably, though it does happen quite often. There are various methods that I have used to make the problem go away, though none work reliably. These include closing the tab, hitting enter to cause a pageload, restarting the browser.

I am using Ubuntu 10.04. This problem was not present in Ubuntu 9.10 on the same hardware. The firefox package version is 3.6.3+nobinonly-0ubuntu4.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: firefox 3.6.3+nobinonly-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
Architecture: amd64
CheckboxSubmission: e8b67d75e6dc3e68647d9c34878edc73
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Wed May 19 20:21:20 2010
FirefoxPackages:
 firefox 3.6.3+nobinonly-0ubuntu4
 firefox-gnome-support 3.6.3+nobinonly-0ubuntu4
 firefox-branding 3.6.3+nobinonly-0ubuntu4
 abroswer N/A
 abrowser-branding N/A
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: firefox

Asif Rahman (asif-alumni) wrote :
Draycen DeCator (ddecator) wrote :

Thank you for reporting this to Ubuntu. Sometimes Firefox profiles can become corrupt and/or extensions can conflict. Could you please try this with a new profile and see if the problem still exists? You do not need to delete your old profile to test. If this helps, you might want to try to disable all your extensions and re-enable them one by one until you find the problematic one.

You can start the profile manager with the following command:
firefox -ProfileManager

Changed in firefox (Ubuntu):
status: New → Incomplete

I'm also affected, as are the people in this thread: http://ubuntuforums.org/showthread.php?t=1474728

I'm not able to intentionally reproduce it. Seems to only happen (to me) in one-line input boxes. It happens very rapidy in Gmail or Google Apps, but quite slowly in the Firefox search bar at the top-right. Often (in Gmail) I will type out an entire subject line, look up, and my subject line reads: "d" (or similar).

Occurs multiple times daily. Only happening since I installed 10.04 (fresh install, amd64 architecture).

I haven't been able to figure a reliable way to make it stop, but what I usually do is mash a combination of: esc, left cursor, right cursor, alt-tab, lCtrl, rCtrl, and my shift keys. Usually after a few seconds of this, it stops.

Sorry I can't provide any further info.

dsn0wman (josgray) wrote :

I am also affected by this bug. I can't fill out HTML input box's on many pages.

ex...

http://omikron.freeforum.ca/ucp.php?mode=register

This happens occasionally to me.

Most common with gmail subject line in a new email, and the google search bar at the top right. It's a little reminiscent of a "bug" on a banking website I used to use. I would load it up, the entry bar would become visible, I'd type most of the number during which time the rest of the page would load and suddenly clear the typing I'd done.

In gmail, when I'm writing a subject line and this starts, I basically have to alternate between a letter of the subject line and the right arrow (which moves the cursor to the end and de-selects the highlighted text).

I have this on two separate lap tops, both of which had 9.10, and were then upgraded to 10.04 (about a week before the release in both cases). The problem only started with 10.04, as far as I can tell.

Julian Haagsma (jhaagsma) wrote :

This also affects me; it appears to affect certain (one line) input boxes and not others (however it does not always happen), though there doesn't seem to be any correlation between the ones it affects; one is a "Subject" box in an internal company webpage, so it has been of considerable annoyance =( It does eventually go away with enough random moving around it seems.

I'm running 64 bit ubuntu 10.04.

Update to my bug report above. Seems to occur after returning from screensaver or a suspend. I've found that hitting Alt-Tab, Alt-Tab (as opposed to Alt-Tab-Tab) solves the problem until the next screensaver/suspend event.

Perhaps this is related to the Firefox bug posted here: https://bugs.launchpad.net/firefox/+bug/438868

Running 64-bit Ubuntu Lucid, 10.04, and Firefox 3.6.6.

Diaa Sami (diaa.sami) wrote :

Happens for me as well(in searchbox and input elements)
Kubuntu 10.04 freshly installed, Firefox 3.6.8

Daniel Dunér (daniel-duner) wrote :

The bug appears to be related to the suggestion feature and possibly the spelling-correction-feature. When you type something in a field, suggestions come up (based on what you have previously typed in the same or similar fields). When the described bug appears, the auto-suggestions stop working.

Suggested workarounds from http://ubuntuforums.org/showthread.php?p=9724642#post9724642:
• Right-click the search bar and uncheck "Show Suggestions"
• Go to "Preferences -> Advanced" and uncheck "Check my spelling as I type"

Daniel Dunér (daniel-duner) wrote :

This might be the same bug:
https://bugs.launchpad.net/firefox/+bug/438868

According to comment #94 (https://bugs.launchpad.net/firefox/+bug/438868/comments/94) and the following discussion, they could be related.

dolst (dolst-com) wrote :

Just wanted to chime in and let you know this bug affects me as well. I am running Ubuntu 10.04, Firefox 3.6.10 and the following Extensions:
Adblock Plus 1.2.2, Firebug 1.5.4, PDF Download 3.0.0.1, and Ubuntu Firefox Modifications 0.9rc2
I also have JavaScript Debugger 0.9.87.4 but it's grayed out, says it's not compatible with Firefox 3.6.10, and I can't seem to uninstall it either.

I regularly type things into the search bar with no problems. I don't recall ever having this affect my search bar. It does, however, affect random text inputs in HTML forms. The example that drove me to track this issue down is that I am currently adding email addresses to a system through Postfix Admin. When entering names and quota amounts, it does it almost all the time.

Anyway, I hope my information helps build a bigger picture of who is affected. Surf Wisely.

dolst (dolst-com) wrote :

I really hate to double-post, especially so soon, but I had a little more insight to add.
I find this bug only seems to happen when I tab to a field. When I click on the field with the mouse I have no problems. But if I tab to it from another field, it almost always does it. (Sometimes it just doesn't do it no matter what.)
But it has been consistent so far that it never does it when the field's focus results from a mouse click.
Just another piece of the puzzle. Surf Wisely.

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.10) Gecko/20100915 Ubuntu/10.04 (lucid) Firefox/3.6.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.10) Gecko/20100915 Ubuntu/10.04 (lucid) Firefox/3.6.10

While writing "search keyword" in the Search box on the Firefox version 3.6.1, the text written is automatically gets selected.

Hence, as the user tries to write further, the older text written gets lost.

Reproducible: Sometimes

Steps to Reproduce:
1.Start the Mozilla Firefox
2.Try writing into the google search box some keywords.

Actual Results:
The text gets selected writing automatically. hence, if continued writing the older text is lost.

Expected Results:
The text should not be selected automatically

I can confirm this behaviour in Ubuntu 10.10 with Firefox version 3.6.10+build1+nobinonly-0ubuntu3.

This bug has been filed on Launchpad at https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/641300 and is being tracked there. Any information regarding this bug can be asked for or found there if needed at all.

Thank you :)

Note: I have this problem without ANY extensions other than the default Ubuntu installed ones.
I have noticed something about this bug. When this happens the usual Google search terms that normally appear do not, and it is only when changing tabs or closing firefox and restarting it that it fixes itself, but when it does, the search terms appear again, so this may have something to do with that?

diego (marcodiegomesquita) wrote :

It looks like it is a compiz-related bug. Is anyone able to reproduce this bug without compiz enabled?

WSM (wsmpurchases) wrote :

This has been happening on my machine for quite a while, I think maybe even before 10.04. Currently I'm on 10.10 with Firefox 3.6.11.

Whatever the problem is you can stop it from happening for a while if you go just go into Edit - Preferences. I currently have it on the "Advanced Tab" just because i was thinking it was part of the spelling features, not sure if it matters. I used to turn spelling on and off but it seems all you have to do is open preferences.

Hope that helps.

exactt (giesbert) wrote :

This problem is occuring to many people. Just look at the duplicates and search at google. Maybe https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/597399 has some good explanation of what is going on.

I personally experience this problem for a long time now. probably since the release of 10.04 and still on 10.10. This is happening to me on many different machines.

FMaz (fmaz008) wrote :

I've also tried to:
- delete all the autocomplete values going in the preference, privacy, and delete the Form & Search History ONLY
- double click in the field and delete all the suggestion with the DEL key on hightlighted items
... and the problem disapeared in the problematic field, without even refreshing the tab.

I'm sorry I didn't test out between those 2 actions, but I think we're having a clue here...

Tony T (tonytovar) wrote :

it's probably something to do with the autocomplete, as that function 'disappears' while you're having the issue. Also, opening a new window will fix it (in the new window).

VERY ANNOYING, and how in the world can this bug be 'marked for expiration' when so many people are experiencing it?

Here's an idea for testing:

1. load about:config
2. change the setting for autocomplete.grab_during_popup from 'true' (default) to 'false'

Then wait and see if the problem goes away? I've just made the change to my own system but I have no idea how long I should wait before declaring victory in tracking the problem; I can go days and days between incidents. According to the MozDev page about these settings, http://preferential.mozdev.org/preferences.html , there is a known bug in mode switching?
"This option can be set to false to work around the bug where XKB does not set mode switching properly."
On the other hand, that page was last updated in Oct' 06 !

FMaz (fmaz008) wrote :

WORKARROUNG:

I just add the bug again and tested this step alone:
- delete all the autocomplete values going in the preference, privacy, and delete the Form & Search History ONLY
It worked without having to reload the page.

Jeff Lane (bladernr) wrote :

Marked it confirmed as it's been seen by enough people at this point to say that the issue is not a one-off problem.

Not sure why it was never moved from Incomplete.

Changed in firefox (Ubuntu):
status: Incomplete → New
status: New → Confirmed
rockfx01 (tim-filmchicago) wrote :

I have been seeing this bug on and off for at least several months, if not a year. It is very intermittent, but when it does happen it is painfully annoying especially because I usually must restart FF completely to resolve the issue.

I have seen this defect on multiple different versions of Ubuntu (9.04, 10.04, 10.10) with different versions of Firefox (but probably all 3.0+) as well as on Windows Vista, all with various add-ons installed.

As other users said above, this appears to be a Firefox autofill problem. This is such an annoying defect it makes me seriously consider switching from FF to Chrome permanently (not to mention Chrome is FAR more stable using Flash than Firefox in Ubuntu).

Knightlie (knightlie) wrote :

Guys, this is happening with the Mac OS version of Firefox too (my wife just lost a huge post) - it's not Ubuntu-specific.

Roy Jamison (xteejx) wrote :

This bug was already reported upstream by a duplicate reporter, and can be found at https://bugzilla.mozilla.org/show_bug.cgi?id=604390 . You can track it and make comments there. It may be helpful for the Mac OS guy to put that in the upstream report since it looks like Mozilla think that it's an Ubuntu specific bug. There has been no update on the upstream report for over 2 months so a nudge might just be what it needs. :)

Changed in firefox (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged

I've noticed the same issue.

Firefox 3.6.13 on 64bit Ubuntu
Linux hiro 2.6.32-27-generic #49-Ubuntu SMP Thu Dec 2 00:51:09 UTC 2010 x86_64 GNU/Linux

I get around it byu clicking in another text box or the URL bar and then clicking back to the text box affected. Only seems to happen when selecting the textbox using tab.

This bug affects all operating systems. I have seen it on numerous versions of Ubuntu (9.04, 9.10, 10.04) as well as Windows Vista/7. Other users have also reported seeing it on Mac OS X on launchpad in this bug (of which 641300 mentioned above is a duplicate):

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/583122

I have not discovered a specific way to reproduce it - it occurs very intermittently but when it does happen it is extremely annoying. 27 other people have also reported suffering from this defect (not including additional people who may have reported duplicate issues) on Launchpad.

rockfx01 (tim-filmchicago) wrote :

If you are affected by this defect, please go to the mozilla bugzilla report and vote for the defect to increase its priority.

https://bugzilla.mozilla.org/show_bug.cgi?id=604390

Changed in firefox:
importance: Unknown → Medium
status: Unknown → New

This always happens after sleep/hibernate, and it also makes firefox temporarily forget its address history. It usually starts to work normally after a few minutes.

I have this issue both in Ubuntu 10.04 and 10.10, with Firefox 3.6.13

*** Bug 622511 has been marked as a duplicate of this bug. ***

I see this bug on Fedora 14 with latest (3.6) packages. It's not (just) caused by sleep/hibernate -- I just saw it on a machine that never sleeps.

Whenever this bug is happening, it reliably causes:
 - Characters I type into the 'Lookup forecast by "City, St"' box at weather.gov
 - Whenever I type one or two characters into the subject field when composing a message in gmail, they get highlighted. To continue typing without losing those characters, I have to hit the right arrow or otherwise deselect them.
 - The awesomebar isn't awesome. That is, it just acts like a plain text box and doesn't pop up any hints.

The most recent time it triggered, I fixed it by defocusing Firefox and then refocusing it.

Restarting Firefox always fixes it for awhile. I have no idea how to trigger it in the first place, though.

Blaine (frikker) wrote :

This bug is so annoying. I notice three additional things:

1) Every time that the text gets deleted, I notice there is activity in my status bar. Something to the order of "Waiting on server.com..." even though the text boxes are "regular" non-ajax boxes half the time.

2) If I wait about 20 seconds and come back, it is fine. I can type regularly, and there is no activity in the status window.

3) On gmail, this doesn't affect the email body or recipient boxes, but does affect the subject box.

Blaine (frikker) wrote :

I just noticed that the server that is contacted is actually a "stats.server.com". The page I'm visiting is actually on "secure.server.com". So it seems that maybe this is a side effect of a script gone wrong?

Kevin Waddell (onatawahtaw) wrote :

I am not convinced that bugs such as https://bugzilla.mozilla.org/show_bug.cgi?id=604390 are a duplicate of this one. I have never had a problem with the address bar or search bar. I cannot always repeat it, but seems to happen more for some sites. Here is what I do know:

1. It only happens when you tab to a field (clicking on a form field does not cause this problem)
2. It is not a problem with compiz as someone has suggested, I set effects to "None" and this problem still exists.

Something else to consider. I have not taken the time to figure it out for all fields, but it seems that in some cases only certain keys produce the problem. For example, when trying to type into one particular field, I found that typing a 1, 8, or 00 (two zeros) caused the problem, but typing any of the other numbers did not. Of course, this problem is not only related to numerics.

Tapas Mishra (mightydreams) wrote :

I agree with you Kevin I also observed this happens when you use Tab to switch fields.

fyo (fyo) wrote :

I'm affected by this bug as well. It does NOT appear to happen unless my computer has been "inactive" (screensaver, at least).

I have not been able to replicate the "tab" requirements. That is, I have experienced the bug without tabbing between fields.

For some reason, opening Ubuntu's "Keyboard Shortcuts" application CONSISTENTLY causes the behavior to revert to normal (that is, when I'm experiencing the bug, I can launch Keyboard Shortcuts, shut it down without doing anything, and then FF is back to normal).

I've observed this bug on two different systems with different versions of FF and Ubuntu. Only addons are the default Ubuntu ones.

Roland Giesler (lifeboy) wrote :

Here's what I found:

The problem seems to be interference / competition between firefox's auto-complete (or it could be google's autocomplete, I'm not sure which service does this) and the firefox spell-checker. When I turn off spell-checking in the subject box when the problem occurs, the auto-complete shows and all is well. If there is no auto-complete (ie. I have not typed text start with the same word(s) previously), there is no problem.

To test this: Try is with a gmail subject box. Make sure auto-complete is on, as well as spell-checking. Type something you never typed before. Like '6tiksmkd'. No problem. Type something like 'Japan Tsunami" (or whatever you entered before) and the problem occurs. No right-click in the subject box and turn off spell-checking. The problem goes away.

Can others confirm if the same happens with them?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.