cannot save images on kubuntu 10.04 firefox

Bug #572772 reported by Wiebz
130
This bug affects 22 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Chris Coulson
Natty
Medium
Chris Coulson
firefox (openSUSE)
Fix Released
Medium

Bug Description

Binary package hint: firefox

the save dialog didn't show while i right clicked the image and choose save image as...

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: firefox 3.6.3+nobinonly-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Sat May 1 09:51:07 2010
FirefoxPackages:
 firefox 3.6.3+nobinonly-0ubuntu4
 firefox-gnome-support N/A
 firefox-branding 3.6.3+nobinonly-0ubuntu4
 abroswer N/A
 abrowser-branding N/A
InstallationMedia: Kubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox

Related branches

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; fi-FI; rv:1.9.1.5) Gecko/20091103 SUSE/3.5.5-2.2 Firefox/3.5.5

If i choose that "save image as", it doesnt do anything.

Reproducible: Always

Steps to Reproduce:
1. right click some image
2. choose show image
3. right click agin
4. choose "save image as"
Actual Results:
nothing happends

Expected Results:
FF opens dialog and ask where to save

Revision history for this message
In , Wolfgang Rosenauer (wolfgang-rosenauer) wrote :

Do you run under KDE or another desktop?

Do you get any interesting output in the Error console under Tools?

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

KDE 4.3.3 "release 3". Nothing in error console.

Seems this is random. Sometimes it works, sometimes its not. This is one of those i cant save:

http://www.simplemachines.org/community/custom_avatars/avatar_272_1257232094.jpg

Revision history for this message
In , Llunak (llunak) wrote :

Works fine here. What is 'rpm -q mozilla-xulrunner191 mozilla-xulrunner191-kde4'?

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

mozilla-xulrunner191-1.9.1.5-5.1.x86_64
mozilla-xulrunner191-kde4-0.6-0.1.1.x86_64

Hmmm, this happends randomly. Seems working now. Could be some addon or something.

Revision history for this message
In , John (venoom27) wrote :

I am having the same issue and have run a couple of different distributions over the last week Fedora 12, and Ubuntu 9.10 with the same add ons and this has not been an issue at all.

Revision history for this message
In , Wolfgang Rosenauer (wolfgang-rosenauer) wrote :

Something you can crosscheck if it doesn't work:

Check with following command on a terminal if kmozillahelper is still running:
ps ax | grep kmozillahelper

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

osku@kotipurkki:~> ps ax | grep kmozillahelpe
 3719 ? S 0:00 /usr/lib/mozilla/kmozillahelper
 3838 pts/2 R+ 0:00 grep kmozillahelp

Revision history for this message
In , John (venoom27) wrote :

 5786 ? S 0:00 /usr/lib/mozilla/kmozillahelper
 7589 pts/1 S+ 0:00 grep kmozillahelper

Revision history for this message
In , John (venoom27) wrote :

I found a work around I installed an add on "Image Toolbar 0.6.6" and it works even when the right click menu will not work.

Revision history for this message
In , astronic (bugreports-tittel) wrote :

I can confirm this problem with the current official Firefox (3.5.5) and official KDE (4.3.1) package (thereby using openSUSE's Firefox with KDE integration).

The problem only appears sometimes. If it appears I can do "File->Save Page As" and after closing the resulting file chooser dialog, right clicking on an image and choosing "Save Image As" works again.

Naturally I suspect the KDE Firefox integration. Please tell me how I can help to provide information for fixing this the next time the problem appears (at the moment it doesn't.)

Revision history for this message
In , John (venoom27) wrote :

Two things to add

1. I am running a 32 bit computer

2. This bug goes beyond saving images as if you go to file and select "save as" this will not work. What does work is hitting control+s. Same thing with open option in the file drop down menu it will not work in the file drop menu but will work if you hit control+o. It seems the only things that will not work in the drop down menu are option that bring up a file browser.

Revision history for this message
In , Kranthrak (kranthrak) wrote :

I have also been experiencing this issue on a 32 bit system and as far as I can tell it only happens when trying to save images into a folder already containing a lot of files. Both of the folders that get me every time have 1500+ images in them (coincidentally 1554 and 1557 files respectively). It makes me wonder if there's a certain threshold number of files where this starts to happen. Saving the images elsewhere works perfectly (so long as I don't browse into those folders and lock kmozillahelper up).

Revision history for this message
In , Don Rhummy (donrhummy) wrote :

This is occurring for me as well.

* OpenSUSE 11.2
* 32-bit
* Firefox 3.5.6 OpenSUSE branding

It occurs when I try to do any right-click action AND when i attempt to do anything from the file menu such as open a file or save the page as.

I have uninstalled the firefox that came with openSUSE 11.2 and installed (manually just by extracting into a folder) the firefox from mozilla.org to see if that fixes the issue. I'll let you know if it does (in which case it's something with opensuse's branding).

Revision history for this message
In , Wolfgang Rosenauer (wolfgang-rosenauer) wrote :

*** Bug 570120 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

Can someone please fix this. its annoying as hell.

Revision history for this message
In , Wolfgang Rosenauer (wolfgang-rosenauer) wrote :

I just was able to reproduce the first time. A Firefox restart fixed the issue for me.
I'm pretty sure it's related to the KDE integration getting stuck or something like that.

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

Restart doesnt fix it for me. Now i cant save any images.

Revision history for this message
In , Don Rhummy (donrhummy) wrote :

(In reply to comment #13)
> This is occurring for me as well.
>
> * OpenSUSE 11.2
> * 32-bit
> * Firefox 3.5.6 OpenSUSE branding
>
> It occurs when I try to do any right-click action AND when i attempt to do
> anything from the file menu such as open a file or save the page as.
>
> I have uninstalled the firefox that came with openSUSE 11.2 and installed
> (manually just by extracting into a folder) the firefox from mozilla.org to see
> if that fixes the issue. I'll let you know if it does (in which case it's
> something with opensuse's branding).

This is DEFINITELY an OpenSUSE issue. After uninstalling OpenSUSE-branded firefox and installing firefox directly from mozilla.org, the issue has disappeared. I've been using it for a month with out this issue.

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

I use

Mozilla/5.0 (X11; U; Linux x86_64; fi-FI; rv:1.9.2.0) Gecko/20100115 SUSE/3.6.0-1.2 Firefox/3.6

Linux 2.6.31.12-0.1-desktop x86_64
openSUSE 11.2 (x86_64)
KDE: 4.4.00 (KDE 4.4.0) "release 222"

Revision history for this message
In , Wolfgang Rosenauer (wolfgang-rosenauer) wrote :

To get more confirmation, please remove (rpm -e) mozilla-xulrunner191-kde4 or
mozilla-kde4-integration (it depends which version you have) and restart Firefox.
Is it still an issue?

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

# rpm -e mozilla-kde4-integration

-> FIXED!

Revision history for this message
In , Jay Bowles (penguinclaw) wrote :

As this appears to be an integration problem can we expect a fix for this or do we just remove the integration which seems a step backward.

Revision history for this message
In , Llunak (llunak) wrote :

I'd need a way to reproduce this problem first. I still cannot reproduce and as such cannot fix.

Revision history for this message
In , Alexander-koenig (alexander-koenig) wrote :

I can confirm this problem on all my different systems with different architecture, 32 bit and 64 bit with all the latest patches from online update installed.

The problem with reproducing the bug is that it does not appear immediately after start-up of Firefox, but only after having used Firefox for some time. Simply closing Firefox and restarting resolves the problem - at least temporarily.

To reproduce the problem I recommend that you work with Firefox for some time until the problem occurs (my suspicion is that you need to work with some multimedia files to induce the problem).

What is the information I should send you from my computer when this bug is active?

Revision history for this message
In , Jean-Christophe Baptiste (jc-baptiste) wrote :

Same issue here, no more right click menu after having used Firefox for a while.

Revision history for this message
Wiebz (wibiharto) wrote :
Revision history for this message
Olli-Pekka Korpela (okorpela) wrote :

I have the same problem.

Revision history for this message
Мартин Спасовски (moondowner) wrote :

+1, to confirm this bug.

I've installed Firefox with the installer provided with the Kubuntu installation, I'm using amd64 architecture.

tags: added: amd64
Revision history for this message
Мартин Спасовски (moondowner) wrote :

When I started firefox from Konsole (by typing firefox), this is what happened:

I right clicked an image, chose Save Image As, and the dialog opened (which I didn't expected), and I saved the picture. Meanwhile in console the following text was output-ed.

"kmozillahelper(16928): couldn't create slave: "Unable to create io-slave:
klauncher said: Unknown protocol ''.
"
kmozillahelper(16928): couldn't create slave: "Unable to create io-slave:
klauncher said: Unknown protocol ''.
"
kmozillahelper(16928): couldn't create slave: "Unable to create io-slave:
klauncher said: Unknown protocol ''.
"
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/martin/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon"

Which may tell something about the cause of the bug.

Revision history for this message
Micah Gersten (micahg) wrote :

Thank you for reporting this to Ubuntu. Is this just when saving the image or saving any content?

Changed in firefox (Ubuntu):
status: New → Incomplete
Revision history for this message
Мартин Спасовски (moondowner) wrote :

It turns out that it's not only for 'Save Image As', but also for 'Save Page As' and 'Save Frame As'.

Revision history for this message
starslights (starslights) wrote :

Hi Micah,

Look like only pictures can't be saved.

The only way to save a pictures are use "copy picture" and after paste somewhere on HDD. So it's my workaround for the time.

So this bug are confirmed .

Best Regards

Changed in firefox (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Felix Geyer (debfx) wrote :

Does it work if you click on "View Image" and then "Save Page"?

Revision history for this message
starslights (starslights) wrote :

Hello Felix,

"view image" work for me but "save page" not.

Revision history for this message
dryans (dryans) wrote :

Same issue here, using amd64 architecture, but I seem to have got it working.
Went to konsole and ran sudo firefox
I was able to save images while running in this mode though the console output showed the above errors regarding io-slave. Also the graphics of the browser itself seemed to go into a blocky "safe mode" of sorts. I closed firefox and logged out, logged back in and ran firefox as usual (no sudo priviledges) and saving images seems to be working for me now.

Hope this helps track down the bug

Revision history for this message
dryans (dryans) wrote :

Modification to my previous comment..

When I'm back in normal user mode I can only save one or two images then the bug returns. Running in sudo mode is ugly but it gets me the functionality.

Revision history for this message
Micah Gersten (micahg) wrote :

Please do not run firefox with sudo as that causes other issues.

@Felix Geyer

Any ideas? Anyone else from Kubuntu we should subscribe?

Revision history for this message
Carlos (carlos-camara) wrote :

+1 to this problem. Also using 64-bits architecture.
Is there any solution to it?

Revision history for this message
Felix Geyer (debfx) wrote :

I remember having this problem once, but could never reproduce it after restarting firefox.

Does saving images/pages not work all the time or only sporadically?

Revision history for this message
starslights (starslights) wrote : Re: [Bug 572772] Re: cannot save images on kubuntu 10.04 firefox

Le Tue, 18 May 2010 16:17:57 -0000,
Felix Geyer <email address hidden> a écrit :

> I remember having this problem once, but could never reproduce it
> after restarting firefox.
>
> Does saving images/pages not work all the time or only sporadically?
>

It never work, at all times. Text are possible to save but no pictures.

Revision history for this message
Nythain (nythain) wrote :

Another confirm. I can "save link as" when that's an option, but no save dialog for "save image as" or "save page as" :( It's very annoying requiring 2 different browsers for general internet usage.

Revision history for this message
starslights (starslights) wrote :

Hello,

The bug are fixed on the last update committed today, Thanks very much :D

Revision history for this message
Felix Geyer (debfx) wrote :

Which update? The Firefox update from mozilla-security PPA?

Can anyone else confirm this?

Revision history for this message
starslights (starslights) wrote :

Le Fri, 28 May 2010 11:01:23 -0000,
Felix Geyer <email address hidden> a écrit :

> Which update? The Firefox update from mozilla-security PPA?
>
> Can anyone else confirm this?
>

Maybe, i run FF from the kubuntu repo and just have added the ppa
security, wjile daily don't make possible to report bug here. If you
want i can apport collect and so you can see what update it was.

Revision history for this message
starslights (starslights) wrote :

Hi,

From today i am not able again to save the picture. So mabye i was kust lucky last time while it have just recompiled FF and work a couple of time but the bug still .

Best Regards

Revision history for this message
Rafael Menezes (farrapos) wrote :

I'm affected by the same bug. Using Kubuntu 10.04 64bits.

Changed in firefox (openSUSE):
status: Unknown → Confirmed
Revision history for this message
mrl586 (mrl586) wrote :

I have same bug in Kubuntu 10.10.

tags: added: maverick
Revision history for this message
starslights (starslights) wrote :

hi,

With the last update of FireFox to 3.6.6, it seem that this bug are definitively fixed for me on kubuntu lucid 10.04 64 bits . for Marvick, i will keep in touch.

Revision history for this message
Jamie (solowinter) wrote :

Problem exists for me in Firefox 3.6.8 under Kubuntu Lucid. It's not a consistent problem, though, and I can't find a pattern. Sometimes I can "resolve" it by closing some tabs or restarting Firefox but it's completely possible neither of these have any effect on what appears to be a random problem.

Revision history for this message
In , astronic (bugreports-tittel) wrote :

This bug is still present in openSUSE 11.3. Any news on this?

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

(In reply to comment #26)
> This bug is still present in openSUSE 11.3.

Yes, annoying bug it is.

Revision history for this message
SabreWolfy (sabrewolfy) wrote :

Confirmed in 32-bit Lucid with Firefox 3.6.8, KDE 4.4.2 and kmozillahelper 0.6-0ubuntu3.

Revision history for this message
Adam Par (adam.p.01) wrote :

Look for "browser.download.saveLinkAsFilenameTimeout" in about:config. Change to 0.
It should solve the problem.

Revision history for this message
Turk Back (turkback) wrote :

The "browser.download.saveLinkAsFilenameTimeout" hack didn't work for me. I'm still getting the bug. I can save images for an indeterminate amount of time and then it stops. When I started Firefox from a terminal I get

kmozillahelper(3346): couldn't create slave: "Unable to create io-slave:
klauncher said: Unknown protocol ''.
"

whenever I was able to save an image successfully. When it finally gave up the ghost and no longer allowed me to save at all, it added this to the terminal:

*** NSPlugin Viewer *** WARNING: unhandled variable 18 (<unknown variable>) in NPN_GetValue()

I'm on Lucid-amd64 fully-updated, Firefox 3.6.10~hg20100828r34553+nobinonly-0ubuntu1~umd1~lucid from the Ubuntu Mozilla Daily Builds PPA (also got same behavior with the firefox in the official repo), KDE 4.4.2, kmozillahelper 0.6-0ubuntu3.

Revision history for this message
Turk Back (turkback) wrote :

Further research on the web seems to indicate this is a common problem with kmozillahelper. I uninstalled kmozillahelper and haven't been able to reproduce the "save image as" problem even after 12 hours of use.

Revision history for this message
Micah Gersten (micahg) wrote :

I'm marking the Ubuntu task as Triaged since the issue is upstream with kmozillahelper and Novell. Please report any other issues you may find.

Changed in firefox (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in firefox (openSUSE):
importance: Unknown → Medium
Revision history for this message
Kyle Bishop (kybishop) wrote :

Confirmed in 64-bit kubntu 10.10 with version 3.6.10

Revision history for this message
Floop (floop) wrote :

Confirmed in 64-bit Kubuntu with Firefox 3.6.10.
No file open/save dialog ever appears. But it works, when evoked by shortcut. For example: pressing File->Save Page As... (by cursor) does nothing. But pressing Ctrl+S opens <Save Page As...> dialog. kmozillahelper is not installed. I had the same problem with Kubuntu 10.04.

Revision history for this message
Floop (floop) wrote :

Everything is working fine after today's update to Firefox 3.6.11! Thank you!

Revision history for this message
schiemanski (schiemanski) wrote :

I still have these problems in kubuntu 10.04 32-bit after the update to Firefox 3.6.11

Revision history for this message
Kazma (kazma-deactivatedaccount) wrote :

Same here too. FIrefox 3.6.11 on Kubuntu 10.10(32bit)
Also i have a problem with bookmark management. (Backup and Restore)

Revision history for this message
Jason Straight (jason-jeetkunedomaster) wrote :

This happens to me all the time, the fix for me is to kill firefox and restart it. It doesn't seem to be anything to do with the site or page. I can fail on a pic, kill firefox, start it and let it use crash recovery to open all the pages it had open before, then save the same picture it failed on before (every time).

Revision history for this message
jake dalton (jacobrdalton) wrote :

I have this issue. No 'save as' dialog for images, although I can do 'view image info' and then 'save as' the image. Running Firefox 3.6.12 with kmozillahelper installed on Kubuntu 10.04 Lucid KDE 4.4.2 amd64.

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

Can you please fix this annoying bug?

Revision history for this message
In , Pcerny (pcerny) wrote :

I doubt it is SUSE specifis. Actually, I have experienced very similar behaviour with Seamonkey 2.0.7 or .8 running on Windows. Could you please check whether the bugs below (and possibly other mozilla.org bugs) match your problem?

https://bugzilla.mozilla.org/show_bug.cgi?id=400592
https://bugzilla.mozilla.org/show_bug.cgi?id=407572
https://bugzilla.mozilla.org/show_bug.cgi?id=427049

Revision history for this message
In , Wolfgang Rosenauer (wolfgang-rosenauer) wrote :

*** Bug 619703 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Pcerny (pcerny) wrote :

Anyone experienced this with the latest versions of Firefox or Seamonkey (or Thunderbird for that matter)?

Revision history for this message
In , astronic (bugreports-tittel) wrote :

Yes, the problem is still there with the latest official Firefox package on openSUSE 11.3.

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

Its totally random. Sometimes it works, sometimes not. Most of the time not.

Revision history for this message
David H (david-houlder) wrote :

Affects me too. Kubuntu 10.04.1 on x86_64, kmozillahelper installed. Ctrl+S will bring up the 'save page' dialog, but File -> 'Save Page as' won't.

Revision history for this message
In , Pagan13 (pagan13) wrote :

This bug is still here. I have the same problem. "Save Image As" from the pop-up menu does not work. Sometimes it works when Firefox is first started and a simple page is loaded. If I load something complex like Facebook, it fails. Same with saving pages from the pull-down menu (although ctrl-s does work).

I use:
Opensuse 11.3 x86_64
KDE4 Version 4.4.4 "release 3"
Mozilla Firefox 3.6.13

This is what I tried to correct the problem:

Removed:
mozilla-xulrunner191-gnomevfs
mozilla-xulrunner192-gnome
(Both version 1.9.1.16-3.1)
No fix. I put them back.

Then I changed branding from Opensuse to Moblin
No fix. I restored Opensuse branding

Finally, I removed Mozilla-Kde4 integration. That makes it work right. The problem seems to be a bad Kde4 integration. (Version 0.6.3-17.2-x86_64)

I fully expect this to appear in Opensuse 11.4 unless it's fixed before release (in a couple of weeks!).

A question: What is this "integration" and why is it necessary or desirable?

Revision history for this message
In , Llunak (llunak) wrote :

*** Bug 620304 has been marked as a duplicate of this bug. ***

Revision history for this message
Mowild (mowild-dev) wrote :

Kubuntu 10.10 on x86_64 also failing.
(Googling I found some Windows users with such an issue who could fix it by deleting a file, isn't there any such workaround on linux platforms?)

Revision history for this message
In , Don-raboud (don-raboud) wrote :

For those having problems with this bug, a workaround that appears to work here, short of unistalling the KDE4 integration, is to change

"ui.allow_platform_file_picker" to "false" under about:config.

You get the gnome file dialog instead, which you may or may not like, but this seems to avoid the problems mentioned in this bug.

Revision history for this message
In , Don Rhummy (donrhummy) wrote :

Can someone explain why almost 2 years later this still isn't fixed?

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

This seems to be working in FF 4. Can anyone confirm?

Revision history for this message
In , Llunak (llunak) wrote :

(In reply to comment #37)
> Can someone explain why almost 2 years later this still isn't fixed?

See comment #23.

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

*** Bug 619703 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Pagan13 (pagan13) wrote :

IRT comment #38:
It is not fixed in Firefox 4. Still broken. And in exactly the same way.

IRT comment #39:
Lubos, You can not be having zero problem with this; it is just too consistent. It happens with Mozilla Firefox and KDE4 integration on any platform. I am using openSUSE 11.3 x86_64 on a 64-bit dual-core laptop. All I have to do is run Firefox and use it to browse a variety of sites like Twitter, Facebook and YouTube. Once I've done that, if I try to save an image, it won't work. Also, DownloadHelper (and probably a large variety of other stuff) won't work properly either.

As with a very large percentage of software bugs, this one won't show up when the affected program (in this case, Firefox) is first started. Something changes in the relationship between Firefox and KDE4 integration that breaks Firefox's normal file-saving behavior.

Revision history for this message
In , Jan-olof-eriksson (jan-olof-eriksson) wrote :

(In reply to comment #41)
> IRT comment #38:
> It is not fixed in Firefox 4. Still broken. And in exactly the same way.

Hmmm, im using 11.4 now, mayby its fixed in that then?

Revision history for this message
In , Llunak (llunak) wrote :

If it's so consistent, finally give me consistent steps to reproduce. "Do random stuff and then it shows up" is not that.

Revision history for this message
In , Pagan13 (pagan13) wrote :

Lubos, it took me some time to work it out, but this should do at least enough to trace down the problem.

To reproduce:
1. Shut down any instances of Firefox you have running.

2. Ensure that you have the latest versions of Firefox (4.0.0) and KDE4 integration (0.6.3) installed.

3. Allow the "Welcome to Firefox 4" and "openSUSE.org" tabs to fully load.

4. Create a new tab and load the image:
      http://countdown.opensuse.org/11.4/large.png

5. Right-click the image and select "Save Image As" to try to save the picture. The KDE4 "Save As" dialog, which should appear, will not.

That image can be saved by using ctrl-s, but that is impossible when the image is part of a web page instead of being loaded alone.

I am including my "about:plugins" page, just so you can see what plugins I'm using. I would include "about:config" but Firefox won't save that to disk. I am including it just in case the problem is affected or caused by a plugin.

While we're about KDE4 integration, I notice that the web page extension defaults to ".htm" without any option to change it to ".html" which is more usual on the web today. Is there any way to change this?

Revision history for this message
In , Pagan13 (pagan13) wrote :

Created an attachment (id=421526)
about:plugins for Comment #44

I saved the about:plugin page from Firefox and gzipped it.

Revision history for this message
In , Llunak (llunak) wrote :

Ok, I could finally reproduce using steps from comment #44, thanks.

SR #65329

Revision history for this message
In , Wolfgang Rosenauer (wolfgang-rosenauer) wrote :

Fixed packages for Firefox 4 are available in mozilla repo.
I'll backport it to Firefox 3.6 as well soon.
(Assigning to me for tracking)

For official updates this will end up in the next security updates.

affects: firefox (Ubuntu) → ubuntu
affects: Ubuntu Natty → firefox (Ubuntu Natty)
Changed in firefox (Ubuntu Natty):
assignee: nobody → Felix Geyer (debfx)
milestone: none → ubuntu-11.04
Revision history for this message
Felix Geyer (debfx) wrote :

Still waiting for my branch to be merged.

Changed in firefox (Ubuntu Natty):
assignee: Felix Geyer (debfx) → Chris Coulson (chrisccoulson)
Changed in firefox (Ubuntu Natty):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 4.0+nobinonly-0ubuntu3

---------------
firefox (4.0+nobinonly-0ubuntu3) natty; urgency=low

  [ Felix Geyer <email address hidden> ]
  * Fix LP: #572772 - can't save files in KDE
    - update debian/patches/mozilla-kde.patch

  [ Chris Coulson ]
  * Fix LP: #766151 - popuphiding and popuphidden events aren't dispatched
    when a menu is closed, leading to exceptions being thrown in
    browserPlacesViews.js (visible from the error console)
    - update globalmenu-extension to 1.0.2
  * Fix LP: #744580 - Firefox doesn't autoscroll when selecting content
    downwards
    - add debian/patches/fix-selection-drag-autoscroll.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Tue, 19 Apr 2011 17:10:50 +0100

Changed in firefox (Ubuntu Natty):
status: Fix Committed → Fix Released
Revision history for this message
Bat (batclod) wrote :

Firefox. 3.6.17 on Kubuntu 10.10 (maverick) on x86_64 same problem.
"save page as" hangs without dialog windows.

(fixable setting "browser.download.saveLinkAsFilenameTimeout" to 0)

Revision history for this message
Pelládi Gábor (pelladigabor) wrote :

I have the same problem with Kubuntu Oneiric. firefox 7.0.1+build1+nobinonly-0ubuntu2, firefox-kde-support 0.6.2-0ubuntu2. The issue can be reproduced as described in comment 83.
Open http://countdown.opensuse.org/11.4/large.png in firefox, right click -> save image as, and nothing happens. If it works (a rare occasion), just try it again, it will fail soon.
browser.download.saveLinkAsFilenameTimeout does not fix it.
If I start firefox from console, the following gets printed:

kmozillahelper(8664): couldn't create slave: "Nem sikerült egy io-alfolyamatot létrehozni:
a klauncher válasza: Ismeretlen protokoll - ''.
"
kmozillahelper(8664): couldn't create slave: "Nem sikerült egy io-alfolyamatot létrehozni:
a klauncher válasza: Ismeretlen protokoll - ''.
"
kmozillahelper(8664): couldn't create slave: "Nem sikerült egy io-alfolyamatot létrehozni:
a klauncher válasza: Ismeretlen protokoll - ''.
"
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id: 0x6400012

Removing firefox-kde-support makes save image as work, but it displays the ugly gnome dialog then.

Revision history for this message
Pelládi Gábor (pelladigabor) wrote :

I have created a new bug, because I can't repoen this:
https://bugs.launchpad.net/ubuntu/+source/kmozillahelper/+bug/887304

Revision history for this message
In , Unskipp-raul (unskipp-raul) wrote :

This bug is fixed in openSUSE 12.1 and firefox version 7.0.1

Revision history for this message
In , Pcerny-v (pcerny-v) wrote :

Closing as fixed.

Changed in firefox (openSUSE):
status: Confirmed → Fix Released
Revision history for this message
Grendel (togr) wrote :

I noticed that in the current Ubuntu version, the addon "automatic save folders" prevents the save dialogue to appear.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.