Ubuntu

package firefox (not installed) failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Reported by gkasinath on 2010-05-01
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

I did have firefox 3.0.6 (ubunutu install) and 3.5 manually installed with the following symbolic link(s) and folders
   0 lrwxrwxrwx 1 root root 20 2009-03-24 22:02 firefox -> /opt/firefox/firefox
   0 lrwxrwxrwx 1 root root 22 2009-02-04 18:24 firefox.old -> ../lib/firefox/firefox
   0 lrwxrwxrwx 1 root root 20 2009-03-24 22:02 mozilla-firefox -> /opt/firefox/firefox

These were manually removed (before removing via synaptic) using:
gkasinath@rivermaker:~$ sudo rm /usr/bin/firefox
[sudo] password for gkasinath:
gkasinath@rivermaker:~$ sudo rm /usr/bin/firefox.old
gkasinath@rivermaker:~$ sudo rm /usr/bin/mozilla-firefox
gkasinath@rivermaker:~$ sudo rm -rf /opt/firefox
gkasinath@rivermaker:~$ sudo rm -rf /lib/firefox

I hope this helps and I havent screwed the folder/links up.

Cheers
G

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: firefox (not installed)
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
AptOrdering:
 firefox-branding: Install
 firefox: Install
 firefox: Configure
 firefox-branding: Configure
Architecture: i386
Date: Sat May 1 08:55:55 2010
ErrorMessage: subprocess installed post-installation script returned error exit status 2
SourcePackage: firefox
Title: package firefox (not installed) failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

gkasinath (gautham-kasinath) wrote :
Anorgan (marin-crnkovic) wrote :

Ok, what i did was:
1. remove all firefoxes via synaptic :)
2. apt-get install firefox
2. cp /usr/bin/firefox.ubuntu /usr/bin/firefox
3. apt-get install firefox
4. works

Chris Coulson (chrisccoulson) wrote :

This is caused by installing packages from Ubuntuzilla, please report your problems to them instead

Changed in firefox (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 4.0~b12+build1+nobinonly-0ubuntu2

---------------
firefox (4.0~b12+build1+nobinonly-0ubuntu2) natty; urgency=low

  * Fix some typos in the manpage
    - update debian/firefox.1.in
  * Fix up the mess left by Ubuntuzilla rather than leaving our official
    package in a broken and inconsistent state, which ends up with users
    reporting bugs to Launchpad and giving us a bad reputation. If
    /usr/bin/firefox has been diverted and there is no /usr/bin/firefox
    provided on the system, just do the job of whatever package it was that
    broke the users install and remove the diversion for them. This should
    hopefully stop the frequently reported bugs we get from Ubuntuzilla users
    about /usr/bin/firefox being missing
    - update debian/firefox.postinst.in
    - Fixes LP: #512937, LP: #529136, LP: #552919, LP: #572733, LP: #574111,
      LP: #599978, LP: #600271, LP: #610522, LP: #610756, LP: #610907,
      LP: #612162, LP: #620400, LP: #623980, LP: #625014, LP: #630643,
      LP: #635166, LP: #638342, LP: #641838, LP: #658828, LP: #668809,
      LP: #672282, LP: #676239, LP: #707704, LP: #724090
  * Don't allow users to report bugs with apport-bug when /usr/bin/firefox
    has been diverted
    - update debian/firefox.py.in
  * Don't build with --disable-elfhack on armel. It's been fixed now
    - update debian/rules
 -- Chris Coulson <email address hidden> Fri, 25 Feb 2011 13:54:59 +0000

Changed in firefox (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers