Preferences > Cookies > Exceptions should default to the current site

Bug #52524 reported by Aaron Whitehouse on 2006-07-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Wishlist
firefox (Ubuntu)
Low
Unassigned

Bug Description

I have my browser set not to allow cookies. This means that I often have to add the site that I am on to the list of exceptions in order to make the site work properly.

I would find it very useful if, when I clicked Edit > Preferences > Cookies > Exceptions, the text box had the current URI in it (highlighted). It would be a matter of pressing a key (or delete) to remove the text, but would save a lot of time for any user wanting to set preferences for a site that they were already on.

Roel Huybrechts (rulus) wrote :

Thanks for your report. Your idea might get more attention and have
the possibility of being implemented if you would submit a
specification for this.

You should first check whether it already exists at the Ubuntu specs
page (https://launchpad.net/distros/ubuntu/+specs) in Launchpad. If
that is the case, feel free to contact the drafter of that spec about
your comments/suggestions. Otherwise you can start writing a spec
following the steps described in
        https://wiki.ubuntu.com/FeatureSpecifications.

Changed in firefox:
assignee: nobody → rulus
status: Unconfirmed → Rejected
era (era) wrote :

Also, when you click on a site in the list, it would be helpful if the "Block" and "Allow" buttons could be used to change the status from whatever it is. (The button for the site's current status should be grayed out, I guess.)

Alternatively, clicking (or at least, double-clicking) on a site should copy its name to the "Address of web site": field, but that has problems because you might end up erasing something the user has typed in there.

There's an upstream bug about making the exceptions dialog more navigable (in particular, by making the list of sites less clumsy to browse and sort, and maybe add a few more informational columns); maybe this could be brought up there, too. (Perhaps they even have this particular bug already.)

Roel Huybrechts (rulus) wrote :

Hi, thanks for the comment. Can you provide an exact url of this upstream bug? If yes, we can link these two bugs.

Passing on this feature request from someone who contacted me.

STR:
1. Turn off cookies
2. Go to a site which requires cookies
3. Open Preferences/Options -> Privacy -> Exceptions...

Expect the site to be pre-filled in the "Address of web site:" input.

The only concern I'd have is what the expected behavior would be if you switched tabs/windows. Do we change the entry in the input? Or do we keep it how it is? I'd say we keep it static, but it did cross my mind.

(Can't find a dupe, so filing as NEW.)

I believe I've seen this bug before too and even multiple times, but I can only find the related Bug 301120.

This would also make sense for some other site-specific prefs that are currently treated as whitelists or blacklists, such as popup blocking and extension installation.

era (era) wrote :

Sorry for taking so long to respond, and for confusing the Cookie Manager with the Cookie Exceptions Manager.

https://bugzilla.mozilla.org/show_bug.cgi?id=381209 requests the name of the current web site to be filled in the Cookie Exception Manger and so should be suitable as an upstream bug for this one. It is very new but that shouldn't hurt.

The one I was originally thinking of is https://bugzilla.mozilla.org/show_bug.cgi?id=142179 but that is about the Cookie Manager (what sites set cookies, when; of course, there is a whole lot of other more or less related bugs, too -- for example, https://bugzilla.mozilla.org/show_bug.cgi?id=201936 and even https://bugzilla.mozilla.org/show_bug.cgi?id=236133 is vaguely related, to my mind).

Bug 363929 looks like a duplicate. Since this one has a better summary etc I would nominate that as a duplicate of this one, rather than vice versa.

Roel Huybrechts (rulus) wrote :

I'm linking it to Mozilla bug #381209 as that one covers the best the original bug description. Thanks for the other related bugs though!

Changed in rebuntu:
status: Unknown → Confirmed
Alexander Sack (asac) on 2007-05-29
Changed in rebuntu:
status: Unconfirmed → Rejected
Changed in firefox:
status: Unknown → Confirmed

I am changing this back to confirmed. Others clearly have the same behaviour. I don't really think that it is suitable for a specification.

It is filed upstream, so shouldn't need work in Ubuntu, but it is a little odd to have it marked as invalid.

Changed in firefox:
status: Invalid → Confirmed
Roel Huybrechts (rulus) on 2008-05-08
Changed in firefox:
assignee: rulus → nobody
Alexander Sack (asac) on 2008-05-12
Changed in firefox:
importance: Undecided → Low
Changed in firefox:
importance: Unknown → Wishlist

*** Bug 363929 has been marked as a duplicate of this bug. ***

Changed in firefox:
status: Confirmed → Unknown
Changed in firefox:
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.