tabs are not clickable sometimes, and firefox-bin needs to be killed when exiting after this happens

Bug #522727 reported by Kris OMealy on 2010-02-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

Tabs become not clickable sometimes (you can still change to them using Ctrl-Tab), and firefox-bin needs to be killed when exiting after this happens. This is present in the 3.6.2pre version of firefox. I am running it on amd64 and installed it using the ubuntu-mozilla-daily ppa. It seems to happen more often when a flash applet is loaded, but it happens elsewhere too, less often. As far as I can tell it only happens when more than one tab gets opened.

Kris OMealy (komealy) on 2010-02-16
description: updated
Draycen DeCator (ddecator) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we cannot process this report without more information. Could you please answer the following questions?

1. What version of Ubuntu are you using?

2. Are there any specific steps you can take to cause this issue to occur consistantly?

After you answer these questions, we will have a better idea of how to proceed.

Changed in firefox (Ubuntu):
status: New → Incomplete
Kris OMealy (komealy) wrote :

I'm using amd64 karmic with linux-kernel 2.6.31-20.57. As far as getting it to happen consistently... The way I can get it to happen 65+ percent of the time is by using google image search looking for 1080P wallpaper sized images and opening the image in a new tab using the middle mouse button click. I think it depends on which image site the image is coming from, I'm pretty sure imageshack is one of them.

Kris OMealy (komealy) wrote :

I have noticed that in the last couple of days it is happening far less.

Draycen DeCator (ddecator) wrote :

Thank you for the extra information. Please make sure that you are using the latest build since you are using a pre-release. If the build is in fact up-to-date, then you may wish to try running Firefox in Safe Mode. In order to do so, simply run 'firefox-3.6 --safe-mode' in the Terminal. A box will pop up offering the option to reset the settings of Firefox permanently. If you do not wish to make any permanent changes to Firefox, then make sure all of the boxes are unchecked (they should be by default), then simply click "Continue." This will disable your Add-ons and reset all of the settings for one session. Since you are testing a pre-release, it is possible that some settings and/or Add-ons are conflicting and causing your bug. If you do not experience this problem in Safe Mode, then you can look at disabling your Add-ons until you find which one is causing the issue, or changing some of your settings back to the default.

Please let us know if you are running the latest build and if you experience this bug in Safe Mode. Thanks in advance!

Kris OMealy (komealy) wrote :

Running in safe-mode seems to eliminate the problem. So I started by disabling all of my add-ons and turning them on one at a time to find out which one was the culprit, and after a bit of testing I found that it was actually the cybersearch add-on that I don't even really need since there is a search bar up there already. It adds google (and other searchengines) functionality to the address bar. So after I got ridof that one, I re-enabled all of my other add-ons, and I haven't been able to reproduce the error. I always update the build each morning, and before even doing the safe mode trial, I found that this issue was greatly reduced last Friday (Feb 19, 2010) anyway. But this add-on is actually the reason for it, not firefox itself..

Draycen DeCator (ddecator) wrote :

Thank you for the update. I am closing this bug since it was found to be caused by an incompatible add-on instead of a problem with Firefox itself. If you begin to experience this bug again, then please feel free to set the Status back to New. Also, feel free to report any other bugs that you find!

Changed in firefox (Ubuntu):
status: Incomplete → Invalid
fbraun (fbraun) wrote :

For a few days now, I'm having the exact same bug - even with addons disabled.
I am running Firefox in safe-mode right now, with my tabs still not-clickable. (Firefox 3.6 (not 3.6.2), on amd64, karmic and linux-kernel 2.6.31-19)

Kris' steps to reproduce the bug work - although it occurred to me in other cases at first.
I supposed that middle-clicking might be of key-importance here, but right-clicking and hitting "Open Link in New Tab" does the trick as well.

Draycen DeCator (ddecator) wrote :

@ChosenOne
Thank you for letting us know that you are still experiencing this issue in Safe Mode. Could you please run 'apport-collect 522727' in the Terminal? This will add debugging information about your system to this report so we can get a better idea of what is going on.

fbraun (fbraun) wrote :
Draycen DeCator (ddecator) wrote :

@ChosenOne
I have set this report back to "Incomplete" since your comment suggests that this bug is in fact a real Firefox issue. Please run 'apport-collect -p firefox-3.6 522727' if you have the firefox-3.6 package installed (since you are using Karmic). Otherwise, simply use 'apport-collect 522727'. Thanks in advance!

Changed in firefox (Ubuntu):
status: Invalid → Incomplete

Architecture: amd64
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: fglrx
Package: firefox-3.6 (not installed)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=de_DE.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
Uname: Linux 2.6.31-19-generic x86_64
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

Changed in firefox (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
fbraun (fbraun) wrote :

uh, sorry. I use 3.6 from the firefox-3.5 package - should I run apport again? :>

fbraun (fbraun) wrote :

The bug appears to be profile-bound. Using a new profile, will not trigger the bug, although safe-mode will.

Draycen DeCator (ddecator) wrote :

@ChosenOne
In order to get a better idea of what could be causing this behavior, we would appreciate it if you could let us know about any errors in your error console. To get this information, please go to Tools > Error Console, clear anything currently in the console, then see if anything gets added there once the behavior begins. If any errors show up once the behavior begins, then please post the error messages here.

fbraun (fbraun) wrote :

Okay, it is the following (background: I activated that I'm being asked before accepting any cookies)

No chrome package registered for chrome://cookie/content/cookieAcceptDialog.xul

Draycen DeCator (ddecator) wrote :

Thank you for letting us know what the exact error message is. It sounds like this may be related to bug 514108, which was fixed with a recent update for Firefox 3.6. Can you please make sure that you are running the latest version and report back to us on whether or not an update resolved the issue?

fbraun (fbraun) wrote :

Sorry, I forgot where my Firefox version is coming from.
I am using the "ppa:mozillateam/firefox-stable" ppa-repository.

Draycen DeCator (ddecator) wrote :

@ChosenOne
Sorry about that, I did not realize that the latest Firefox 3.6 update had not been pushed to Karmic through the PPA yet. The update is being pushed right now and you should be able to get it relatively soon. This update fixes the bug I mentioned before, which appears to be the same as yours.

Since the fix will be available to you soon, I am closing this bug. I would mark it as a duplicate of bug 514108, however the original reporter ended up having this problem due to a bad extension. Although the behaviour is similar, I do not want to get the causes mixed up.

If this bug continues to be a problem for you after you receive the update, then please feel free to come back to this bug and set the status back to "New."

Thank you again for helping to make Ubuntu better, and please report any more bugs that you encounter!

Changed in firefox (Ubuntu):
status: New → Invalid

I've got the same problem using version 6.0.2+build2+nobinonly-0ubuntu0.11.04.1 in Natty. Strangely, when I try safe-mode the problem disappears, but then I turn on every addon one by one and in the end I have all the addons activated and there is no problem. Yet, after some days the problem appears again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers