Firefox(all versions) with an element with "contenteditable" attribute the "middle click" doesn't work (open link in new tab)

Bug #514828 reported by José Cabo
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Hi,
I'm from spain.

I have a problem with Firefox (I test the v. +3.5, the v +3.0 AND with different 3.6 compilations). But with Chromium or Chrome works totally correctly.

***The problem is***:

If in an HTML document any of the elements has the "contenteditable=true" attribute the middle click of the mouse (open link in a new tab) doesn't work.

I post in a question first because i don't sure if this is a real bug.

I try to reproduce it in other systems (windows 7) with Firefox 3.5 and the -middle click works- so I think that the problem is in the version of the Firefox compiled for Linux, in especial, Ubuntu.

I think that the problem seems to conflict with the "paste event" in Linux system (middle click in gedit or something).

PS: to reproduce it:
- You can try with Firebug.
- First try the middle click works (It should open a new tab if you click over an anchor).
- with some element (like div) edit it I write or add a new attribute: contenteditable=true
- try to use the middle click.

Please if this is a bug can you convert in a bug report? Thanks!

PS: sorry for my English.

Revision history for this message
José Cabo (folcwine) wrote :

Any comments, any "testers"?

Revision history for this message
Draycen DeCator (ddecator) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. I have tested this with Firefox 3.7 on Ubuntu Karmic and seem to have gotten the same results.

When the content of a site is editable, then middle-click causes anything copied to be pasted into the middle of the text for the link. Right-clicking the link gives the option to open in a new tab (which does work), so Firefox does recognize that it is a link. The behavior is the same in Opera.

With Chrome, no text is pasted anywhere on the page when a middle-click is used. However, I was unable to get the link to open in a new tab after a middle-click with Chrome while the content was editable (but it did work when it was not editable).

I am marking this report "Confirmed," however more research needs to be done in regards to the exact cause of this behavior (and whether or not anything can really be done about it).

Changed in firefox (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers