Firefox is not honoring /etc/fonts/local.conf settings

Bug #42955 reported by Mante on 2006-05-04
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Mozilla Bugs
firefox-3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: fontconfig

I have a line like this in /etc/fonts/local.conf so that all the gnome fonts below 14px are not antialiased. Strange things with dapper (breezy works) Firefox ignore local.conf and render all fonts with antialias.
Bug? Need to change something in firefox too?

<match target="font">
   <test name="size" compare="less">
      <double>14</double>
</match>
   </test>
   <edit name="antialias" mode="assign"><bool>false</bool></edit>
</match>

Mante (mante) wrote :

Update: firefox is totally ignoring also whatever else local.fonts directive (font-size, font-type etc). I had to manually create UserChrome.css to set the font I wish to use.

Mante (mante) wrote :

fixed

Don't understand why but <test name="size"> is ignored

changed with:

<test name="pixelsize">

Charles (landemaine) wrote :

Ok, I finally found a solution. I updated my XML files, please go ahead and follow this tutorial that will fix fonts for good: http://ubuntuforums.org/showthread.php?t=208396 - Problem was in fontconfig. Now fonts in Firefox are going to look good.

Marco Rodrigues (gothicx) wrote :

Still a problem at Feisty ?!

Changed in fontconfig:
assignee: nobody → mozillateam
status: Unconfirmed → Confirmed
Changed in firefox:
assignee: mozillateam → mozilla-bugs
Kaihsu Tai (kaihsu) wrote :

Still a problem in Gutsy. (I updated last night.) I attach a screenshot, which I hope illustrates this bug (or maybe I am reporting a new bug? Let me know if that is the case). You can notice that the shapes of the letters are different in the menu bar and in the browser-rendered content. In particular, the shape of the letter ‘a’ is horrible in the latter.

In Feisty this did not seem to be the case unless certain language-support packages were installed (I cannot remember which; sorry). In Gutsy, I think I only have the support for the English-language installed; even then, this is still a problem.

Kaihsu Tai (kaihsu) wrote :

I should add that this is a problem when I am using the typeface Gentium. When I use a typeface such as FreeSerif, there seems to be antialiasing (no problem; I attach screenshot for this).

Kaihsu Tai (kaihsu) wrote :

The setting in my NFS-mounted home directory worked beautifully with the correct rendering in Feisty, but not in Gutsy.

Kaihsu Tai (kaihsu) wrote :

Just upgraded Firefox to ‘Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.8) Gecko/20071022 Ubuntu/7.10 (gutsy) Firefox/2.0.0.8’, but problem still remains.

Mante (mante) wrote :

Disabling language-selector.conf in /etc/fonts doesn't help?
mv /etc/fonts/language-selector.conf /etc/fonts/language-selector.conf~

and then restart gnome

Kaihsu Tai (kaihsu) wrote :

I have a network-file-system-mounted version of Firefox 2.0.0.6 in which the problem does not seem to occur. (The problem is there in 2.0.0.8.)

Kaihsu Tai (kaihsu) wrote :

Now, I have upgraded the NFS-mounted version to 2.0.0.8. So both copies are 2.0.0.8, but the NFS-mounted one does not have the font problem, whereas the local one in /usr/bin/firefox does! What could be wrong?

Kaihsu Tai (kaihsu) wrote :

Strangely, if I open a web link from the ‘About Ubuntu’ help page, the font is antialiased. Running
  ps -elf |grep firefox
gave the following:

0 S kaihsu 12709 1 0 85 0 - 438 wait 12:20 ? 00:00:00 /bin/sh /usr/bin/firefox http://www.gnu.org/philosophy/
0 S kaihsu 12722 12709 0 85 0 - 439 wait 12:20 ? 00:00:00 /bin/sh /usr/lib/firefox/run-mozilla.sh /usr/lib/firefox/firefox-bin http://www.gnu.org/philosophy/
0 S kaihsu 12726 12722 23 75 0 - 42038 - 12:20 ? 00:00:10 /usr/lib/firefox/firefox-bin http://www.gnu.org/philosophy/
0 S kaihsu 12828 12759 0 77 0 - 747 pipe_w 12:21 pts/2 00:00:00 grep firefox

Trying to mimic these commands gave Firefox instances without antialiasing. I am puzzled.

Alexander Sack (asac) wrote :

Is this an issue with the firefox-3.0 package available in gutsy universe? Anyone can verify?

Thanks,
 - Alexander

Changed in firefox-3.0:
status: New → Incomplete
Kaihsu Tai (kaihsu) wrote :

Still problematic in Firefox 2.0.0.10 + Gutsy.

How does one verify this?

Alexander Sack, 2007-11-06 17:35:37-0000:
> Is this an issue with the firefox-3.0 package available in gutsy
> universe? Anyone can verify?

--
2007-12-10 Human Rights Day http://www.un.org/events/humanrights/

Kaihsu Tai (kaihsu) wrote :

Still problematic in Firefox 2.0.0.11 + Gutsy.

Alexander Sack (asac) wrote :

to verify: Install the firefox-3.0 package. you should be able to use it without interfering your "normal" firefox install.

Thanks,
  - Alexander

Kaihsu Tai (kaihsu) wrote :

I installed and tested firefox-3.0. I can see the rendering is ‘different’ but the problem still persists.

In about:config, I have:
font.FreeType2.autohinted;true
font.FreeType2.enable;true
font.FreeType2.unhinted;false

and the rendering is very similar to that in the first image I posted on 2007-10-18.

description: updated
Kaihsu Tai (kaihsu) wrote :

To demonstrate, I attach an image. Notice the difference in the rendering of the letter ‘a’ for example. In the image, you can see how differently gnome-panel, OpenOffice.org 2.3, Firefox 2.0.0.11, and Gran Paradiso (firefox-3.0) render the typeface Gentium with about the same size. OpenOffice.org is the best, then gnome-panel, then the Firefox versions.

Changed in firefox-3.0:
status: Incomplete → Confirmed
Kaihsu Tai (kaihsu) wrote :

Strange: I went to Preferences: Appearances: Fonts, and went into Details to turn Smoothing to Greyscale and Hinting to Slight, and the typefaces looked better (like that in OpenOffice.org)! I consider it resolved this way for me.

Alexander Sack (asac) on 2007-12-29
Changed in firefox-3.0:
status: Confirmed → Fix Released
Changed in firefox (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers