Yoruba missing from language preferences

Bug #366578 reported by Lars Noodén on 2009-04-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Medium
firefox (Ubuntu)
Wishlist
Unassigned
firefox-3.0 (Ubuntu)
Wishlist
Unassigned

Bug Description

Yoruba, and possibly other languages, are missing from the language preferences list.
The full list of ISO-630 two-letter language codes can be filled out.
http://www.loc.gov/standards/iso639-2/php/code_list.php

Reproducible: Always

Steps to Reproduce:
1. Edit
2. Preferences
3. Content
4. Language
5. Choose
6. Select language
Actual Results:
Yoruba (yo) not shown.

Expected Results:

Yoruba (ISO-639 code = "YO") should be in the list next to YI (yiddish)

Platform:

Linux mini 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

Package: firefox
Version: 3.0.8+nobinonly-0ubuntu3

Upstream bug report:
https://bugzilla.mozilla.org/show_bug.cgi?id=489404

Lars Noodén (larsnooden) wrote :

Yoruba, and possibly other languages, are missing from the language preferences list.
The full list of ISO-630 two-letter language codes can be filled out.
http://www.loc.gov/standards/iso639-2/php/code_list.php

Reproducible: Always

Steps to Reproduce:
1. Edit
2. Preferences
3. Content
4. Language
5. Choose
6. Select language
Actual Results:
Yoruba (yo) not shown.

Expected Results:

Yoruba (ISO-639 code = "YO") should be in the list next to YI (yiddish)

Platform:

Linux mini 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

Package: firefox
Version: 3.0.8+nobinonly-0ubuntu3

Upstream bug report:
https://bugzilla.mozilla.org/show_bug.cgi?id=489404

Micah Gersten (micahg) wrote :

Moving to Firefox 3.

affects: firefox (Ubuntu) → firefox-3.0 (Ubuntu)
Lars Noodén (larsnooden) wrote :

Still present in Firefox 3.5.3 in Karmic Koala

$ apt-cache policy firefox
firefox:
  Installed: 3.5.3+build1+nobinonly-0ubuntu2
  Candidate: 3.5.3+build1+nobinonly-0ubuntu2
  Version table:
 *** 3.5.3+build1+nobinonly-0ubuntu2 0
        500 http://fi.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Micah Gersten (micahg) wrote :

User already reported upstream.

Changed in firefox-3.0 (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Changed in firefox:
status: Unknown → New
Lars Noodén (larsnooden) wrote :

The language is still missing from the list of options:

$ lsb_release -rd
Description: Ubuntu 10.04.1 LTS
Release: 10.04

# apt-cache policy firefox
firefox:
  Installed: 3.6.7+build2+nobinonly-0ubuntu0.10.04.1
  Candidate: 3.6.8+build1+nobinonly-0ubuntu0.10.04.1
  Version table:
     3.6.8+build1+nobinonly-0ubuntu0.10.04.1 0
        500 http://fi.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
        500 http://security.ubuntu.com/ubuntu/ lucid-security/main Packages
 *** 3.6.7+build2+nobinonly-0ubuntu0.10.04.1 0
        100 /var/lib/dpkg/status
     3.6.3+nobinonly-0ubuntu4 0
        500 http://fi.archive.ubuntu.com/ubuntu/ lucid/main Packages

Changed in firefox:
importance: Unknown → Medium
Lars Noodén (larsnooden) wrote :

Still present in Firefox 4.0.1

$ apt-cache policy firefox
firefox:
  Installed: 4.0.1+build1+nobinonly-0ubuntu0.11.04.1
  Candidate: 4.0.1+build1+nobinonly-0ubuntu0.11.04.1
  Version table:
 *** 4.0.1+build1+nobinonly-0ubuntu0.11.04.1 0
        500 http://fi.archive.ubuntu.com/ubuntu/ natty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ natty-security/main amd64 Packages
        100 /var/lib/dpkg/status
     4.0+nobinonly-0ubuntu3 0
        500 http://fi.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages

Lars Noodén (larsnooden) wrote :

Still present in Oneiric with Firefox 7.0.1

$ lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

$ apt-cache policy firefox
firefox:
  Installed: 7.0.1+build1+nobinonly-0ubuntu2
  Candidate: 7.0.1+build1+nobinonly-0ubuntu2
  Version table:
 *** 7.0.1+build1+nobinonly-0ubuntu2 0
        500 http://fi.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

Lars Noodén (larsnooden) wrote :

Still present in precise in Firefox 8:

$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

$ apt-cache policy firefox
firefox:
  Installed: 8.0+build1-0ubuntu1
  Candidate: 8.0+build1-0ubuntu1
  Version table:
 *** 8.0+build1-0ubuntu1 0
        500 http://fi.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Lars Noodén (larsnooden) wrote :

Still precent in Precise with Firefox 9:

$ apt-cache policy firefox
firefox:
  Installed: 9.0~b6+build1-0ubuntu1
  Candidate: 9.0~b6+build1-0ubuntu1
  Version table:
 *** 9.0~b6+build1-0ubuntu1 0
        500 http://fi.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Andreas Moog (ampelbein) on 2011-12-17
Changed in firefox (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Lars Noodén (larsnooden) wrote :

Still present in Firefox 10

$ apt-cache policy firefox
firefox:
  Installed: 10.0+build1-0ubuntu1
  Candidate: 10.0+build1-0ubuntu1
  Version table:
 *** 10.0+build1-0ubuntu1 0
        500 http://ports.ubuntu.com/ubuntu-ports/ precise/main powerpc Packages
        100 /var/lib/dpkg/status

In , 5pa0 (5pa0) wrote :

Created attachment 608687
Screenshot showing lack of Yoruba language option.

This is still the case in 13.0a2.

Changed in firefox:
status: New → Confirmed
Lars Noodén (larsnooden) wrote :

Seems to be fixed in Firefox 15.

$ apt-cache policy firefox
firefox:
  Installed: 15.0~b2+build1-0ubuntu1
  Candidate: 15.0~b2+build1-0ubuntu1
  Version table:
 *** 15.0~b2+build1-0ubuntu1 0
        500 http://ports.ubuntu.com/ubuntu-ports/ quantal/main powerpc Packages
        100 /var/lib/dpkg/status

I'm not sure if it is important to back port it, but it does seem fixed in the current version.

Changed in firefox (Ubuntu):
status: Triaged → Fix Released

Looks like this was fix by bug 730625.

Changed in firefox:
status: Confirmed → Fix Released
Micah Gersten (micahg) wrote :

Firefox 3.0 source is only left in hardy which no longer has desktop support, all supported stable desktop releases should have this fix now.

Changed in firefox-3.0 (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.