Firefox language settings incorrect for Aus & NZ users

Bug #3127 reported by Aaron Whitehouse on 2005-10-14

This bug report will be marked for expiration in 17 days if no further activity occurs. (find out why)

24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Wishlist
Unassigned

Bug Description

I use a fully updated Dapper Beta.

The languages which are in the list by default in Firefox are en-us and en. For New Zealand they should be (in this order):
en-nz
en-gb
en
en-us

Perhaps the "System -> Administration -> Languages" can be used to prioritise languages etc. to improve the 'one setting, one place' philosophy which Ubuntu is attempting (for example with OOo localisations etc.). Even if the system setting was only used if a profile did not already exist it would be a great start.

Two approaches could be taken to this:
 * the user could manually rank variants of 'English' so that I could set (in System -> Administration -> Languages) the above rankings; or
 * New Zealand users have the above languages set up for them; or
 * a section in the languages could allow the ranking manually *and* they default to the above for New Zealanders.

Obviously I would like to see the same philosophy applied to all languages. One advantage in doing this may be that programs (synaptic?) could install alternative dictionaries etc. if your first choice was missing.

Questions or clarifications, just ask.

Changed in firefox:
assignee: nobody → ijackson
Henrik Nilsen Omma (henrik) wrote :

Hi Aaron,

Have you had a chance to test this with dapper? Reporting such bugs 4-6 weeks before the release is actually more helpful than after, because this is the time when we focus most on fixing these smaller errors. After the release we tend to focus on new features and only critical bugs and security issues are fixed in older versions.

- Henrik

User Agent in a fully updated Dapper Flight 6 is:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060413 Ubuntu/dapper Firefox/1.5.0.1
so still not correct. I'll check the languages when I get a moment (I think I fixed it in my install so will have to reset my profile).

Changed in firefox:
status: Unconfirmed → Needs Info

Hello all,

I found a second and retested this. My languages are:
En-US
En
(in that order).

As I posted, this should be:
en-nz
en-gb
en
en-us
(in that order).

I tested on a fully updated Dapper Beta (updated to 11 May).

Thanks.

Changed in firefox:
status: Needs Info → Unconfirmed

Would it help if I separated the UA and languages issues into two bugs?

description: updated

Re-tested. The issue is still present in Dapper Final.

Re-tested. This issue is still present in Bon Echo Beta 2 in Edgy Knot 3.

Ian Jackson (ijackson) on 2006-09-20
Changed in firefox:
assignee: ijackson → nobody

Still present in Edgy RC.

Still present in Edgy Final.

John Vivirito (gnomefreak) wrote :

Alexander what are your thoughts on this bug?

Changed in firefox:
assignee: nobody → mozillateam
importance: Low → Wishlist
status: Unconfirmed → Needs Info
David Farning (dfarning) on 2007-02-24
Changed in firefox:
assignee: mozillateam → mozilla-bugs

This is still occurring in Gutsy Tribe 5.

Nanley Chery (nanoman) on 2007-09-17
Changed in firefox:
status: Incomplete → Confirmed
nullack (nullack) wrote :

Its also still occuring in Jaunty since the original bug was reported in 2005 :)

Anyway this occuring for Australia as well. For Australia a user has to manually add the en-au, make it first preference, then add en-gb and make it the second preference. This is despite the system knowing I have an Australian configuration.

Alexander Sack (asac) wrote :

Can you please check that the language order for this bug is determined through the "intl.accept_languages" setting in about:config?

nullack (nullack) wrote :

Thanks for looking at this Alexander. Im not sure if this will help as Ive overwritten the default with my user preference of:

intl.accept_languages;en-au,en-gb,en-us,en

This came about when I manually added the Aus and GB languages. Im not sure what the default used to be.

Can you please retest with newer and supported Ubuntu versions?

Changed in firefox (Ubuntu):
status: Confirmed → Incomplete
Stephen Brown (sbrown1992) wrote :

Problem still exists in Ubuntu 12.04. Firefox language preference is still en-US, en on a New Zealand based system.

Changed in firefox (Ubuntu):
status: Incomplete → Confirmed
Carlos Gomes (gocarlos) wrote :

can we close this issue?

Paul White (paulw2u) wrote :

>can we close this issue?

With no comments for nearly 6 years, probably.

Changing status to "Incomplete" so that the bug report expires in the absence of anyone advising that they still see the issue reported.

Changed in firefox (Ubuntu):
assignee: Mozilla Bugs (mozilla-bugs) → nobody
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers