Firefox doesn't always shut down properly

Bug #252151 reported by Noelinho on 2008-07-26
8
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned
firefox-3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mozilla-firefox

Firefox version: 3.0.1+build1+nobinonly-0ubuntu0.8.04.2
Ubuntu release: 8.04.

The problem is with closing and re-opening Firefox. Sometimes, when I close Firefox, the process is still running, and so when I go to re-open Firefox, I get a message telling me Firefox is still running and I need to close it first before opening it again, and so I need to use the terminal or system monitor to shut the program down.

Thank you for your bug report. I'm setting the status of this bug to 'incomplete' to indicate we would like to have some more information.

- How did you close firefox when it happens? From the menu, by closing a window, re-open after an applet installation or update, mouse, keyboard, ... ?
 - Does it seem to happen when you have been viewing particular webpages? If so: what pages are those?
 - Is firefox using a lot of memory when it is still running after you closed it? The system monitor provides this information.
 - Please check if it happens also when you are using an entirely new profile. https://wiki.ubuntu.com/MozillaTeam/Bugs explains how.
 - That same page also might give you some other useful ways to get more information.

Please do not hesitate to mention anything else you think might be useful. Thanks.

Changed in firefox:
status: New → Incomplete
Sergio Zanchetta (primes2h) wrote :

It happens always for me, since some upgrades 1 or 2 months ago.

I usually exit firefox closing the main window, then "Clear private data" window pops up but after closing it firefox is still running.
I have to kill firefox brutally from terminal to open it again.

It doesn't depend on specific webpages.

Sergio Zanchetta (primes2h) wrote :

I'll try to create a new profile and I let you know the result.

Thank you for your bugreport. Since this seems to be an issue with
version 3 of the firefox browser, I'm reassigning the package.

 affects ubuntu/firefox
 status invalid

 affects ubuntu/firefox-3.0
 status incomplete

Changed in firefox:
status: Incomplete → Invalid
Brice Terzaghi (terzag) wrote :

I have been encountering this bug too. It happens at least since Firefox 3.0b5 was included in Hardy and is still present in Intrepid. I think it already happened with FF2 in Gutsy, although I'm not completely sure of it.

What happens is that "sometimes", quitting Firefox doesn't kill the firefox process, which then starts to eat up CPU power. When trying to restart FF, there's a message stating that it's already running.

I haven't been able to find a pattern in the crashes : no particular website or technology (e.g. Flash) is involved. It seems random.

Also, as it happened to me again two days ago, I've started to run Firefox exclusively from a terminal to see if I could get an error message that could explain the crash : I got the problem again today and no info. When quitting FF, I came back to the terminal with no prompt. Simply using ctrl+C killed the process and came back to the prompt.

I there a way to have infos about what happens with a process in that kind of case ?

Daniele (danielevaltorta) wrote :

I have the same problem too, but in my case it seems that firefox doesn't close properly if (but not only if) during my last browsing I have visited the page:
http://www3.uninsubria.it/uninsubria/facolta/scico.html

Maybe it has something to do with the embedded java frame.

Łukasz Kuryło (lukasz-kurylo) wrote :

Firefox is waiting on futex if this helps.

lukasz@eleonore:~$ ps ax | grep fire
 7541 ? S 1:01 /usr/lib/firefox-3.0.7/firefox
 7943 pts/1 S+ 0:00 grep fire
lukasz@eleonore:~$ strace -p 7541
Process 7541 attached - interrupt to quit
futex(0xd99138, FUTEX_WAIT_PRIVATE, 2, NULL
^C <unfinished ...>
Process 7541 detached
lukasz@eleonore:~$ killall firefox

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers