user string agent doesn't identify ubuntu

Bug #246775 reported by John Levin on 2008-07-08
18
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Alexander Sack
Hardy
High
Alexander Sack
Intrepid
High
Alexander Sack

Bug Description

Binary package hint: mozilla-firefox

The user agent string of firefox in hardy doesn't identify it as being Ubuntu:

• Ubuntu 7.10: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071204 Ubuntu/7.10 (gutsy) Firefox/2.0.0.11
• Ubuntu 8.04: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008060309 Firefox/3.0

This was noted by Distrowatch:
http://distrowatch.com/weekly.php?issue=20080707#statistics

Alexander Sack (asac) wrote :

most likely was dropped in one of our preference cleanups. Thanks for escalating this.

Changed in firefox:
importance: Undecided → High
status: New → Triaged
assignee: nobody → asac
importance: Undecided → High
status: New → Fix Committed
assignee: nobody → asac
Matt Zimmerman (mdz) wrote :

According to the changelog, this is fixed in Intrepid:

firefox-3.0 (3.0.1+build1+nobinonly-0ubuntu2) intrepid; urgency=low

  RELEASE 3.0.1+build1+nobinonly-0ubuntu2 to ubuntu/intrepid
  * Fix: #246775 - "wrong user-agent string in hardy build" by adding proper
    build-depends
    - update debian/control

 -- Alexander Sack <email address hidden> Sat, 26 Jul 2008 16:08:26 +0200

though the magic syntax was missing to automatically close the bug.

Changed in firefox:
status: Triaged → Fix Released
Julian Alarcon (alarconj) wrote :

I'm using Firefox 3.0.3 in Hardy from official repositories. And this bug is no more!!

My user agent string:
Mozilla/5.0 (X11; U; Linux i686; es-AR; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3

Changed in firefox:
status: Fix Committed → Fix Released
Julian Alarcon (alarconj) wrote :

Changelog here:
https://lists.ubuntu.com/archives/hardy-changes/2008-September/012018.html

firefox-3.0 (3.0.2+build6+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * new security/stability release (v3.0.2 build6)
    - see USN-645-1

  * Fix: #246775 - "wrong user-agent string in hardy build" by adding proper
    build-depends
  - update debian/control

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers