Ubuntu

Java console not available.

Reported by asdf on 2008-06-19
6
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Undecided
Unassigned
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

The Java console is nowhere, but Java works in the browser. I even installed the Java Console extension (6.0.02), but there is still no console in the tools menu. I didn't try it on another platform, so I don't know whether it's a problem with ubuntu or not. However I tried on another Ubuntu box and it did also not work there .

I installed the following packages:
sun-java6-bin
sun-java6-doc
sun-java6-jdk
sun-java6-jre
sun-java6-plugin

and yes this is important and we need this feature. I have checked now it's a problem with Ubuntu, on Vista with FF3 and suns jdk it works without any extension.

strangedata (rcteigao) wrote :

bump

Johan Dahl (johan-dahl) wrote :

A workaround

In gnome: Select System > Settings Sun Java x.x Control Panel
In terminal: jcontrol

1) Select the tab advanced.
2) Expand the node "Java-console"
3) Select show console (default is hide)

Now will the console show up the first time you run an applet. You can keep it open for debugging etc.
If you close the console window must you restart your browser to make it pop-up again.

John Vivirito (gnomefreak) wrote :

Thank you for taking the time to file this bug report with us. Closing due to age. If this is still a problem in 3.0.7 please reopen this bug.
Also please reopen with all new information on how to reproduce this bug by giving us step by step instructions.
We also need what happens what is expected to happen.
To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in firefox (Ubuntu):
status: New → Invalid
Johan Dahl (johan-dahl) wrote :

Tested with Firefox 3.0.7 and Java Console Extension. Extension installs without a problem. But no menu item for showing the java console is available.

Brian C. Ladd (drbcladd) wrote :

Johan Dahl's workaround from 2008-09-01 still works. The Java Console Extension does not provide a menu entry (and there is no native entry in the tool menu).

Firefox 3.0.8
Java: java-6-sun 1.6.0_13

Micah Gersten (micahg) wrote :

Per https://bugzilla.mozilla.org/show_bug.cgi?id=191299 :
Feature has been removed on purpose. Will not be added back. They suggest making an extension. Someone has done that, but it's out of date:
https://addons.mozilla.org/en-US/firefox/addon/5403
You can contact the author of the extension if you would like it updated.

Changed in firefox-3.0 (Ubuntu):
status: Invalid → Won't Fix
Micah Gersten (micahg) wrote :

Status addressed in other update.

Changed in firefox (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.