Ubuntu

Default Hebrew fonts in Firefox are unreadable, ugly

Reported by mangar on 2005-10-05
48
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
firefox (Ubuntu)
Low
Mozilla Bugs

Bug Description

The default Hebrew fonts in firefox are unreadable and ugly,
The default can be easily changed. suggestion:
using the Hebrew font package "Culmus", already in ubuntu,

firefox settings:

Proportional: Sans Serif Size(pixels) 16
Serif : FreeSans
Sans-serif : FreeSans
Monospace : Monospace Size(pixels) 12

Those values are based on feedback from a local (and the main) LUG
www.whatsup.org.il

Thanks in advance!
(as a side note: most of the israeli users of FOSS seems to prefer english UI -
changing the values only for
the locale will be - in ,my opinion - insufficient)

Henrik Nilsen Omma (henrik) wrote :

Hi mangar,

Have you had a chance to test this in dapper (with a Live CD perhaps)? I don't read Hebrew, but the fonts in dapper look ok to my untrained eye.

- Henrik

i've asked the local LUG it's opinion,
and the majority of opinions claim that the
default font is okay.

thanks !

forum discussion (in hebrew - for reference):
http://www.whatsup.org.il/index.php?name=PNphpBB2&file=viewtopic&t=30672

ok, maybe i wrote too soon, sorry.
in several sites, the anti-aliasing makes the fonts
too fuzzy, and unreadable.

screenshot:
http://img91.imageshack.us/img91/1553/dapperhebrewscreenshot9tk.th.png

the website is www.ynet.co.il (local news site)
the problem is that the serifs of the font in use are too pronounced.

a possible solution: use the nachlieli CLM font
from the culmus font package.

thanks in advance!

Henrik Nilsen Omma (henrik) wrote :

Thanks, yes I see that some of the fonts are too fuzzy. The right image link seems to be http://img91.imageshack.us/img91/1553/dapperhebrewscreenshot9tk.png

Changed in firefox:
status: Unconfirmed → Confirmed
Ian Jackson (ijackson) on 2006-09-27
Changed in firefox:
assignee: ijackson → nobody
David Farning (dfarning) wrote :

Mangar,

Is this still and issue in edgy.

Thanks
David

i've asked at the local linux site : www.whatsup.org.il

it seems that the problem wasn't solved
(there's some screenshots there, although most of the text is in hebrew)

http://whatsup.org.il/index.php?name=PNphpBB2&file=viewtopic&p=226630#226630

err... the relevant screen shot is at the post with the words ubuntu, arial,msttcorefonts

thanks for your interest!

David Farning (dfarning) wrote :

Manger,

Thanks for all the time your have invested in helping with this issue.

My inability to read Hebrew is make it difficult to work on this issue. I had the same problem with a Thai language issue the other day.

Would you, or someone, from your local users group install the official firefox from http://www.mozilla.com to see if the issue exist upstream as well. If the problem exist there as well we can file a bug at https://bugzilla.mozilla.org/

Thanks
David

i've tried the following:
1. backed up ~./mozilla,
2. remove ~./mozilla
3. downloaded firefox 2 from mozilla.com, extracted, run.

result:
the fonts on www.ynet.co.il looks fine.

caveat:
i've got msttcorefonts, as well as culmus and culmus-fancy (hebrew fonts packages) installed.

i've asked at the forums, whether anyone there can try firefox from mozilla.com
on a clean installation, and i'll update when there will be results

Alexander Sack (asac) wrote :

is this still an issue in latest firefox (e.g. edgy or feisty)?

Changed in firefox:
assignee: nobody → mozillateam
status: Confirmed → Needs Info

On Monday 19 February 2007 18:25:08 Alexander Sack wrote:
> is this still an issue in latest firefox (e.g. edgy or feisty)?
Well, there is a workaround: installing the additional fonts. However, I think
this problem still has to be handled, for the following reasons:

1. the system should work well by default. If it means that those fonts should
be enabled in a default config (in Hebrew locale), maybe that's the solution.
2. Note that the problem does not happen in Konqueror - therefore, it looks
like some configuration bug.

> ** Changed in: firefox (Ubuntu)
> Assignee: (unassigned) => Mozilla Team
> Status: Confirmed => Needs Info
>
> ** Tags added: mt-needtester

Alexander Sack (asac) wrote :

so what packages are missing in default hebrew install? Can you add them as comment and maybe extent bug description?

Thanks!

using the Hebrew font package "Culmus", already in ubuntu,

firefox settings:

Proportional: Sans Serif Size(pixels) 16
Serif : FreeSans
Sans-serif : FreeSans
Monospace : Monospace Size(pixels) 12

David Farning (dfarning) on 2007-02-24
Changed in firefox:
assignee: mozillateam → mozilla-bugs
Rich Wales (richw) wrote :

I've noticed some problems with the placement of "vowel points" when Hebrew text is displayed in Firefox. For example, in the Wikipedia article "Keturah", the dot that indicates the "u" vowel is showing up to the right of the letter "vav" (vertical line), whereas it ought to be positioned to the left of the "vav". (See attached screen shot.)

Rich Wales (richw) wrote :

Here's another example -- again from Wikipedia (article "Mezuzah"), but using a different font. The vowel points are positioned completely wrong -- appearing after (i.e., to the left of) the letters, whereas most vowel points should appear under or over the letters. (See attached screen shot.)

If you aren't familiar with Hebrew writing, you might want to look at the Wikipedia article "Niqqud" for an explanation of how vowels are indicated in certain texts.

Rich Wales (richw) wrote :

Here's a sample of Hebrew text from the same WIkipedia article ("Mezuzah") -- as seen in Firefox in Windows. This is what Hebrew with "vowel points" is supposed to look like. Again, note that the vowel points are positioned under, over, or in the middle of the letters -- which is NOT the way they currently look when I view this or other pages in Firefox while running Ubuntu.

I checked my Hebrew font settings in Firefox, and they are exactly the same as what "mangar" reported earlier.

For comparison's sake, I installed Konqueror and looked at this same web page in Konqueror. The text of the Hebrew blessing looks better in Konqueror, but there are still problems. I'll include a screen shot in a followup comment.

Rich Wales (richw) wrote :

OK, here's the same Hebrew text sample as before, as viewed in Konqueror on my Ubuntu Feisty system. Most of the vowel points are in their correct places, but a few are shown in separate boxes instead of being merged into the preceding letter (i.e., the character to the right of the box). This is NOT acceptable; the text really needs to look just like the Windows example in my previous comment.

Alexander Sack (asac) wrote :

On Sun, Apr 08, 2007 at 06:52:20PM -0000, Rich Wales wrote:
> OK, here's the same Hebrew text sample as before, as viewed in Konqueror
> on my Ubuntu Feisty system. Most of the vowel points are in their
> correct places, but a few are shown in separate boxes instead of being
> merged into the preceding letter (i.e., the character to the right of
> the box). This is NOT acceptable; the text really needs to look just
> like the Windows example in my previous comment.
>

So what font settings do you have to choose to make firefox detect it
properly. BTW, are you running hebrew ubuntu?

 - Alexander

Rich Wales (richw) wrote :

Alexander Sack asked:

> So what font settings do you have to choose to make firefox detect it properly?

I didn't have to make any changes at all to Firefox's default settings to have Hebrew text show up. If, by "properly", you mean settings that would cause vowel-pointed text to show up properly, I still haven't seen this sort of text displayed properly in Firefox on an Ubuntu system -- though it shows up just fine in Firefox on a Windows system.

Note that Hebrew text without "vowel points" looks fine in Firefox on Ubuntu. Most modern Hebrew text is written without those extra dots and lines (native speakers generally know which vowels are required in which words without needing visual cues). However, in those examples of Hebrew text that do include vowel points (such as sacred texts, or rare cases where vowels must be indicated in ordinary text as the only way to resolve an ambiguity), it is essential that they are positioned correctly, or else there is a bug that needs to be fixed.

> BTW, are you running hebrew ubuntu?

No. I'm running an English-language installation of Ubuntu.

liorwohl (liorwohl) wrote :

to make the fonts look good in websites which don't choose font or choose font that there is only on Windows you just need to change sarif to sans-sarif. no need for culmus...

liorwohl (liorwohl) wrote :
liorwohl (liorwohl) wrote :

the problem is fixed in firefox 3 that is currently in Hardy :-)
firefox now use a readable hebrew font by default. (tested with http://ynet.co.il)

The problem still exists for Hardy alpha, as of the 14/3/2008.
ynet.co.il, haaretz.co.il.
(default installation).

The bug is still appliable

John Vivirito (gnomefreak) wrote :

This bug is a duplicate of a bug already reported I will look for it sometime today but its still before 7am here and im waiting to get to sleep

John Vivirito (gnomefreak) wrote :

This bug was fixed in new version of 'he' from upstream and i could swear we added the fix into language-pack-gnome-he please try to install that if its not already see if it fixes it (dont forget to restart firefox after installing before testing.) Im still looking for the bug

John Vivirito (gnomefreak) wrote :

EVERYONE please let me know if you suffer from same thing as bug #23402 that is the bug i was looking for that i know we fixed in language-pack-gnome-he and language-pack-gnome-he-base.
Can you please install these or if already there please make sure you have version 1:8.04+20080527 these are found in the following repo, please add these 2 repos to your hardy /etc/apt/sources.list save and close it than run sudo apt-get update than sudo apt-get upgrade (or) dist-upgrade. as long as you keep all your repos to Hardy you are in no danger of upgrading to intrepid assuming this is Hardy install.

John Vivirito (gnomefreak) wrote :

OOPS sorry here is the lines to add to your /etc/apt/sources.list file

deb http://de.archive.ubuntu.com/ubuntu/ hardy-proposed main restricted universe multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ hardy-proposed main restricted universe multiverse

Alexander Sack (asac) wrote :

firefox 3 is the only place where this gets fixed.

Changed in firefox:
status: Incomplete → Won't Fix
Alexander Sack (asac) wrote :

somewhat a dupe of bug 234029

Changed in firefox-3.0:
status: New → Fix Committed
Changed in xulrunner-1.9:
status: New → Fix Committed

On Sun, Jun 01, 2008 at 01:00:13PM -0000, mangar wrote:
> The bug is still appliable
>

Ensure that you hvae install hebrew language support in System ->
Administration.

Then restart your system. if you still see this, its probably a font
package thing. requesting reassignment

 affects ubuntu/firefox
 status invalid

 affects ubuntu/firefox-3.0
 status invalid

 affects ubuntu
 status incomplete
 tag needs-reassignment

 - Alexander

Changed in firefox:
status: Won't Fix → Invalid
Changed in firefox-3.0:
status: Fix Committed → Invalid
Yossi Gil (yossi-gil) wrote :

I use 8.10 Intrepid Ibex. The problem is here. Cannot read Hebrew in firefox. I installed the packages as you suggested. That is: language-pack-gnome-he-base
and language-pack-gnome-he

Przemysław Kulczycki (azrael) wrote :

Can someone with a knowledge of Hebrew language check if this bug is still present in the latest version of Ubuntu? (9.10. codename: Karmic Koala)

Rich Wales (richw) wrote :

The vowel-pointed Hebrew text in the "Keturah" and "Mezuzah" articles in the English Wikipedia look OK using Firefox 3.5.5 on Ubuntu 9.10.

Rich Wales (richw) wrote :

Minor correction: I did see one small flaw in the pointing of the word "קִדְּשַׁנוּ" (kideshanu = "sanctified us") in the "Mezuzah" article (http://en.wikipedia.org/wiki/Mezuzah) -- the schwa under the daled is shifted to the right (instead of being directly lined up with the vertical stroke). This same flaw occurs in the monospaced font used when editing a Wikipedia page. When I look at this same page using Firefox 3.5.5 on a Windows 7 system, this problem is not there. In any case, the bulk of the pointed Hebrew text looks just fine now -- previously, all the pointed text looked awful.

The fonts on www,ynet.co.il (and other sites that expect to use similar font), are still unreadable.
For illustration, look at the screenshots liorwohl submitted two years ago.
for solution, look at the free, open source solution I've suggested 3 years ago.
For the record, using "Serif" as the default font (as in the current configuration), will look terrible in any language.

FWIW, I no longer use Linux, and I've run Ubuntu from a virtual machine.

Additional sites that are shown using serif (totally illegible):

firefox.co.il/he - goes without saying
linux.org.il - well..
ynet.co.il - Israel's #1 tabloid
globes.co.il - Israel's #1 economics website.
bankhapoalim.co.il - Israel's largest bank online site.
fxp.co.il - The most popular under 12y/o forum in Israel
nana10.co.il - entertainment focus website
clalit.co.il - Israel's largest medical services insurance company
memri.org.il - Right wing political site
myparty.org.il - Left wing political site
http://inbarhovav.blogspot.com/ - pretty esoteric electronics blog
il.msn.com - well..
parts of hamakor.co.il, iglu.co.il - Israel's FOSS main website.
abmaps.co.il - major maps website
walla.co.il - second tier portal.
Layla.co.il - Israel's largest club and performances site.
parts of habama.co.il - Israel's premier culture site.

All of those sites are either major, or second tier. ALL of them are unusable out of the box for Hebrew reading users.

Changed in xulrunner-1.9 (Ubuntu):
status: Fix Committed → Confirmed
Micah Gersten (micahg) wrote :

@mangar,
thank you for the updates. I cannot see these issues any more in Firefox 3.5.6 on Ubuntu Karmic. I added the Hebrew Language pack and set that as default and tried a few of the font suggestions in this bug (FreeSans, serif) and I can read everything just fine. Could you please let us know what version of Ubuntu you are running with which version of Firefox?

Thanks.

Micah Gersten (micahg) wrote :

BTW, the pages in your list were fine with the serif font even before I installed the Hebrew language pack.

I've used a VirtualBox image of ubuntu karmic from:

http://downloads.sourceforge.net/virtualboximage/ubuntu-9.10.vdi.7z
(from http://virtualbox.wordpress.com/images/ubuntu/ )

updated with the latest packages, as of 14.12.2009, with no changes to the default install, running on a windows 7 x64 host, Virtualbox 3.1

after submitting the bug, I've made the following changes:
1. changed the theme to dust.
2. changed the wallpaper.
4. changed the anti-aliasing to "full".

It had no effect on the font readability (as expected).
I do not know what was the version of Firefox before or after the updates. If it's a problem with the font itself, updating Firefox won't fix the problem.

I'm well aware that changing the font will fix the problem with the font, trivially.

@Micah - can you add a screenshot of ynet before and after you've installed the Hebrew language pack?

I've removed myself as a subscriber to this bug. I won't be able to provide further information.

Tomer Cohen (tomerc) wrote :

I can confirm this is an upstream bug, which I wish to fix for years. Fixing it is not to complicated, and won't require too much work, but I am not too familiar with the default fonts that ship with Ubuntu and Linux in general. If someone want to help, please contact me.

Workaround: Installing msttcorefonts (Microsoft Windows core fonts) will make the fonts more readable, but this package is non-free and is not installed by default.

Changed in ubuntu:
status: Incomplete → Invalid
mikewhatever (mikewhatever) wrote :

Confirmed! This bug has been present in all versions of Ubuntu and Firefox, as far as I can remember. I've been changing serif to DejaVu Sans to work around it.

Changed in ubuntu:
status: Invalid → Confirmed
Changed in firefox (Ubuntu):
status: Invalid → Confirmed
Thomas Hotz (thotz) on 2012-11-06
Changed in xulrunner-1.9 (Ubuntu):
status: Confirmed → Invalid
no longer affects: firefox-3.0 (Ubuntu)
no longer affects: xulrunner-1.9 (Ubuntu)
wissotzky (wissotzky) wrote :

Hi there,
Just did a fresh install of 14.04 and the bug is still preset, although in less websites.
for instance, if you go to http://www.tapuz.co.il/ you can see the fonts are very hard to read there.

In order to fix that, you have to go to Firefox's Preferences-->Content tab--> click 'Advanced' in 'Fonts & Colors'--> Choose 'Hebrew'--> Change Serif to 'DejaVu Sans'.

This way there is no need to install silly proprietary ms fonts.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.