Ubuntu

firefox-3 doesn't provide a symlink libnspr4.so and libnss3.so

Reported by tonfa on 2008-05-08
18
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Undecided
Unassigned
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

ff2 used to provide some symlinks like libnspr4.so and libnss3.so. ff3 doesn't provide them anymore, but debian still does that:
$ dpkg -c /org/ftp.root/debian/pool/main/i/iceweasel/iceweasel_3.0~b5-3_i386.deb |grep nspr
-rw-r--r-- root/root 197904 2008-04-26 18:52 ./usr/lib/iceweasel/libnspr4.so

Not having them makes some java applet crash (I was unable to fill my tax report until I created the symlinks):
java.lang.UnsatisfiedLinkError: /home/tonfa/local/bin/.TaoUSign/libjsec.so: libnspr4.so: cannot open shared object file: No such file or directory
 at java.lang.ClassLoader$NativeLibrary.load(Native Method)
 at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
 at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1647)
 at java.lang.Runtime.load0(Runtime.java:769)
 at java.lang.System.load(System.java:968)
 at com.dictao.plfm.a.b(Unknown Source)
 at signview.b(Unknown Source)
 at signview.start(Unknown Source)
 at sun.applet.AppletPanel.run(AppletPanel.java:420)
 at java.lang.Thread.run(Thread.java:595)
$ ldd /home/tonfa/local/bin/.TaoUSign/libjsec.so
 linux-gate.so.1 => (0xb7f96000)
 libnspr4.so => not found
 libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7f64000)
 libnss3.so => not found
 libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7f5f000)
 libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7f3a000)
 libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7deb000)
 /lib/ld-linux.so.2 (0xb7f97000)

MickTaiwan (faivrem) wrote :

Same here:
java.lang.UnsatisfiedLinkError: /home/mick/.TaoUSign/libjsec.so: libnss3.so: cannot open shared object file: No such file or directory

... from a tax report problem too :)

tonfa (bboissin) on 2008-05-20
Changed in firefox:
status: New → Confirmed
John Vivirito (gnomefreak) wrote :

Please dont confirm Mozilla bugs without reading how we handle bugs, the link will follow my post. Is this a problem with latest Firefox-3.0 in repos? We dont use Debians package at all we build from Mozilla package so we have patcheds they dont and they have patches we dont.
Can you please list steps to reproduce this. What tax software are you using and is it the only time you see this?
What version of Firefox and ubuntu and java are you using Also please list all extensions and addons that you have installed.
Thanks

Changed in firefox:
status: Confirmed → Incomplete
tonfa (bboissin) wrote :

That was using 3.0~b5+nobinonly-0ubuntu3, using sun-java5-jre version 1.5.0-15-0ubuntu1 (java6 fails differently).
There's no addon involved, since I tried with a new firefox account.
That's for the http://impots.gouv.fr website (https://cfspart.impots.gouv.fr/tdir-06/accueil.html I don't know if this will work for you).

If you search the forums you'll find a lot of people having problems with the last part of the process. At the end you need to sign your "declaration", and most people under ubuntu end up seeing two blank rectangle with nothing to click.
I debugged it by launching the java console and it showed me the error I posted, that's because the website sends a .so (libjsec.so) and it can't find some libs.
Since firefox-2 provides the symlink, I see no reason why firefox-3 shouldn't. As a workaround, people can aptitude install libnspr4-dev and libnsss3-dev, which will provide those symlinks too (but globally in /usr/lib, not just for firefox).

And no I can't show you the steps to reproduce, unless you are a french taxpayer (I can't redo it too, since it worked for me).

And sadly, it should work ff2, but since java is broken with ff2+hardy there's no way it can easily work for people (I've seen people advising to add this symlinks by hand in /usr/lib).

On Thu, May 08, 2008 at 01:33:36AM -0000, tonfa wrote:
> Public bug reported:
>
> Binary package hint: firefox
>
> ff2 used to provide some symlinks like libnspr4.so and libnss3.so. ff3 doesn't provide them anymore, but debian still does that:
> $ dpkg -c /org/ftp.root/debian/pool/main/i/iceweasel/iceweasel_3.0~b5-3_i386.deb |grep nspr
> -rw-r--r-- root/root 197904 2008-04-26 18:52 ./usr/lib/iceweasel/libnspr4.so
>
> Not having them makes some java applet crash (I was unable to fill my tax report until I created the symlinks):
> java.lang.UnsatisfiedLinkError: /home/tonfa/local/bin/.TaoUSign/libjsec.so: libnspr4.so: cannot open shared object file: No such file or directory

Is this a debian built lib?

 status incomplete

 - Alexander

tonfa (bboissin) wrote :

There's nothing from debian. libjsec.so is downloaded by the java applet.
I do not work at the French IRS so I don't know how they built it.

I think (but I may be wrong) that their primary test target is Mandriva. But it works fine with an older version of ubuntu and with debian (you may
have to downgrade to java5 but it's a separate issue).

I still think that having the symlinks disappear in FF3 is a regression. Is there something wrong with that ?

Anyway the deadline for the declaration is close, so I think most people have either used a different OS or a livecd to workaround the issue.

On Mon, Jun 09, 2008 at 02:15:56PM -0000, tonfa wrote:
> There's nothing from debian. libjsec.so is downloaded by the java applet.
> I do not work at the French IRS so I don't know how they built it.
>
> I think (but I may be wrong) that their primary test target is Mandriva. But it works fine with an older version of ubuntu and with debian (you may
> have to downgrade to java5 but it's a separate issue).
>
> I still think that having the symlinks disappear in FF3 is a regression.
> Is there something wrong with that ?
>
> Anyway the deadline for the declaration is close, so I think most people
> have either used a different OS or a livecd to workaround the issue.
>

Could you please give us step by step instructions to reproduce your
exact case? (starting from a clean profile on a system without any
java installed). If I can reproduce I will look into fixing this.

 status confirmed

Thanks,

 - Alexander

Changed in firefox:
status: Incomplete → Confirmed
tonfa (bboissin) wrote :

Sadly, I don't think you can reproduce it, unless you work in France/are a french citizen.

You need to go to impots.gouv.fr, and have already created a ssl certificate to identify yourself.
Then go to https://cfspart.impots.gouv.fr/tdir-03/accueil.html
It will check the dependencies to the process (browser, OS, java vm).
For Hardy, it will warn because FF3 isn't in the list of supported browser (firefox-2 is), but you can still continue (that's just a warning).
Then you proceed filling up some forms, and at the end you have to sign your declaration.
Since there are no cross-plateform API to use the certificate stored in the browser, the developpers at impots.gouv.fr have
built a binary (probably a different one under each OS/browser) to access the certificate store and sign the declaration.
So the java applet download a .so for the signature(the libjsec.so), but sadly this dynamic library can't be used because of the linkerror.

As you can see from this search (sorry, in french) there's quite a lot of people who had some problem with this:
http://www.google.com/search?hl=fr&q=ubuntu+impots.gouv.fr+signature&btnG=Rechercher&lr=

Note: using firefox-2 isn't a suitable workaround, since the java installation is (was?) quite broken when I tried.

tonfa (bboissin) wrote :

This debian change is related:
http://lists.debian.org/debian-devel-changes/2008/06/msg00547.html

(it adds the symlink to the libnss3 package)

Jan Wrobel (wrobel-blues) wrote :

I can confirm this is a bug in Ubuntu.
Firefox 3.0 when downloaded from Mozilla site is still shipped with libnspr4.so,
libplds4.so and libplc4.so. These libs are available at least since Firefox v. 1.5 so I think a lot of
developers can depend on them.

I'm developer of Firekeeper extension which depends on these libraries.
To reproduce this bug install the newest Firekeeper:
http://downloads.mozdev.org/firekeeper/firekeeper-0.3.1-linux.xpi
after Firefox restart you will see red '!' in lower right corner that indicates failed installation.
Remove Firekeeper and create missing symbolic links:
ln -s /usr/lib/libnspr4.so.0d /usr/lib/libnspr4.so;
ln -s /usr/lib/libplds4.so.0d /usr/lib/libplds4.so;
ln -s /usr/lib/libplc4.so.0d /usr/lib/libplc4.so;
Install Firekeeper again. It should work fine.
I don't know what was the reason for removing these links. Is seems other developers
have also problem with this issue:
http://groups.google.co.uk/group/gears-eng/browse_thread/thread/e8942a7c15f2bc72/698059fe9397beb6?lnk=st&q=libnspr4.so+ubuntu#698059fe9397beb6

The workaround would be to link against libxul.so which on Ubuntu depends on /usr/lib/libplds4.so.0d,
/usr/lib/libplds4.so.0d, /usr/lib/libplc4.so.0d.
But it is not convenient solution, since libxul is not available in Firefox 2.0 so it would require to ship different versions of extension for FF2.0 and 3.0.
It would be much simpler if these libs are just available in Ubuntu under standard names.

Cheers,
Jan

Andrew Conkling (andrewski) wrote :

Alexander, this bug is also triggered by attempting to use Mozilla's Weave extension. See https://bugzilla.mozilla.org/show_bug.cgi?id=442788.

Also see related bug: https://bugs.launchpad.net/ubuntu/+source/nss/+bug/244439. Not sure how everything works together, but it seems like there are two separate but related bugs?

On Wed, Jul 2, 2008 at 08:10, Andrew Conkling <
<email address hidden> <andrew.conkling%<email address hidden>>>
wrote:

> Alexander, this bug is also triggered by attempting to use Mozilla's
> Weave extension. See
> https://bugzilla.mozilla.org/show_bug.cgi?id=442788.
>
> Also see related bug:
> https://bugs.launchpad.net/ubuntu/+source/nss/+bug/244439. Not sure how
> everything works together, but it seems like there are two separate but
> related bugs?

I'm sorry, Alexander, I see now that you were already quite aware of that
other bug, and the upstream one. Apologies. ^_^

*** This is an automated response ***

Thank you for your bugreport. Since this seems to be an issue with
version 3 of the firefox browser, I'm reassigning the package. If you
feel this is an error, please don't hesitate to add a comment to your
report.

 affects ubuntu/firefox
 status invalid

 affects ubuntu/firefox-3.0
 status confirmed

Changed in firefox:
status: Confirmed → Invalid
Julian Alarcon (alarconj) wrote :

This bug is already fixed. In Intrepid and Jaunty there is no problem.

Changed in firefox-3.0 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.