firefox crashes when trying to launch after using profile manager

Bug #206561 reported by Ryura on 2008-03-25
6
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Unassigned

Bug Description

The program 'firefox-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 449 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

version 2.0.0.13

Occurs only when opening from terminal, firefox -ProfileManager

Ryura (yoyoboy) on 2008-03-25
description: updated
Alexander Sack (asac) wrote :

can you reproduce? please ensure that all running firefox instances have been stopped? Maybe restart your X session adn try again.

please attach the strace.log produced by:

 strace -e open -f firefox -ProfileManager &> /tmp/strace.log

Thanks,
 - Alexander

Changed in firefox:
status: New → Incomplete
Ryura (yoyoboy) wrote :

Restarted computer and made sure firefox wasn't running, restarted X, etc. Still happens.

Intriguingly, when doing the strace.log, it opened correctly. Attached the log.

Alexander Sack (asac) wrote :

but you can reproduce if running without strace? strange.

Does downgrading firefox to the current version in gutsy help?

Alexander Sack (asac) wrote :

... and please try to get an strace of a run that crashes this way. if its due to a race you might be able to see it when trying multiple times.

Ryura (yoyoboy) wrote :

Tried the strace again and it crashed "properly" this time. Attached.

Downgrading to the current gutsy version appears to have worked.

Ryura (yoyoboy) wrote :

Or perhaps not. Just reproduced it using the current gutsy one.

Attached another strace log for this one.

Alexander Sack (asac) wrote :

ok, not a regression then. please search the firefox bugs in launchpad ... i think there is a similar bug already (with maybe a workaround).

Changed in firefox:
importance: Undecided → Medium
status: Incomplete → Confirmed
Alexander Sack (asac) wrote :

actually i think that this is due to some extensions. try to disable them one by one in the tools -> addons dialog with restarts in between (trying to reproduce this bug) until you either have no extension enabled anymore or the crash disappeared - please let us know which extension caused this.

Ryura (yoyoboy) wrote :

Yep - disabling Google Gears fixed the problem (tried about 10 times, then enabled GG and got the error again).

Ryura (yoyoboy) wrote :

An update to Google Gears today fixed the issue, it seems.

Changed in firefox:
status: Confirmed → Fix Released

I also have this issue and do not use google gears. I haven't had the
chance to investigate the problem yet though.

On 3/30/08, Ryura <email address hidden> wrote:
> An update to Google Gears today fixed the issue, it seems.
>
> ** Changed in: firefox (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> firefox crashes when trying to launch after using profile manager
> https://bugs.launchpad.net/bugs/206561
> You received this bug notification because you are a direct subscriber
> of the bug.
>

On Mon, Mar 31, 2008 at 04:38:49PM -0000, Andrew wrote:
> I also have this issue and do not use google gears. I haven't had the
> chance to investigate the problem yet though.

Check by disabling extensions one by one in tools -> addons.

 - Alexander

Alexander Sack (asac) wrote :

On Tue, Apr 29, 2008 at 02:01:45PM -0000, Alexander Sack wrote:
> On Mon, Mar 31, 2008 at 04:38:49PM -0000, Andrew wrote:
> > I also have this issue and do not use google gears. I haven't had the
> > chance to investigate the problem yet though.
>
> Check by disabling extensions one by one in tools -> addons.

No reply,

 affects ubuntu/firefox
 status invalid

 - Alexander

Alexander Sack (asac) on 2008-05-09
Changed in firefox:
status: Fix Released → Invalid
Merike Sell (merikes) wrote :

I have disabled all addons with firefox-2 on Hardy.
I still get:

The program 'firefox-2-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 3193 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Included log for: strace -e open -f firefox-2 -ProfileManager &> /tmp/strace.log

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers