FF exception: firefox source will be revived to produce firefox-2 binaries in universe

Bug #193319 reported by Alexander Sack on 2008-02-19
4
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

Firefox 2 won't be officially supported in hardy anymore. However, there are several use-cases where it still makes sense to have the old firefox available (like some extensions don't exist anymore). Thus, I want to serve this need and provide firefox-2 binaries in universe.

I don't think this is really a feature that needs approval, as the same package version (2.0.0.12) previously was shipped in main. Anyway, an ack from motu-release would make me feel better as there will be binary NEW packages.

StefanPotyra (sistpoty) wrote :

If you want, ACK from me, but imho that's not really exception worthy... (I assume you deal with adjusting rdepends correctly, right?)

Scott Kitterman (kitterman) wrote :

I would give this idea a strong NACK. Main pushed to FF3 at least in part because FF2 was not suportable for an LTS release. This is even more true in Universe than in Main. Firefox takes a lot of security work to keep current and due to the Mozilla corp trademark policy a lot of upstream coordination. I don't think we are prepared to take this on in Universe unless Canonical will commit to providing security support (in which case it may as well stay in Main).

StefanPotyra (sistpoty) wrote :

hm... that's indeed a pretty good point.

Alexander Sack (asac) wrote :

there are other gecko providers (namely xulrunner 1.8) in universe that don't have a security support commitment. What do you plan to do about those?

That said, IMO, security for universe is a completely different beast and shouldn't interfere with this Feature Freeze exception.

Scott Kitterman (kitterman) wrote :

Ack from me contingent on the plan discussed on IRC that mozillateam will support this package for security fixes while feasible and then at some point make the package an upgrade to FF3 so that motu-swat does not get an extra security burden.

StefanPotyra (sistpoty) wrote :

*nod*, confirming. (sorry for the delay).

Changed in firefox:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 2.0.0.12+2nobinonly+2-0ubuntu3

---------------
firefox (2.0.0.12+2nobinonly+2-0ubuntu3) hardy; urgency=low

  * FF Exception upload: LP: #193319
  * make firefox 2 2nd class citizen, by renaming binary packages
    from firefox* to firefox-2*
  * fix update-desktop database invocation to use proper path
    (/usr/bin/update-desktop-database)
    - update debian/firefox-2.postinst
  * fix .desktop icon to refer to firefox.png again
    - update debian/firefox-2.desktop
  * elminate superfluous firefox-2 -> firefox links
    - update debian/firefox-2-dev.links
    - update debian/firefox-2.links
  * provide compatibility links for several .pc files: firefox-gtkmozembed.pc,
    firefox-js.pc, firefox-plugin.pc, firefox-xpcom.pc
    - update debian/firefox-2-dev.links

 -- Alexander Sack <email address hidden> Mon, 25 Feb 2008 10:57:06 +0100

Changed in firefox:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers