[apparmor] Unable to show Downloads with apparmor enabled

Bug #1931603 reported by Dariusz Gadomski
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Fix Released
Medium
Dariusz Gadomski
Focal
Fix Released
Medium
Dariusz Gadomski
Hirsute
Won't Fix
Undecided
Unassigned
Impish
Fix Released
Medium
Dariusz Gadomski

Bug Description

[Impact]

 * After a finished download (or opening the downloads list) it is impossible to "Open Containing Folder" for a downloaded file - pressing the button does nothing visible.

[Test Plan]

 * sudo aa-enforce /etc/apparmor.d/usr.bin.firefox

 * launch Firefox

 * Download a file.

 * Go to downloads list.

 * Press the "Open Containing Folder" button next to the downloaded file on the list.

[Where problems could occur]

Unlocking the possibility of launching file browser from Firefox, that was not working before may result in windows popping up where they have not earlier (e.g. from the Downloads window, downloads list).

[Other Info]

Tags: sts
Changed in firefox (Ubuntu):
importance: Undecided → Medium
tags: added: sts
Revision history for this message
Iain Lane (laney) wrote :

(Just assigning to clean the report)

Changed in firefox (Ubuntu):
assignee: nobody → Dariusz Gadomski (dgadomski)
Changed in firefox (Ubuntu Focal):
assignee: nobody → Dariusz Gadomski (dgadomski)
Changed in firefox (Ubuntu Hirsute):
status: New → Won't Fix
Changed in firefox (Ubuntu Impish):
assignee: nobody → Dariusz Gadomski (dgadomski)
description: updated
Revision history for this message
Dariusz Gadomski (dgadomski) wrote :

Attaching impish fix proposal.

Changed in firefox (Ubuntu):
importance: Medium → Low
importance: Low → Medium
Changed in firefox (Ubuntu Focal):
importance: Undecided → Medium
Changed in firefox (Ubuntu Impish):
importance: Undecided → Medium
Changed in firefox (Ubuntu):
status: New → Invalid
Revision history for this message
Dariusz Gadomski (dgadomski) wrote :

Fix proposal for focal.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu Focal):
status: New → Confirmed
Changed in firefox (Ubuntu Impish):
status: New → Confirmed
Changed in firefox (Ubuntu):
status: Invalid → In Progress
Revision history for this message
Sebastien Bacher (seb128) wrote :

I'm closing for the current serie since we aren't providing a firefox deb anymore

Changed in firefox (Ubuntu):
status: In Progress → Invalid
description: updated
Revision history for this message
Olivier Tilloy (osomon) wrote :

Fix committed:

  https://bazaar.launchpad.net/~mozillateam/firefox/firefox.focal/revision/1552

  https://bazaar.launchpad.net/~mozillateam/firefox/firefox.impish/revision/1585

The update will make its way to the security and updates pockets with the next stable update of firefox.

Changed in firefox (Ubuntu Focal):
status: Confirmed → Fix Committed
Changed in firefox (Ubuntu Impish):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 100.0.2+build1-0ubuntu0.18.04.1

---------------
firefox (100.0.2+build1-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release (100.0.2+build1)

  [ Dariusz Gadomski ]
  * Enable launching external file browser with AppArmor enabled (LP: #1931603)

 -- Olivier Tilloy <email address hidden> Fri, 20 May 2022 07:20:46 +0200

Changed in firefox (Ubuntu):
status: Invalid → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 100.0.2+build1-0ubuntu0.20.04.1

---------------
firefox (100.0.2+build1-0ubuntu0.20.04.1) focal; urgency=medium

  * New upstream release (100.0.2+build1)

  [ Dariusz Gadomski ]
  * Enable launching external file browser with AppArmor enabled (LP: #1931603)

 -- Olivier Tilloy <email address hidden> Fri, 20 May 2022 08:14:35 +0200

Changed in firefox (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 100.0.2+build1-0ubuntu0.21.10.1

---------------
firefox (100.0.2+build1-0ubuntu0.21.10.1) impish; urgency=medium

  * New upstream release (100.0.2+build1)

  [ Dariusz Gadomski ]
  * Enable launching external file browser with AppArmor enabled (LP: #1931603)

 -- Olivier Tilloy <email address hidden> Fri, 20 May 2022 08:15:03 +0200

Changed in firefox (Ubuntu Impish):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers