Ubuntu

Firefox 3 misses .desktop translations, should be copied from Firefox 2 debian/ directory

Reported by Timo Jyrinki on 2008-02-16
6
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Fabien Tassin

Bug Description

Binary package hint: firefox

The menu item says "Firefox 3 Web Browser", even though it should be translated. The item is translated when using Firefox 2 packages, eg. in gutsy and in hardy before the update to FF3.

Probably also the English menu item should be renamed to just "Firefox Web Browser", as version numbers are not part of the program name.

Related branches

Alexander Sack (asac) on 2008-03-14
Changed in firefox:
importance: Undecided → High
milestone: none → ubuntu-8.04
status: New → Confirmed

Added patch for make a .desktop file for firefox 3 with all translations of the Firefox 2

Changed in firefox:
assignee: nobody → festor90
status: Confirmed → Fix Committed

Translated firefox desktop file

Timo Jyrinki (timo-jyrinki) wrote :

The patch is fine. However, putting this back to "Confirmed" since the fix is not really committed in any source tree yet, as far as I know.

Changed in firefox:
status: Fix Committed → Confirmed
James Westby (james-w) wrote :

Hi,

I'm unassigning you from the bug so that it is clear it needs
someone else to pick it up and push it in to the archive.

Thanks,

James

Changed in firefox:
assignee: festor90 → nobody
Colin Watson (cjwatson) on 2008-04-02
Changed in firefox:
assignee: nobody → asac
Alexander Sack (asac) wrote :

fta, didn't we commit this to bzr head already? is this a dupe?

Changed in firefox:
assignee: asac → fta
Fabien Tassin (fta) wrote :

I've fixed that a while ago as part of bug #195013, which occurs to be half duplicate of this bug. This will land with beta 5.
Updating the branch to close this bug instead.
I'm not marking #195013 duplicate as the locales part is not closed.

Changed in firefox:
status: Confirmed → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

The fix for .desktop file was released so marking as such.

Changed in firefox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers