No sound with adobe flashplayer 9 in Mozilla

Bug #186726 reported by ephie on 2008-01-28
12
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

There is an error when the flashplayer installes from apt deposetories..... so I installed the package directly from the adobe web site.... The video works fine but I can't get the sound working...

I installed Ubuntu 7.10 32 bits on an amd64 bits computer if that can help...

ProblemType: Bug
Architecture: i386
Date: Mon Jan 28 19:42:53 2008
DistroRelease: Ubuntu 7.10
NonfreeKernelModules: nvidia
Package: firefox 2.0.0.11+2nobinonly-0ubuntu0.7.10
PackageArchitecture: i386
SourcePackage: firefox
Uname: Linux ephie-desktop 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux

ephie (fat-guy) wrote :
era (era) wrote :

I think I have the same problem. I am on amd64 proper and I installed flashplugin-nonfree 9.0.48.0.2+really0ubuntu12.2 (from proposed-updates, I guess?)

I get an insane amount of these error messages, and no sound:

ALSA lib ../../../src/pcm/pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
ALSA lib ../../../src/pcm/pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
ALSA lib ../../../src/pcm/pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
ALSA lib ../../../src/pcm/pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave

Based on http://ubuntuforums.org/showthread.php?p=4289792 I am speculating that the source of the problem is in Firefox, not in Adobe's Flash player, though I'm prepared to stand corrected on that.

I also have Nvidia drivers, in case that it significant. I thought I saw mention of those in the Forum posts too.

era (era) wrote :

Upon closer examination, this might well be a duplicate of bug 151849

I have PulseAudio (because upgrading from Feisty to Gutsy was problematic; some new packages -- I guess in Universe -- had a conflict with esound); I imagine the original reporter would be on esound probably?

On Mon, Feb 25, 2008 at 08:29:41AM -0000, era wrote:
> I think I have the same problem. I am on amd64 proper and I installed
> flashplugin-nonfree 9.0.48.0.2+really0ubuntu12.2 (from proposed-updates,
> I guess?)

this is not a firefox issue,

 affects ubuntu/firefox
 status invalid

but a problem in the flashplugin-nonfree package:

 affects ubuntu/flashplugin-nonfree
 status confirmed

Thanks,

 - Alexander

Changed in firefox:
status: New → Invalid

do you have the package libflashsupport?

Dara Adib (daradib) on 2008-04-05
Changed in flashplugin-nonfree:
status: Confirmed → Incomplete
era (era) wrote :

I do, now; installing it by hand seemed to solve the problem for me. (See also bug #151849.) If it is required for sound, it should be a required dependency.

(I'm not the original reporter; feel free to set back to Incomplete if you like.)

Changed in flashplugin-nonfree:
status: Incomplete → New

but it is a dependency of flashplugin-nonfree. (check it yourself)

however, there is a problem for people who installed flash player a kludgy way (in an older install) and now have the plugin for flash in ~/.mozilla/plugins, so have flash without the actual package flashplugin-nonfree installed. for these people libflashsupprt wont be installed, and they could be left with problems.

era, was this what happened to you too? can you confirm this is a problem in this set up?
maybe firefox should depend on libflashsupport, just in case
or maybe old flash plugins should be deleted, from ~/.mozilla/plugins, which would then prompt the user to reinstall flash on first visit to flash site, where install would be done through apt, and then be safe from this problem in the future.

this is a bug, but only for non standard people (perhaps people who have used automatix or something similar previously?)

euromos (bogy96) wrote :

FIXED Thx

gr Harrie
----------------------------------------
> From: <email address hidden>
> To: <email address hidden>
> Date: Sun, 6 Apr 2008 12:58:05 +0000
> Subject: [Bug 186726] Re: No sound with adobe flashplayer 9 in Mozilla
>
> but it is a dependency of flashplugin-nonfree. (check it yourself)
>
> however, there is a problem for people who installed flash player a
> kludgy way (in an older install) and now have the plugin for flash in
> ~/.mozilla/plugins, so have flash without the actual package
> flashplugin-nonfree installed. for these people libflashsupprt wont be
> installed, and they could be left with problems.
>
> era, was this what happened to you too? can you confirm this is a problem in this set up?
> maybe firefox should depend on libflashsupport, just in case
> or maybe old flash plugins should be deleted, from ~/.mozilla/plugins, which would then prompt the user to reinstall flash on first visit to flash site, where install would be done through apt, and then be safe from this problem in the future.
>
> this is a bug, but only for non standard people (perhaps people who have
> used automatix or something similar previously?)
>
> --
> No sound with adobe flashplayer 9 in Mozilla
> https://bugs.launchpad.net/bugs/186726
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "firefox" in Ubuntu: Invalid
> Status in Source Package "flashplugin-nonfree" in Ubuntu: New
>
> Bug description:
> Binary package hint: firefox
>
> There is an error when the flashplayer installes from apt deposetories..... so I installed the package directly from the adobe web site.... The video works fine but I can't get the sound working...
>
> I installed Ubuntu 7.10 32 bits on an amd64 bits computer if that can help...
>
> ProblemType: Bug
> Architecture: i386
> Date: Mon Jan 28 19:42:53 2008
> DistroRelease: Ubuntu 7.10
> NonfreeKernelModules: nvidia
> Package: firefox 2.0.0.11+2nobinonly-0ubuntu0.7.10
> PackageArchitecture: i386
> SourcePackage: firefox
> Uname: Linux ephie-desktop 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux

_________________________________________________________________
Jouw nieuws en entertainment, vind je op MSN.nl!
http://nl.msn.com/

era (era) wrote :

I have installed only the standard flashplugin-nonfree, and only after 12.1 was out (because I became aware of the problem, and didn't particularly need or want Flash until sometime in late February, apparently) and at that point, it did not have sound out of the box.

The system has been through some earlier installations so it is not completely impossible that I had something in my .mozilla/plugins folder, but I don't think I ever installed Flash directly from Adobe (it wouldn't have worked anyway; it's an amd64 box).

This is a Gutsy system, where libflashsupport is not among the dependencies. (I write this on an i386 system, so the architecture is wrong, but the same dependencies should work, still; right?) If this is fixed in Hardy, then great.

gutsy$ apt-cache show flashplugin-nonfree | fgrep libflash

gutsy$ echo $?
1

John Vivirito (gnomefreak) wrote :

For 64 bit it needs ndispluginwrapper to run flash and make it "work" where as 32 bit doesnt so maybe a missing depend or something in that package, Will add the package to list and assign Mozilla-Team to the bug.

Changed in flashplugin-nonfree:
status: New → Incomplete
John Vivirito (gnomefreak) wrote :

After more thought please give me a few days to think on this one.
Does the new version of flash fix this issue
Josh per your post. https://bugs.edge.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/186726/comments/7
It shouldnt matter when it was installed if the depends changed it would install the needed depends during an update to flash.

the thing is that (according to the original poster) flash is installed without flashpluin-nonfree being installed. apt was never involved. the original poster did it directly from adobe website, so there should be no thought about dependencies.
the original poster is also NOT using 64bit.

i now realise era has a completely seperate problem to do with pulseaudio (its reasonable to not have libflashsupport as a dependeny as pulseaudio isnt default, and this is a dependecy in hardy), which should be ignored. perhaps the original poster ephie also has pulseaudio too though, but no details are given.

there is going to be a problem for people like ephie, who installed flash directly from adobe website, who upon upgrading to hardy are not going to get the new dependencies (ie libflashsupport, so sound wont work). THis is what I was referring to, but this is probably outside of the scope of this bug,

this bug should be forgotten about, unless ephie wants to reopen it

euromos (bogy96) wrote :

hello Duncan

The problem is fixd , thx for ur help

YS Harrie
----------------------------------------
> From: <email address hidden>
> To: <email address hidden>
> Date: Mon, 7 Apr 2008 17:33:50 +0000
> Subject: [Bug 186726] Re: No sound with adobe flashplayer 9 in Mozilla
>
> the thing is that (according to the original poster) flash is installed without flashpluin-nonfree being installed. apt was never involved. the original poster did it directly from adobe website, so there should be no thought about dependencies.
> the original poster is also NOT using 64bit.
>
> i now realise era has a completely seperate problem to do with
> pulseaudio (its reasonable to not have libflashsupport as a dependeny as
> pulseaudio isnt default, and this is a dependecy in hardy), which should
> be ignored. perhaps the original poster ephie also has pulseaudio too
> though, but no details are given.
>
> there is going to be a problem for people like ephie, who installed
> flash directly from adobe website, who upon upgrading to hardy are not
> going to get the new dependencies (ie libflashsupport, so sound wont
> work). THis is what I was referring to, but this is probably outside of
> the scope of this bug,
>
> this bug should be forgotten about, unless ephie wants to reopen it
>
> --
> No sound with adobe flashplayer 9 in Mozilla
> https://bugs.launchpad.net/bugs/186726
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "firefox" in Ubuntu: Invalid
> Status in Source Package "flashplugin-nonfree" in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: firefox
>
> There is an error when the flashplayer installes from apt deposetories..... so I installed the package directly from the adobe web site.... The video works fine but I can't get the sound working...
>
> I installed Ubuntu 7.10 32 bits on an amd64 bits computer if that can help...
>
> ProblemType: Bug
> Architecture: i386
> Date: Mon Jan 28 19:42:53 2008
> DistroRelease: Ubuntu 7.10
> NonfreeKernelModules: nvidia
> Package: firefox 2.0.0.11+2nobinonly-0ubuntu0.7.10
> PackageArchitecture: i386
> SourcePackage: firefox
> Uname: Linux ephie-desktop 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux

_________________________________________________________________
Probeer Live Search: de zoekmachine van de makers van MSN!
http://www.live.com/?searchOnly=true

euromos (bogy96) wrote :

----------------------------------------
> From: <email address hidden>
> To: <email address hidden>
> Date: Mon, 7 Apr 2008 16:05:36 +0000
> Subject: [Bug 186726] Re: No sound with adobe flashplayer 9 in Mozilla
>
> After more thought please give me a few days to think on this one.
> Does the new version of flash fix this issue
> Josh per your post. https://bugs.edge.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/186726/comments/7
> It shouldnt matter when it was installed if the depends changed it would install the needed depends during an update to flash.
>
> --
> No sound with adobe flashplayer 9 in Mozilla
> https://bugs.launchpad.net/bugs/186726
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "firefox" in Ubuntu: Invalid
> Status in Source Package "flashplugin-nonfree" in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: firefox
>
> There is an error when the flashplayer installes from apt deposetories..... so I installed the package directly from the adobe web site.... The video works fine but I can't get the sound working...
>
> I installed Ubuntu 7.10 32 bits on an amd64 bits computer if that can help...
>
> ProblemType: Bug
> Architecture: i386
> Date: Mon Jan 28 19:42:53 2008
> DistroRelease: Ubuntu 7.10
> NonfreeKernelModules: nvidia
> Package: firefox 2.0.0.11+2nobinonly-0ubuntu0.7.10
> PackageArchitecture: i386
> SourcePackage: firefox
> Uname: Linux ephie-desktop 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux

The problem is fixd , thx for ur help

YS Harrie
---------------
_________________________________________________________________
Probeer Live Search: de zoekmachine van de makers van MSN!
http://www.live.com/?searchOnly=true

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flashplugin-nonfree - 10.0.1.218ubuntu1

---------------
flashplugin-nonfree (10.0.1.218ubuntu1) intrepid; urgency=low

  * New upstream beta fixes many crashers (most significantly
    LP: #192888).
  * debian/config:
    debian/postinst: Update md5sums, filenames, and paths. Remove
    debugging bits (LP: #176226).
  * debian/control: Readd versioned dependency for libflashsupport|
    libasound2-plugins to play nicely with either PulseAudio config
    while preserving OSSv4 users' ability to have audible "shiny"
    (LP: #206307, #186726, #183943, #151849).

 -- Daniel T Chen <email address hidden> Tue, 20 May 2008 16:34:40 -0400

Changed in flashplugin-nonfree:
status: Incomplete → Fix Released
TM (junkmail-media) wrote :

I installed the debug version of the flash player (version 9.0.151.0) as per the Adobe instructions and it seems to work fine except for the sound problem already mentioned above. Is there a fix for a manual install of the flash player? Better yet, Is there a Ubuntu package that installs the debug version of the flash player? I tried snagging the libflashsupport.so that flashplugin-nonfree-extrasound installs and placing it in my ~/.mozilla/plugins directory alongside my debug player, but that didn't seem to work. Any ideas would be greatly appreciated -- I use Ubuntu at work for flash development, a crucial part of which is sound. I've confirmed that the non-debug player works as advertised when installed via aptitude, but I need to debug as well as hear sound. I'm using Ubuntu 8.10 on a MacBook Pro 15" Santa Rosa.

TM (junkmail-media) wrote :

As a follow up to my previous post, I just tried installing alsa-oss and running aoss firefox instead of just firefox, but there was no difference in the behavior of the debug flash player.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers