Firefox don't start

Bug #1845422 reported by VinsS on 2019-09-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

when I start Firefox nothing append.
If I restart it, a message appears with says "Firefox is already running but not responding. Close the first session if you want open a new one".

This problem concern the latest update (this morning) of firefox.

I've also tried in a terminal with the option -g without any reaction.

----------------------------------------------------------------
vincent@djoliba:~$ apt show firefox
Package: firefox
Version: 69.0.1+build1-0ubuntu0.18.04.1
Priority: optional
Section: web
Origin: Ubuntu
Maintainer: Ubuntu Mozilla Team <email address hidden>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 189 MB
Provides: gnome-www-browser, iceweasel, www-browser
Depends: lsb-release, libatk1.0-0 (>= 1.12.4), libc6 (>= 2.27), libcairo-gobject2 (>= 1.10.0), libcairo2 (>= 1.10.0), libdbus-1-3 (>= 1.9.14), libdbus-glib-1-2 (>= 0.78), libfontconfig1 (>= 2.12), libfreetype6 (>= 2.3.5), libgcc1 (>= 1:4.2), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.31.8), libgtk-3-0 (>= 3.4), libpango-1.0-0 (>= 1.22.0), libpangocairo-1.0-0 (>= 1.14.0), libstartup-notification0 (>= 0.8), libstdc++6 (>= 6), libx11-6, libx11-xcb1, libxcb-shm0, libxcb1, libxcomposite1 (>= 1:0.3-1), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxrender1, libxt6
Recommends: xul-ext-ubufox, libcanberra0, libdbusmenu-glib4, libdbusmenu-gtk3-4
Suggests: fonts-lyx
Replaces: kubuntu-firefox-installer
Task: ubuntu-desktop, kubuntu-desktop, kubuntu-full, xubuntu-desktop, lubuntu-gtk-desktop, lubuntu-desktop, ubuntustudio-desktop, ubuntukylin-desktop, ubuntu-mate-core, ubuntu-mate-desktop
Xul-Appid: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
Supported: 5y
Download-Size: 50,3 MB
APT-Manual-Installed: yes
APT-Sources: http://be.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
Description: Le Navigateur Internet simple et sûr de Mozilla ......
-----------------------------------------------------------------

VinsS (vincent-vandevyvre) wrote :

After creating a new profile with firefox -P, now I can launch firefox with this new profile.

Of course without my markups and extensions.

Olivier Tilloy (osomon) wrote :

Thanks for the report VinsS.

Can you reliably reproduce the problem, across reboots ?

Does it start if you run it in safe mode (`firefox -safe-mode`) ?

Changed in firefox (Ubuntu):
status: New → Incomplete
VinsS (vincent-vandevyvre) wrote :

Hi, as I say, I've solved the problem with a new profile.

But if I retry firefox -P and choose the profile default I've immediately the message "Firefox is already running but don't respond".

VinsS (vincent-vandevyvre) wrote :

I've tested with my old profile and the safe-mode, same problem.

Olivier Tilloy (osomon) wrote :

Vincent, do you know which version was installed prior to 69.0.1+build1-0ubuntu0.18.04.1 ? Can you attach /var/log/apt/history.log ?

VinsS (vincent-vandevyvre) wrote :

Attached.

Olivier Tilloy (osomon) wrote :

Unfortunately this file doesn't contain the info I'm after, could you please also attach /var/log/apt/history.log.1.gz ? Thanks!

VinsS (vincent-vandevyvre) wrote :
Olivier Tilloy (osomon) wrote :

The log file says firefox was updated from 68.0.2+build1-0ubuntu0.18.04.1 to 69.0+build2-0ubuntu0.18.04.1 on the 5th of September, then from 69.0+build2-0ubuntu0.18.04.1 to 69.0.1+build1-0ubuntu0.18.04.1 on the 26th of September. Can you confirm that the latter is the update that broke things for you?

VinsS (vincent-vandevyvre) wrote :

Yes this is the update of 26th of September the origin of the problem.

Olivier Tilloy (osomon) wrote :

Thanks for the confirmation.
The problem hasn't been reported by anyone else AFAIK, so it looks like an isolated profile corruption. At this stage I'm not sure what to suggest, other than importing your bookmarks and extensions from the old broken profile to the new one (I understand it's not a satisfactory solution, merely a workaround).

Changed in firefox (Ubuntu):
status: Incomplete → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers