Cannot submit crash reports from firefox' "this tab crashed" page

Bug #1845205 reported by Gabriele Svelto on 2019-09-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Olivier Tilloy

Bug Description

Steps to reproduce:

- Launch firefox
- Enter "about:crashcontent" in the URL bar
- Upon hitting return, the tab should crash and display the "This tab just crashed" page
- Ensure that the checkmark to send the crash report is ticked
- Add a comment (anything will do, a non-empty comment ensures that the crash is accepted by Mozilla crash reporting back-end)
- Click on "Restore this tab"
- Go to the "about:crashes" page

Expected behaviour:

In the "about:crashes" page the crash is displayed among the submitted crash reports, showing that the crash report was indeed submitted correctly.

Actual behaviour:

The crash appears among the unsubmitted crashes.

This bug is specific to the packaged version of Firefox that comes with Ubuntu. I've tried reproducing using Mozilla's builds and crash submission works correctly there. See this bug https://bugzilla.mozilla.org/show_bug.cgi?id=1583247 on Mozilla's tracker regarding this behaviour. In Mozilla we noticed the issue because we've started properly processing crash reports coming from Ubuntu and tab crashes were strangely few. Feel free to contact me directly at <email address hidden> about this issue since I'm in charge of Firefox crash reporting machinery.

Olivier Tilloy (osomon) wrote :

Thanks for the report Gabriele. I can confirm that the steps in the description lead to an unreported crash. If however I click the "Send" button in about:crashes afterwards, the crash report is correctly sent and processed. Is that what you're seeing too?

Changed in firefox (Ubuntu):
status: New → Confirmed
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → Medium
Gabriele Svelto (gsvelto) wrote :

Yes, manual submission via about:crashes works fine. It's just the tab crash reporter that doesn't show up as it should.

Olivier Tilloy (osomon) wrote :

It appears crashes are not submitted because the minidump-analyzer executable is missing.

Olivier Tilloy (osomon) on 2019-10-08
Changed in firefox (Ubuntu):
status: Confirmed → In Progress
Gabriele Svelto (gsvelto) wrote :

Interesting, that shouldn't happen. The minidump-analyzer executable greatly improves our crash telemetry but it's not strictly needed for crash reporting. I'll file a bug on our side to fix that issue.

Olivier Tilloy (osomon) wrote :

I built test packages that include the minidump-analyzer executable, and I can confirm that with those crash reports are now submitted as expected.

Gabriele, please share the link to that bug on your side here.

Changed in firefox (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 69.0.2+build1-0ubuntu2

---------------
firefox (69.0.2+build1-0ubuntu2) eoan; urgency=medium

  * Install the minidump-analyzer executable (LP: #1845205)
    - update debian/firefox.install.in

 -- Olivier Tilloy <email address hidden> Tue, 08 Oct 2019 14:51:08 +0200

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers