No more Amazon icon in Firefox For Ubuntu Canonical

Bug #1844051 reported by Cdag on 2019-09-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Olivier Tilloy

Bug Description

Hello,

since the update with version 69.0 from Firefox for Ubuntu, in the search bar, the Amazon icon doesn't appear. Instead of it, there is a grey magnifying glass.

I sent a report to Mozilla but they replied that the problem comes from Ubuntu, not Mozilla as their Firefox doesn't have any bug with it.

I inform you about this bug. I hope you will manage to fix it soon.

Best Regards.

CD

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: firefox 69.0+build2-0ubuntu0.19.04.1
ProcVersionSignature: Ubuntu 5.0.0-27.28-generic 5.0.21
Uname: Linux 5.0.0-27-generic x86_64
ApportVersion: 2.20.10-0ubuntu27.1
Architecture: amd64
BuildID: 20190831223935
CurrentDesktop: ubuntu:GNOME
Date: Sun Sep 15 13:51:31 2019
DefaultProfileExtensions: extensions.sqlite corrupt or missing
DefaultProfileIncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
DefaultProfileLocales: extensions.sqlite corrupt or missing
DefaultProfilePrefErrors: Unexpected character ',' before close parenthesis @ /usr/lib/firefox/omni.ja:greprefs.js:997
DefaultProfileThemes: extensions.sqlite corrupt or missing
InstallationDate: Installed on 2019-09-14 (1 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
Profiles:
 Profile1 (Default) - LastVersion=None/None (Out of date)
 Profile0 - LastVersion=69.0/20190831223935 (In use)
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)

Cdag (cdag81) wrote :
Olivier Tilloy (osomon) wrote :

This is caused by https://bugzilla.mozilla.org/show_bug.cgi?id=1570700#c10.

The resource:// URLs in the amazon OpenSearch descriptions we ship should be replaced by data: URIs, i.e.:

    resource://search-plugins/images/amazon.ico

replaced by

    data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAABmJLR0QA/wD/AP+gvaeTAAAACXBIWXMAAC4jAAAuIwF4pT92AAABaElEQVQ4y6VTPUvDUBQ9kWRSRHCqND9AcWicXJxCtjqopFtXOwod+g/chWQtThYXG8FV0E0pmUoFk8U6NMW6NKRdWuE4pIbmQyt64A7v4553zr3vCgBAkvgDBEEQhKxk13VRr9fx0u0CAPaLRZTL5WwWJmDbNkVJSkWtVmMWUgTHlQpFSaKqaXQcJ1rnZTmTIGWh3+/D8zz4vo8gCHDRaMCyLADAdDJZbMFxHBYUJdPGryzopRJFSWJBUeh5Hg3T/JFgKanoS66u68jlcmi329HZaDRabGFevqppMQuGaX5jYdyLtTEvy1HlDdOkXipR1TQGQUC652SrGkZEcLNJDp+5EHcHYeLTGXmJOYLebbjRqsbUpDDukd1m+NjVeuIfvFrA42FYmLU9QD6KF+vtHhhcA7tNQFoFhh1g6wTxj/RuA53T8GISy5vAjgFsqMDHrBviCjKHCb4DDB6AqT9TtB0mZk3kf8f5E5FB5xiRl94rAAAAAElFTkSuQmCC

Changed in firefox (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → Medium
status: New → Confirmed
Olivier Tilloy (osomon) on 2019-09-18
Changed in firefox (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 69.0.1+build1-0ubuntu2

---------------
firefox (69.0.1+build1-0ubuntu2) eoan; urgency=medium

  * Restore icons for the amazon search engine descriptions (LP: #1844051)
    - update debian/searchplugins/amazon*.xml

 -- Olivier Tilloy <email address hidden> Wed, 18 Sep 2019 17:32:56 +0200

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.