Screen tearing in Firefox on Wayland

Bug #1838965 reported by Artyom Pozharov
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Medium
firefox (Ubuntu)
Low
Unassigned

Bug Description

Details here: https://photos.app.goo.gl/9kA7R6KqNaSsn9CB8

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: firefox 68.0.1+build1-0ubuntu2
ProcVersionSignature: Ubuntu 5.2.0-8.9-generic 5.2.0
Uname: Linux 5.2.0-8-generic x86_64
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
BuildID: 20190719083815
CurrentDesktop: ubuntu:GNOME
Date: Mon Aug 5 13:36:32 2019
DefaultProfileExtensions: extensions.sqlite corrupt or missing
DefaultProfileIncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
DefaultProfileLocales: extensions.sqlite corrupt or missing
DefaultProfilePrefErrors: Unexpected character ',' before close parenthesis @ /usr/lib/firefox/omni.ja:greprefs.js:1141
DefaultProfileThemes: extensions.sqlite corrupt or missing
InstallationDate: Installed on 2019-08-04 (0 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Alpha amd64 (20190802)
Profiles:
 Profile1 (Default) - LastVersion=None/None (Out of date)
 Profile0 - LastVersion=68.0.1/20190719083815 (In use)
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Artyom Pozharov (artyom-pozharov) wrote :
Revision history for this message
Olivier Tilloy (osomon) wrote :

The tearing isn't obvious to my untrained eye, nor can I observe it locally when testing in VMs.
I tested both X11 and Wayland, by scrolling up and down a long wikipedia page.

Can you provide details about your graphics card and driver?

Can you test an upstream build (download and unpack https://www.mozilla.org/firefox/download/thanks/) and confirm whether it's similarly affected? If so, can you file an upstream bug at https://bugzilla.mozilla.org/enter_bug.cgi#h=dupes%7CFirefox and share the link to it here?

Thanks!

Changed in firefox (Ubuntu):
status: New → Incomplete
Revision history for this message
Artyom Pozharov (artyom-pozharov) wrote : Re: [Bug 1838965] Re: Screen tearing in Firefox on Wayland

I use Intel HD 500 video card and default free driver, that is included in
Ubuntu GNU/Linux

ср, 7 авг. 2019 г., 13:10 Olivier Tilloy <email address hidden>:

> The tearing isn't obvious to my untrained eye, nor can I observe it
> locally when testing in VMs.
> I tested both X11 and Wayland, by scrolling up and down a long wikipedia
> page.
>
> Can you provide details about your graphics card and driver?
>
> Can you test an upstream build (download and unpack
> https://www.mozilla.org/firefox/download/thanks/) and confirm whether
> it's similarly affected? If so, can you file an upstream bug at
> https://bugzilla.mozilla.org/enter_bug.cgi#h=dupes%7CFirefox and share
> the link to it here?
>
> Thanks!
>
> ** Changed in: firefox (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1838965
>
> Title:
> Screen tearing in Firefox on Wayland
>
> Status in firefox package in Ubuntu:
> Incomplete
>
> Bug description:
> Details here: https://photos.app.goo.gl/9kA7R6KqNaSsn9CB8
>
> ProblemType: Bug
> DistroRelease: Ubuntu 19.10
> Package: firefox 68.0.1+build1-0ubuntu2
> ProcVersionSignature: Ubuntu 5.2.0-8.9-generic 5.2.0
> Uname: Linux 5.2.0-8-generic x86_64
> ApportVersion: 2.20.11-0ubuntu7
> Architecture: amd64
> BuildID: 20190719083815
> CurrentDesktop: ubuntu:GNOME
> Date: Mon Aug 5 13:36:32 2019
> DefaultProfileExtensions: extensions.sqlite corrupt or missing
> DefaultProfileIncompatibleExtensions: Unavailable (corrupt or
> non-existant compatibility.ini or extensions.sqlite)
> DefaultProfileLocales: extensions.sqlite corrupt or missing
> DefaultProfilePrefErrors: Unexpected character ',' before close
> parenthesis @ /usr/lib/firefox/omni.ja:greprefs.js:1141
> DefaultProfileThemes: extensions.sqlite corrupt or missing
> InstallationDate: Installed on 2019-08-04 (0 days ago)
> InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Alpha amd64 (20190802)
> Profiles:
> Profile1 (Default) - LastVersion=None/None (Out of date)
> Profile0 - LastVersion=68.0.1/20190719083815 (In use)
> SourcePackage: firefox
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1838965/+subscriptions
>

Revision history for this message
In , Artyom Pozharov (artyom-pozharov) wrote :

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) snap Chromium/76.0.3809.87 Chrome/76.0.3809.87 Safari/537.36

Steps to reproduce:

Details here: https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1838965

Revision history for this message
In , Release-mgmt-account-bot (release-mgmt-account-bot) wrote :

[Bugbug](https://github.com/mozilla/bugbug/) thinks this bug should belong to this component, but please revert this change in case of error.

Changed in firefox:
importance: Unknown → Medium
status: Unknown → New
Revision history for this message
In , Stransky (stransky) wrote :

I think you mean slow scrolling here instead of video playback tearing, right?

Revision history for this message
In , Artyom Pozharov (artyom-pozharov) wrote : Re: [Bug 1838965]

I mean tearing appears with scrolling instead of video playback tearing

чт, 5 сент. 2019 г. в 02:50, Stransky <email address hidden>:

> I think you mean slow scrolling here instead of video playback tearing,
> right?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1838965
>
> Title:
> Screen tearing in Firefox on Wayland
>
> Status in Mozilla Firefox:
> New
> Status in firefox package in Ubuntu:
> Incomplete
>
> Bug description:
> Details here: https://photos.app.goo.gl/9kA7R6KqNaSsn9CB8
>
> ProblemType: Bug
> DistroRelease: Ubuntu 19.10
> Package: firefox 68.0.1+build1-0ubuntu2
> ProcVersionSignature: Ubuntu 5.2.0-8.9-generic 5.2.0
> Uname: Linux 5.2.0-8-generic x86_64
> ApportVersion: 2.20.11-0ubuntu7
> Architecture: amd64
> BuildID: 20190719083815
> CurrentDesktop: ubuntu:GNOME
> Date: Mon Aug 5 13:36:32 2019
> DefaultProfileExtensions: extensions.sqlite corrupt or missing
> DefaultProfileIncompatibleExtensions: Unavailable (corrupt or
> non-existant compatibility.ini or extensions.sqlite)
> DefaultProfileLocales: extensions.sqlite corrupt or missing
> DefaultProfilePrefErrors: Unexpected character ',' before close
> parenthesis @ /usr/lib/firefox/omni.ja:greprefs.js:1141
> DefaultProfileThemes: extensions.sqlite corrupt or missing
> InstallationDate: Installed on 2019-08-04 (0 days ago)
> InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Alpha amd64 (20190802)
> Profiles:
> Profile1 (Default) - LastVersion=None/None (Out of date)
> Profile0 - LastVersion=68.0.1/20190719083815 (In use)
> SourcePackage: firefox
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/firefox/+bug/1838965/+subscriptions
>

Changed in firefox (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Artyom Pozharov (artyom-pozharov) wrote :

If I enable layers.acceleration.force-enabled in the flags, tearing will disappear.

Revision history for this message
In , Artyom Pozharov (artyom-pozharov) wrote :

(In reply to Martin Stránský [:stransky] from comment #2)
> I think you mean slow scrolling here instead of video playback tearing, right?

I mean tearing during thr scrolling here instead of video playback tearing

Olivier Tilloy (osomon)
Changed in firefox (Ubuntu):
status: Confirmed → New
Revision history for this message
In , Stransky (stransky) wrote :

As Wayland is run or recent EGL stack / Gtk versions and compositors we should enable GL compositor by default at least for some subset of hardware - Intel and AMD gfx cards and gnome-shell compositor.

Gnome-shell itself uses EGL backend (composites to EGL textures) so GL is guaranteed to work there. It may also help with transition to WebRenderer.

KDE/Sway may be added later after some tests.

Revision history for this message
In , Stransky (stransky) wrote :

Created attachment 9099847
enable-gl-default-wayland.patch

Let's wait to 72 with it.

Revision history for this message
In , Stransky (stransky) wrote :

That's not point to enable GL compositor, better to go directly for WebRedner which works much better and does not suffer from Bug 1587788. Let's use this bug to track various Wayland/GL related bugs instead.

Revision history for this message
dev3java (dev3java) wrote :

I confirm what this person said.

Revision history for this message
In , Michel Dänzer (michel-daenzer) wrote :

Are you enabling the native Wayland backend via the environment variable `MOZ_ENABLE_WAYLAND=1` (or `GDK_BACKEND=wayland`)?

If not, this is probably an Xwayland issue, possibly fixed in the upstream xserver 1.20.7 release (or in the upcoming 1.20.8 release).

Revision history for this message
In , Aitor Pazos (aitorpazos) wrote :

I am seeing this as well in OpenSUSE Tumbleweed having `GDK_BACKEND=wayland` on a Lenovo Thinkpad X1 Yoga 3rd gen:
```
00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [8086:5914] (rev 08)
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07)
```
Software:
- kwin 5.19.2
- Mozilla Firefox 78.0.1

Revision history for this message
In , W-jan-k (w-jan-k) wrote :

(In reply to mail from comment #5)
If you open about:support, what does "Compositing" say?
It is normal that the Basic compositor (software rendering) shows tearing. Please open about:config, set gfx.webrender.all to true and restart Firefox to enable OpenGL rendering. WebRender is in the process of becoming enabled by default on Linux.

Revision history for this message
In , W-jan-k (w-jan-k) wrote :

*** This bug has been marked as a duplicate of bug 1587060 ***

Revision history for this message
In , W-jan-k (w-jan-k) wrote :

*** Bug 1572866 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Aitor Pazos (aitorpazos) wrote :

Looks much better now, thanks!!
`Compositing` was set to `Basic` indeed. Turning the OpenGL rendering solved the issues for me.

Changed in firefox:
status: New → Invalid
Revision history for this message
In , Aitor Pazos (aitorpazos) wrote :

One issue I noticed even with `GDK_BACKEND=wayland` and `gfx.webrender.all=true` set is that the "Master Password" entry modal dialog is not rendered properly. It is rendered blank.
Reported as a separate bug in https://bugzilla.mozilla.org/show_bug.cgi?id=1652310

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Changed in firefox (Ubuntu):
importance: Undecided → Low
Changed in firefox:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in firefox:
importance: Unknown → Medium
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.