firefox/thunderbird: please drop llvm-4.0 and switch to versionless alternative

Bug #1810772 reported by Gianfranco Costamagna on 2019-01-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Rico Tzschichholz
thunderbird (Ubuntu)
High
Olivier Tilloy

Bug Description

As said, we want to remove llvm-toolchain-4.0 from the archive, and firefox/thunderbird are the two last blockers.

Debian has already switched to the versionless alternative.

thanks

Olivier, can you please have a look?
firefox with the switch does build everywhere except armhf ppc64el s390x
while the current thunderbird in the archive is ftbfs even without changes.

Changed in thunderbird (Ubuntu):
importance: Undecided → High
Changed in firefox (Ubuntu):
importance: Undecided → High
Olivier Tilloy (osomon) on 2019-01-09
Changed in firefox (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) on 2019-01-09
Changed in firefox (Ubuntu):
status: New → Fix Committed
Olivier Tilloy (osomon) wrote :

Reverted the change as this was causing build failures on armhf, ppc64el and s390x (https://launchpad.net/ubuntu/+source/firefox/64.0.2+build1-0ubuntu1).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 64.0.2+build1-0ubuntu2

---------------
firefox (64.0.2+build1-0ubuntu2) disco; urgency=medium

  * Revert previous change back to versioned clang/llvm build dependencies,
    a micro release update is not the right place for such a change
    - update debian/control{,.in}

 -- Olivier Tilloy <email address hidden> Wed, 09 Jan 2019 17:12:09 +0100

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
Olivier Tilloy (osomon) on 2019-01-10
Changed in firefox (Ubuntu):
status: Fix Released → Confirmed
Olivier Tilloy (osomon) on 2019-01-15
Changed in thunderbird (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: New → Confirmed

Looks like 6.0 works for thunderbird, while firefox fails due to cbindgen failing to connect to github (not sure how/if this relates to llvm)

llvm 7 seems to make thunderbird fail, as well as llvm-8, but I think llvm-6 is a safe bet, since we are going to ship cosmic with it.

Olivier Tilloy (osomon) wrote :

The cbindgen build failing to connect to github is unrelated. It seems to be caused by the update to cargo 0.32. I'm looking into that.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 65.0+build2-0ubuntu0.18.10.1

---------------
firefox (65.0+build2-0ubuntu0.18.10.1) cosmic; urgency=medium

  * New upstream stable release (65.0build2)

  [ Olivier Tilloy ]
  * Fix build with newer versions of cargo, which ignore local configuration
    (see https://github.com/rust-lang/cargo/issues/6397)
    - update debian/build/rules.mk
  * Re-enable and update debian/patches/unity-menubar.patch

  [ Rico Tzschichholz ]
  * Drop upstreamed patches
    - remove debian/patches/fix-pixman-build-ppc64el.patch
    - remove debian/patches/extra-webrtc-build-configs.patch
    - remove debian/patches/update-gn-mozbuild.patch
  * Update patches
    - debian/patches/rust-drop-dll-checksums.patch
    - debian/patches/webrtc-fix-compiler-flags-for-armhf.patch
    - debian/patches/fix-armhf-webrtc-build.patch
    - debian/patches/no-region-overrides-for-google-search.patch
    - debian/patches/ppc-no-static-sizes.patch
    - debian/patches/ubuntu-ua-string-changes.patch
  * Bump build-dep on rustc >= 1.30.0 and cargo >= 0.31
  * Use amazon-in override for "gu-IN", "mai", "ml", "pa-IN", "ta"
    - update debian/config/searchplugins.conf
  * Revert parts of google search update
    - add debian/patches/partially-revert-google-search-update.patch
  * Build with --enable-rust-simd (LP: #1808980) (except on i386 and armhf)
    - update debian/config/mozconfig.in
  * Update cbindgen to 0.6.8
    - debian/build/create-tarball.py

 -- Olivier Tilloy <email address hidden> Mon, 28 Jan 2019 18:11:08 +0100

Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
Olivier Tilloy (osomon) wrote :

Not fixed yet.

Changed in firefox (Ubuntu):
status: Fix Released → Confirmed
Olivier Tilloy (osomon) wrote :

thunderbird (1:60.6.0+build2-0ubuntu1) disco; urgency=medium

  * New upstream stable release (60.6.0build2)

  [ Olivier Tilloy ]
  * Bump build-dep to clang-7 and llvm-7-dev
    - debian/config/mozconfig.in
    - debian/control{,.in}

  [ Rico Tzschichholz ]
  * Add patches to fix build on s390x:
    - debian/patches/s390x-ycbcr.patch
    - debian/patches/skia-big-endian.patch

 -- Olivier Tilloy <email address hidden> Fri, 15 Mar 2019 21:45:30 +0100

Changed in thunderbird (Ubuntu):
status: Confirmed → Fix Released
Olivier Tilloy (osomon) wrote :

firefox (66.0+build2-0ubuntu1) disco; urgency=medium

  * New upstream stable release (66.0build2)

  [ Olivier Tilloy ]
  * Re-enable and update debian/patches/unity-menubar.patch
  * Disable unaligned FP accesses emulation on armhf:
    - armhf-disable-unaligned-fp-access-emulation.patch
  * Update build arguments for upstream change that splits the Google
    key management between location services and safe browsing
    (https://bugzilla.mozilla.org/show_bug.cgi?id=1531176):
    - debian/config/mozconfig.in
  * Reduce linker memory usage on armhf:
    - debian/patches/armhf-reduce-linker-memory-use.patch

  [ Rico Tzschichholz ]
  * Bump build-dep to clang-7 and llvm-7-dev
    - debian/config/mozconfig.in
    - debian/control{,.in}
  * Add build-dep on nasm (>= 2.13.02)
    - debian/control{,.in}
  * Bump build-dep on rustc >= 1.31.0 and cargo >= 0.32
  * Update cbindgen to 0.7.1
    - debian/build/create-tarball.py
  * Fix arm64 build
    - debian/patches/revert-1fce91651f43.patch
  * Update patches
    - debian/patches/reduce-rust-debuginfo-on-selected-architectures.patch
    - debian/patches/ppc-no-static-sizes.patch
    - debian/patches/partially-revert-google-search-update.patch
  * Drop upstreamed patches
    - remove debian/patches/dont-treat-tilde-as-special.patch

 -- Olivier Tilloy <email address hidden> Thu, 14 Mar 2019 17:47:23 +0100

Changed in firefox (Ubuntu):
assignee: Olivier Tilloy (osomon) → Rico Tzschichholz (ricotz)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.