firefox windows are black in Ubuntu 18.10

Bug #1798999 reported by Chronon on 2018-10-20
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Critical
Chris Coulson

Bug Description

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu
    Description: Ubuntu 18.10
    Release: 18.10

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center

firefox:
  Installed: 63.0+build1-0ubuntu1
  Candidate: 63.0+build1-0ubuntu1
  Version table:
 *** 63.0+build1-0ubuntu1 500
        500 http://ubuntu.osuosl.org/ubuntu cosmic/main amd64 Packages
        100 /var/lib/dpkg/status

3) What you expected to happen
Normal web browsing experience

4) What happened instead
Graphical elements are black. After upgrading to 18.10, firefox graphical elements (window contents, context menus) are black. The only exception is a small rectangle in the upper left corner.

Right-clicking within the window creates a context menu, which I am able to verify by observing a new black rectangle of the correct width that can be made to occlude the task bar by initiating it at a suitable starting position.

If I launch firefox from a terminal then I get messages like the following:

--------code

[GFX1-]: Failed to lock new back buffer.
[Parent 25238, Main Thread] WARNING: failed to open shm: Permission denied: file /build/firefox-MtV3KQ/firefox-63.0+build1/ipc/chromium/src/base/shared_memory_posix.cc, line 129

--------/code

This occurs regardless of which desktop environment I use. Other browsers are working fine.

I'm guessing the problem is related to the reported problem accessing shm. However, for the sake of completeness, I am using an AMD gpu with standard driver:

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT / Trinidad XT [Radeon R7 370 / R9 270X/370X] [1002:6810]

Chronon (gopindra) on 2018-10-20
summary: - irefox windows are black in Ubuntu 18.10
+ firefox windows are black in Ubuntu 18.10
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Gaele Strootman (gaele) wrote :

Same here, using an Nvidia gpu with nouveau.

Gaele Strootman (gaele) wrote :

Adding
user_pref("layers.acceleration.disabled", true);
to prefs.js did not make any difference.

Gaele Strootman (gaele) wrote :

GPU is GeForce GT 750M Mac Edition

Scott M (sgmaurin) wrote :

Happening to me also. Intel graphics. I've removed everything and reinstalled it. Same.
But the Firefox Snap works fine. So do Chromium and Opera.
Only since the upgrade to 18.10 64bit

----code

[GFX1-]: Failed to lock new back buffer.
[Parent 2199, Main Thread] WARNING: failed to open shm: Permission denied: file /build/firefox-MtV3KQ/firefox-63.0+build1/ipc/chromium/src/base/shared_memory_posix.cc, line 129

----/code

Olivier Tilloy (osomon) wrote :

To everyone affected:

Can you try running the following command in a terminal to temporarily unload the firefox apparmor profile, then launch firefox and comment here on whether this improves the situtation?

    sudo apparmor_parser -R /etc/apparmor.d/usr.bin.firefox

Thanks in advance!

Changed in firefox (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Olivier Tilloy (osomon)
Gaele Strootman (gaele) wrote :

Yes, Firefox is working again now. No more black windows.

Olivier Tilloy (osomon) wrote :

Thanks for the feedback Gaele. The apparmor profile should be disabled by default, I wonder if something enabled it behind your back, or do you remember if you did that intentionally?

Scott M (sgmaurin) wrote :

Yes, that also worked for me. I never enabled it myself, so something may have went awry during the upgrade. I didn't do a clean install if that helps.

Gaele Strootman (gaele) wrote :

I didn't enable the apparmor profile either, and I haven't done a clean install in ages.

BTW I just read https://help.ubuntu.com/lts/serverguide/apparmor.html and learned that you need to do

  sudo ln -s /etc/apparmor.d/usr.bin.firefox /etc/apparmor.d/disable/

to keep the firefox profile disabled (otherwise it will reappear after a reboot).

Olivier Tilloy (osomon) wrote :

Indeed, to have the firefox apparmor profile permanently disabled you need to create a symlink to the profile itself in /etc/apparmor.d/disable/.

I wonder what possibly removed that symlink on upgrade. Can you confirm that this started happening right after upgrading to 18.10 ?

Gaele Strootman (gaele) wrote :

Yes, right after the upgrade.

Scott M (sgmaurin) wrote :

Yes, right after the upgrade here too.

Chronon (gopindra) wrote :

Yes, this also fixed the problem with black windows for me. The problem began immediately after upgrade from 18.04.

Olivier Tilloy (osomon) wrote :

I upgraded a fully up-to-date 18.04 VM to 18.10 (firefox was upgraded from 62.0.3+build1-0ubuntu0.18.04.1 to 63.0+build1-0ubuntu1) and the symlink to the apparmor profile in /etc/apparmor.d/disable/ remained in place.

To everyone originally affected: can you please share the following file: /var/log/dist-upgrade/history.log ?

Gaele Strootman (gaele) wrote :
Chronon (gopindra) wrote :

/var/log/dist-upgrade/history.log

Michael Weimann (m982) wrote :

For me the issue also appeared for a none updated version of 18.10 (installing 18.10 directly).

Michael Weimann (m982) wrote :

The suggested command

    sudo apparmor_parser -R /etc/apparmor.d/usr.bin.firefox

doesn't work for me :/
The profile is already disabled but Firefox still doesn't work.

I get many errors like:
Unable to init server: Could not connect: Connection refu###!!! [Parent][MessageChannel] Error: (msgtype=0x30000B,name=PContent::Msg_InitRendering) Channel error: cannot send/recvsed
(/usr/lib/firefox/firefox:7325): Gtk-WARNING **: 09:24:47.539: cannot open display: :1
[Parent 7238, Gecko_IOThread] WARNING: pipe error: Broken pipe: file /build/firefox-MtV3KQ/firefox-63.0+build1/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 729

Chronon (gopindra) wrote :

I just had an update come through for firefox and I am no longer seeing the behavior that I initially reported. I still don't have a symlink in /etc/apparmor.d/disable/.

However, firefox appears to be functioning normally and I'm not getting the warnings about failing to lock the back buffer, etc.

Olivier Tilloy (osomon) wrote :

Thanks for the confirmation Chronon.
This was fixed by https://bazaar.launchpad.net/~mozillateam/firefox/firefox.cosmic/revision/1231 and released to all supported series.

Changed in firefox (Ubuntu):
assignee: Olivier Tilloy (osomon) → Chris Coulson (chrisccoulson)
status: Confirmed → Fix Released
Gaele Strootman (gaele) wrote :

Thank you Olivier.

Chronon (gopindra) wrote :

Thank you for the information, Olivier.

Scott M (sgmaurin) wrote :

Thanks Olivier.
A little lagniappe for me. My Enpass plugin had quit working about 6 months ago. Tried a bunch of stuff but could never get it to work. It's working now!

Michael Weimann (m982) wrote :

For me Firefox still doesn't work. I'm getting version 63.0+build2-0ubuntu0.18.10.2 .
My Firefox windows aren't black, they're white.

Chronon (gopindra) wrote :

@Michael It appears that you are suffering from a different problem. If you're still having problems you can open your own bug report (or post on an existing one that matches your problem).

Michael Weimann (m982) wrote :

@Chronon thanks for your reply. My report has been closed as duplicate: https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1799483 :(

Linda (elindarie) wrote :

Similar thing happened to me in Ubuntu 18.04. Today is the first day of my installation of 18.04. At first Firefox worked fine. Then I was tweaking a few things after the system upgrade to 18.04, and added the date to the top menu bar / task bar by typing "sudo gsettings set org.gnome.desktop.interface clock-show-date true" in the terminal window at the bash prompt. It didn't show the date, so I rebooted, and then it showed the date. Then I clicked on Firefox. And it was not a black screen, not a white screen, but a clear screen. That is, a transparent screen.

"sudo apparmor_parser -R /etc/apparmor.d/usr.bin.firefox" fixed it for me.

Thank you Olivier Tilloy (osomon) !

I have edited /etc/apparmor.d/usr.bin.firefox in the past when Firefox gave a black screen, after updating to Firefox version 51.0.1 two years ago. What fixed it the black screen then is described here:

  https://bugzilla.mozilla.org/show_bug.cgi?id=1334748#c7

but now my copy of usr.bin.firefox is the same as usr.bin.firefox.dpkg-dist

which I think means it's the same as the current distribution file, although I'm not sure, so I don't know what's going on or why this happened.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.